Jump to content

Can't see selected pattern in Step Sequencer and Deleting when editing


Shisko
 Share

Recommended Posts

I have a pretty troubling situation here. When I select a region in my drum track and go to the editor my pattern doesn't appear in the step sequencer. I hear the part playing and I see the pattern in the tracks window, but the sequencer doesn't reflect my work at all. So I tried to see if I could edit it in the sequencer all the same, and when I added a block THE PATTERN WAS DELETED. I hit undo but the pattern was gone and I can't get it back. I'm using Drum Machine Designer and I created all these patterns from scratch. Also, when I opened the session, the drum regions were all just orange; they didn't look like they had pattern in them. But when I select them in the track window they look normal, just not in the editor. I know that the link button needs to be selected to see the selected region in the piano roll, but there's no link button for the sequencer. And if there were, that wouldn't explain the patterns deleting when I try to edit them, would it? I worked on this song last night and didn't notice any problems. I'm concerned about continuing, but I need to make some progress. Argh. Please help.
Link to comment
Share on other sites

Thanks, David. But no. All my patterns were either 32 or 64 steps long, but when I hit the editor it shows a blank 16 step pattern. And I'm really concerned because I checked another song that I haven't even touched for a couple days and it has the same problem. When I opened it the drums were just a solid orange block and the patterns don't show up.
Link to comment
Share on other sites

I can convert the patterns to midi regions and see the notes for everything and I can edit them without any problems. So the material is there, but it's entirely disconnected to the step sequencer now. Any insights into this is greatly appreciated. I can work on the affected regions in piano roll, but this is going slow work down and be a big problem if it happens again and I can't figure out how to stop it or get it back.
Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...