Jump to content

LPX 8 second lag GUI


Recommended Posts

Hey all. I am experiencing a terrible lag with the GUI in Logic 10.5.1 that I cant seem to resolve.


In normal projects, once I attempt to do pretty much anything - level meters will lag behind, the transport timer will jump milliseconds, etc..


Even upon creating a new project (no template) - it is taking forever to load, and when it finally does I am experiencing 7-9 second delay when attempting to click on a different track.


Everything seemed to be fine (expected latency issues with plugins on heavy projects) two days ago. Only change between then was a cleaner app (Disk Doctor) that deleted

-Application Caches

-Application Logs

-Browser Data


I cant see the clean causing these problems as I've done this before.

However if there is something I am missing if anybody could PLEASE enlighten me or suggest any ways to resolve this issues it will be GREATLY appreciated.





Macbook Pro 15" 2019

2.6Ghz 6 Core Intel Core i7

16GB 2400 MHz DDR4

Intel UHD Graphics 630 1536 MB

Currently running Catalina 10.15.6

Link to comment
Share on other sites

I have had to do that in the past, and funny you say that - I was attempting to connect my SSD (Samsung T7) with the USB-C -> USB-C cable, and I would receive a prompt saying it was using too much power (or something to that extent, I cant remember the exact message) BUT it would work when connecting a dongle for a USB 3.0 -> USB-C


In the past I had a similar issue where I did a SMC reset and it restored capability on my port.


What I dont understand is the lag in LPX (exclusively) having to do with the Thunderbolt ports..

Link to comment
Share on other sites

I was attempting to connect my SSD (Samsung T7) with the USB-C -> USB-C cable, and I would receive a prompt saying it was using too much power


Somebody on the forum a while back said that it mattered on which side of the laptop he plugged his TB3 cables.


Lags are usually related to the computer or app trying to connect somewhere, either a port or online. Do you use any online service with Logic, or iCloud?

Link to comment
Share on other sites

I've tried plugging the SSD in on either side of the laptop using the TB3 cable to no avail. (recieving "too much power prompt")

However, if plugged into dongle with USB it works fine, maybe at lower speed because of the cable?


And I usually have any internet browsers and iCloud off when working. But even if I had had them open in the past I never experienced lag like this.

Link to comment
Share on other sites

Still suffering.


I've tried TM backups, install/reinstall, SMC reset, install/reinstall LPX.




Nothing else on my computer shows any signs of corruption or lag.




It feels like LPX (if it runs) is trying to run something it cant find. Every task I attempt seems to take absolutely forever and most of the time it will just bounce up and down eternally off of the app bar.




If anyone can provide certain files I should be able to locate that may have been deleted in the "Disk Doctor" app it will be greatly appreciated.


Or any info leading to the resolve of this issue.




- Matt

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...