Jump to content

Merged midi makes regions sound quieter


Recommended Posts

This is weird. I have a midi region recorded. Cycle is on but I'm capturing midi after I play to build a track section by section, not using cycle or loop recording.


When I have the Recording prefs set so that Overlapping Midi when Cycle On recording is set to Merge, after I capture the new section of midi, the previous and new regions merge as expected but now the midi is playing back softer for both sections. I haven't changed any input defaults and both regions have the same settings. When I undo, the new region disappears and the previous region plays back loud as expected.


If I set the Midi recording prefs to Merge Current Recording Only, the regions don't merge..as expected because I'm not using the record command, just capturing...and now the new and old midi regions play loud as expected. So something about merging regions is causing the playback to change. Also the midi velocities look the same, just the sound is changing.

Link to comment
Share on other sites

Nothing else is being recorded. It's a very consistent issue and only occurs when I have Recording Prefs/Midi Cycle On/set to Merge. I'm playing the midi overdub and using capture to record it, not using record button.

The attached session has four elements with a midi export and mp3 of each element.

1 I recorded a section before the overdub

2 I recored an overdub with the recording pref set to Merge

3 I recorded the overdub with recording pref set to Merge Current Recording which left it unmerged

4 I manually merged it


I opened these elements in a new session and the midi export is identical each time, but you can clearly hear that the mp3 made when the auto merge was enabled is much lower sounding velocities. Nothing is being changed in my incoming midi defaults either. It's just like it's not playing back correctly after it's been merged even though it's not displaying anything different and the midi velocities are staying consistent.

Auto Merge issue.zip

Link to comment
Share on other sites

Ok I found the issue. I have my input midi default velocity set to +20. If the two recordings don't overlap, there's no issue...each region in the inspector shows the +20 velocity. But if the regions do overlap, then after they are merged the inspector velocity gets reset to 0. So that's why only the overlapped regions are doing this. Is this how Logic is supposed to work? It seems like if the input default is the same in both regions, then after the merge they should still have this setting intact.
Link to comment
Share on other sites

I still thing something is wrong here because If I record the two passes each with the input velocity at +20 and then manually merge them, the new combined region still has the velocity in the inspector at +20. It's only when Logic is automatically merging them that the reset is happening.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...