Jump to content

Control Surfaces / Logic Pro X 'sees' but does not cooperate

Ken Nielsen
Go to solution Solved by Ken Nielsen,

Recommended Posts

I have a PreSonus Faderport Production Control Center, as it is called, plugged in and powered up. Logic Pro X acknowledges that 'something' is detected when I press any button on the control device, one small 'blip' comes up on the top bar of the Logic Pro X screen at each touch of any button. But in Preferences under 'Control Surfaces' there is nothing recognized or available as it is an empty screen. While I think working with keyboard commands is fine, this device could make recording easier with less thought to set-up and more about music. Does anyone here use these control surfaces and how do you make Logic Pro X 'fully' aware of the device?





Link to comment
Share on other sites

  • Solution
I have a PreSonus Faderport Production Control Center


I'm on track with getting this working now and don't know how to delete this thread but Thanks to all who are helping me so I can shut up and quit asking simple questions... getting closer to that goal now. Found Software update online is what I needed for this.

Link to comment
Share on other sites

In the Control Surfaces setup window, is there an icon displayed for the Faderport?


If so, when you select the icon for it by clicking on it, are it's parameters shown on the left side (make sure the inspector is showing if not from the menu in the window).


Good. I'm onto it now, updated software was needed and got that installed and should be getting this working now. Thanks des99, much appreciation for your help here.

Link to comment
Share on other sites



Grr... I spend more time fiddling when I should be playing... Still no recognition of the PreSonus control... Installed latest software all plugged in and Logic Pro X recognizes that something is there as a little blip goes on at the top of the screen when I hit any control on the controller, but no response for anything useful getting done and in Preferences no control surface is showing up. Restarted computer after installing... Maybe I should dump this thing in the trash and go back to just using wireless computer keyboard...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...