Jump to content

The focused view does not support this command


Woodland Hills
 Share

Go to solution Solved by David Nahmani,

Recommended Posts

  • 5 months later...

Hi, There.

 

I just got this error, and I've read the thread and David's reply.

 

I'm not sure that I follow the logic of this error, but the flashing screen happened when I used the Cmd-Tab command to switch from Logic to Safari. When I did this, that's when the screen started freaking out. Switching back got rid of the flashing. Upon reading David's reply, I took note of the bleu frame, which was highlighted on the opened Library, which also was the state while using Logic Remote. Once I clicked on the Main Window, the frame went away, and now switching to Safari and Logic acts normally again.

 

But again, I'm not quite following why, or even if this should, be happening....the flashing screen, that is.

Link to comment
Share on other sites

  • 11 months later...

Hi

 

I am new to this website

I have this issue now with my logic x and safari it hits up like the previous guys before

however I am not unable to get this fixed

can you maybe please provide me in details of steps screenshot where I exactly have to find those buttons

to make this message disappear please

 

thank you

Link to comment
Share on other sites

  • 5 months later...

I have been having this problem too (and banging on about it another thread). I was trying to use my iphone for Logic remote and getting the constant message

Command not available because the focused view does not support this command.

So I bought an ipad instead. And it's still happenning. This is beginning to be less than humorous. Any ideas anyone?

Link to comment
Share on other sites

  • 2 weeks later...

Apologies for not replying sooner. Well I did, but my reply seems to have disappeared. The gist was that I have tried the various approaches to key focus, including there being none at all when there is just the main window open. As to the command i am trying to use, that doesn't really come into it because the error messages start up before I have done anything except switch on.

The breaking news though is that the problem has fixed itself. Logic remote on the ipad AND the iphone are working fine, so the problem, whatever it was, seems to have been with Logic pro itself, but I can't imagine what I had switched on, or off, that I shouldn't have. All part of the wacky digital world.

Edited by stobartagmail.com
typo
  • Like 1
Link to comment
Share on other sites

  • 2 months later...

 

Upgraded to Logic 10.7.5 and I'm getting this same 'Command not available because the focused view does not support this command'

Hi David,

I recently installed a fresh install of Monterey 12.6.1 and a fresh install of logic pro 10.7.5 on a new M1 Macbook Pro.

As you can see from the video below (see dropbox link) when I open Logic Pro I get this continuous error "command not available because the focus of you does not support this command".

When I click on the 'SHOW' button a pop-up comes up and says: 
'Command not available because the focused view does not support this command'

When I am playing the DAW session the curser or slicing the audio files into a million little slices. Super annoying. And after this happens I try to use the RESIZE POINTER to pull out the original audio file and cover over the sliced regions and it doesn't allow me to do this. I also can't select any REGIONS. They highlight and then go back to unhighlighted. I basically can't edit anything.

What is going on here? Is this a known problem? I need some help to get this sorted.

I reset all the Key Commands to factory settings.

Short Video of problem in action:
https://www.dropbox.com/s/zkdioc54wa1i315/IMG_4407.MOV?dl=0

Thank You

 

Screen Shot 2022-11-29 at 11.38.35 AM.png

Screen Shot 2022-11-29 at 11.38.40 AM.png

Screen Shot 2022-11-29 at 12.25.42 PM.png

Edited by FluorescentLife
Link to comment
Share on other sites

5 hours ago, FluorescentLife said:

Ok switched off Control Surfaces. Things have improved. Seems to be working pretty good at the moment.

What did that do?

It makes sure you don't have a device that sends data that is assigned to a key command in Logic Pro. Do you have any MIDI devices connected to your Mac?  

Link to comment
Share on other sites

  • 3 weeks later...

Hi. I had the same issue

'Command not available because the focused view does not support this command'

It was fixed (the flashing on the screen stopped) when I disconnected and reconnected all the MIDI control devices. Hope this helps others.

Best!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...