Jump to content

"PDF Page" inserted as mapping instead of bypass


spride
 Share

Go to solution Solved by GMan111,

Recommended Posts

I have tried this with two different control surfaces now, with the same result.

 

I have two Channel Strips assigned to the same volume fader in - in this case - a Korg NanoControl 2.

I wish to switch between them. Previously I would add a second mapping for the button, map both mappings to Mute at the Channel Strip level, and then ensure that Button On for #1 was Mute and Off was unmuted, and vice versa for #2. Button is set to an unused CC. This still works.

 

In the interests of CPU efficiency I decided to change the behavior from Channel Strip -> Mute to Channel Strip -> Instrument -> Bypass. When I do this, the mapping for instrument #1 is accepted but when I try to repeat this for #2, selecting Bypass in the Instrument puts the legend "PDF Page" in the mapping tab instead of "Bypass".

 

The instrument in question is Aruria's Mini V. I haven't yet tested with other instruments to see if it's the same.

 

Is anyone else seeing this or able to reproduce it?

 

PDF-issue.thumb.jpg.f5ea40b6d43f7b45984e00509e8e1afe.jpg

Link to comment
Share on other sites

  • 2 weeks later...

I get the same "PDF Page"

Software: Mainstage

Mapping parameters for Loopback plugin.

Tested on:

- NanoKONTROL2

- KeithMcMillen 12 STEP control pedal.

 

I don't get "PDF Page" if I use the "Map Parameter" button.

However, if I assign through folder links, the "PDF page" pops up. I noticed that further changes made cannot be saved after "PDF page" issue.

 

Still working on it... Sorry I cannot be of more help.

Link to comment
Share on other sites

  • 2 months later...

Have you had any luck in solving this?

'Pdf page' comes up in mappings when I try to assign the KL88 mod wheel to the attack in ES2.

The mod wheel then ceases to be recognised by MS, and the Screen control Inspector bumps me back to the first page ...

It seems to be the case whenever I try to control a specific parameter in the chosen software instrument, but not if its just a standard volume/expression etc command.

Cheers

Link to comment
Share on other sites

I seemed to solve the problem yesterday in a series of "cleanups" that I made at the concert level and within each patch. I noticed that I had lots of "sub" channels (like a dozen) that somehow accumulated over adding more patches. I deleted them all (my setup doesn't have to have so many subs). After that, assigning a real function to a knob or button just worked. Hope that helps
Link to comment
Share on other sites

  • 4 weeks later...

Hi all,

I've created an 8 track looper: for every track there is an aux channel with a "Looper" plugin. Then, in the actual patch, there is one audio channel for each aux channel.

I've also created some buttons to fire Looper functionalities. For seven of those tracks, the mapping works nicely. For one of them (the number 7) whenever I try to map a button to a Looper function, I get the "PDF Page". Moreover, whenever I change something in this track (number 7), MainStage fails to save the project, and I have to manually close it.

I've also tried to delete all the buttons/controls and the channels for that track, recreating them again manually, but always with the same result. Is there any way to "manually" edit the concert and/or to see what is hidden that may lead to such issue ?

 

Thanks!

Link to comment
Share on other sites

  • 4 weeks later...

I recently got this issue too. After hours of trying to isolate what the issue is, I found that the issue was isolated when I tried to map anything on specific channel strips. A workaround I did that solved this issue is to move the channel strip (drag and drop) to a different location, effectively changing the order in the channel strips. After doing this, that strip worked for anything I wanted to map on it.

 

I am running latest version of OSX, Big Sur 11.3.1 and running latest Mainstage 3.5.2. None of the other workarounds mentioned here worked for me, so hopefully this helps!

Link to comment
Share on other sites

  • 1 month later...

I can confirm vypercat's fix worked for me.

 

In fact, with the channel strip in a new location it worked, and when I moved the channel strip back to where it had been I got the PDF page error again.

 

I really appreciate the solution - it was driving me nuts!

Link to comment
Share on other sites

  • 10 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...