Jump to content

Recording automation into a Live Loops audio cell?


colinb
 Share

Recommended Posts

Has anyone had any luck recording automation for a live loops audio cell?

 

The exact situation is that I am trying to record a guitar loop that uses a software volume pedal—the pedal steel bend and swell sound. I have a midi expression pedal mapped to an automation parameter in a BiasFX2 plugin. The automation records as expected when I am playing or recording to a track, but not when recording to a live loops cell, even when the automation is set to region rather than track.

 

This is for a live performance setting, so I need to be able to record the audio and the automation (midi) into the cell at the same time without additional futzing with the computer. Seems pretty straightforward, but my googling has not been productive.

 

I'd be grateful if anyone could point me in the right direction.

Link to comment
Share on other sites

Just a hunch: have you tried recording actual CC events as automation instead of Fader events?

 

Thanks! Is it possible to do that for an Audio region? I can see how it works for a Midi region, but I don't see where it goes in an audio region.

Link to comment
Share on other sites

  • 3 months later...

Ok I just searched for this exact issue. So it's not possible to record automation (eg playing with a plugin parameter) in cells. You have to record the cell then do it manually afterwards?

 

This seems like a huge oversight and surely something that Apple are looking to fix for a future version, but I've no idea how to find this out. I could make a feature request but it would be nice to know if this is already being worked on..

Edited by mikerolls
Link to comment
Share on other sites

Ok I just searched for this exact issue. So it's not possible to record automation (eg playing with a plugin parameter) in cells. You have to record the cell then do it manually afterwards?

 

This seems like a huge oversight and surely something that Apple are looking to fix for a future version, but I've no idea how to find this out. I could make a feature request but it would be nice to know if this is already being worked on..

Yea I've looked into this previously myself and was a but disappointed to come to the same conclusion.

Link to comment
Share on other sites

  • 1 year later...
21 hours ago, hollandrisley said:

Well that sucks! Not being able to record automation into a live loop!! Is this actually true?

No it isn't. All you have to do is enable this in the Automation Mode menu of software instrument tracks image.png.f7d18c2fcae84619f8c172e919664fbb.png or this (audio tracks) image.png.cb4fc989f82c077025a80156d186e162.pngand put the track into Read mode. Now all incoming automation will be recorded with the region.

Link to comment
Share on other sites

On 9/26/2022 at 7:43 PM, hollandrisley said:

Well that sucks! Not being able to record automation into a live loop!! Is this actually true?

As mentioned by @David Nahmani , one has to record in the linear track and then drag the region to the desired cell.

As hinted by @polanoid, enabling Record Automation with MIDI Regions (for a MIDI or software instrument track) or Record Automation with Audio Regions (for audio track), the automation (either fader or CC) will be included in the recorded region (being MIDI or audio) on the linear track. Providing also that you set the automation destination to Region aka RBA (not Track/TBA); although one could be converted TBA into RBA (and vice-versa).

 

Link to comment
Share on other sites

1 hour ago, Atlas007 said:

Providing also that you set the automation destination to Region aka RBA (not Track/TBA)

That's plain wrong. With "Record Automation with MIDI/Audio Regions" checked, the automation is recorded into the region no matter if you have set the track to display RBA or TBA. The key is to be in Read (not Touch/Write/Latch) mode.

  • Like 1
Link to comment
Share on other sites

1 hour ago, Atlas007 said:

enabling Record Automation with MIDI Regions (for a MIDI or software instrument track) or Record Automation with Audio Regions (for audio track), the automation (either fader or CC) will be included in the recorded region (being MIDI or audio) on the linear track

That's at least misleading. When Record Automation with MIDI/Audio Regions is ON, this automation will also be recorded into Live Loops Cells! Could you please at least try these things before stating them here? 

Link to comment
Share on other sites

9 hours ago, Atlas007 said:

As mentioned by @David Nahmani , one has to record in the linear track and then drag the region to the desired cell.

As hinted by @polanoid, enabling Record Automation with MIDI Regions (for a MIDI or software instrument track) or Record Automation with Audio Regions (for audio track), the automation (either fader or CC) will be included in the recorded region (being MIDI or audio) on the linear track. Providing also that you set the automation destination to Region aka RBA (not Track/TBA); although one could be converted TBA into RBA (and vice-versa).

Thank you for your input. To try and summarise here, my understanding is that you cannot record automation over the top of an existing audio file within a Live Loop cell, but you can record automation at the time of recording.

To add automation later you need to record into the Track view on the right hand side, and record the automation performance using standard Write control.

I have tried this and automation does record into the track view, but when I drag the region with automation recorded into it, then automation doesn't then go back into the cell along with the audio clip.

Is it supposed to work like that? Do I need to Bounce in place first then drag the region into a new cell or should the automation move back into the Cell from the Track view?

Link to comment
Share on other sites

Just now, hollandrisley said:

you cannot record automation over the top of an existing audio file within a Live Loop cell, but you can record automation at the time of recording.

Yes, that is correct. 

1 minute ago, hollandrisley said:

To add automation later you need to record into the Track view on the right hand side, and record the automation performance using standard Write control.

I have tried this and automation does record into the track view, but when I drag the region with automation recorded into it, then automation doesn't then go back into the cell along with the audio clip.

Make sure you record Region automation, not Track automation. It will then work, no need to bounce in place.

Link to comment
Share on other sites

5 minutes ago, hollandrisley said:

I have tried this and automation does record into the track view, but when I drag the region with automation recorded into it, then automation doesn't then go back into the cell along with the audio clip.

In that case you need to write region automation, not track automation.

EDIT: David was faster than me. 

Edited by polanoid
  • Like 1
Link to comment
Share on other sites

5 minutes ago, David Nahmani said:

Make sure you record Region automation, not Track automation. It will then work, no need to bounce in place.

In case you did write Track Automation and don't want to write it again, you can convert it to Region Automation by 

1) Selecting the Region you want to have the Track Automation moved to and then

2) using this command 

 

Screenshot 2022-09-28 at 15.14.09.png

  • Like 1
Link to comment
Share on other sites

27 minutes ago, polanoid said:

In that case you need to write region automation, not track automation.

EDIT: David was faster than me. 

 

21 minutes ago, polanoid said:

In case you did write Track Automation and don't want to write it again, you can convert it to Region Automation by 

1) Selecting the Region you want to have the Track Automation moved to and then

2) using this command 

Screenshot 2022-09-28 at 15.14.09.png

As mentioned above...

Link to comment
Share on other sites

Just now, Atlas007 said:

As mentioned above...

Yes, the idea is that you need to do that only when you record automation into an existing audio region, but you don't need to do it when recording automation and audio at the same time. 

I suppose that is the entire source of the different experiences you and polanoid were having. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...