Jump to content

Clipping / Skipping While Recording


Recommended Posts

First off, I am just getting started with Logic Pro X (10.4.0). I am currently just trying to record vocals and so only have one track dedicated to vocals. My problem is the recording has randoms clicks and skips. It is almost like the recording stops recording for a milisecond here and there and so the recording is missing words. I have watched the "recording line" during recording and it is smooth and slow and doesn't stop or skip.


I have tried recording multiple times and it is happening with every take. I have tried: 1. adjusting the i/o buffer speed from 32 up to 512 and it still happens, 2. restarting the computer 3. Creating new logic session 4. Monitored CPU meter during the clips/skips and getting almost no elevation in the meter


-LapTop Specs: Mac Book Pro 2012, 2.3 GHz Quad-Core Intel Core i7, 8 GB 1600 MHz DDR3, Intel HD Graphics 4000 1536 MB

-Using Presonus Audiobox USB 96 with Rode NT1a mic


I really appreciate the help!

Link to comment
Share on other sites

Ok so that machine should handle a simple vocal recording without any issues, so let's start running some tests.


The first one I would try is to disconnect the Presonus from the Mac. In Logic's audio preferences, set your devices to built-in microphone and connect headphones to your Mac. Now try to do a vocal recording with your Mac's built-in microphone. Do you have the same issue?

Link to comment
Share on other sites

Hey David, thanks for the help, I really appreciate it! So I tried 2 things. I updated Logic Pro and that didn't solve the issue when still using my presonus and mic. I then did what you suggested and unplugged the prosonus and then plugged in my apple headphones/ mic that came with my iphone into to my laptop. I did two test recordings and neither had the issues that I previously had. So what does this mean?
Link to comment
Share on other sites

Hey @triplets thanks for the help. So I did another test recording using the built in mic, not the iphone headphones, and again there was no issue with the recording. So it looks like it's the presonus/mic combo? Or maybe my Mac's ability to handle the combo? How do I further diagnose the issue?
Link to comment
Share on other sites

  • 3 months later...

I am having the exact same problem! I can't remember everything that I have tried in order to fix it ,but I will try to list all that I can remember.

I have tried: 1. adjusting the i/o buffer speed 2. restarting the computer 3. Creating new logic session 4. Monitored CPU 5. Changing the resolution of the Logic screen 6. Resetting PRAM/NVRAM 7. Using different microphones ( phantom powered and not) 8. Using different cables (usb and xlr) 9. Buying the next generation of the interface I've been using, so using Scarlett 2i2 Gen 2 and a new Scarlett 2i2 Gen 3 (where you can check the internal clock of the interface and there was nothing wrong with the clock) 10. Changing the outlets that the computer was plugged into.

I have uploaded a small sample of the glitchy audio that results from this problem. While I am recording I can hear a high pitched noise that is not captured on the track.

audio sample of problem:

I have tried other things but this is everything I can remember that I have tried in the last 6 months of troubleshooting this problem. Any help would be so greatly appreciated! I've taken it to a few stores that work on computers and that sell audio equipment and they said they have never seen anything like this.


-LapTop Specs: Mac Book Pro 2015, 2.3 GHz Dual-Core Intel Core i5, 8 GB 1867 MHz DDR3, Intel Iris Graphics 6100 1536 MB

-Using Scarlett Focusrite 2i2 3rd Gen USB interface with Shure KSM 32 mic (have also tried it with Scarlett 2i2 2nd generation and Beta 57 )

Link to comment
Share on other sites

Hi JakobP, Thanks for your reply.

- Yes that was from a new empty project.

- It was a one track session with no other audio apps running. The microphone was recording audio from a phone.

- I'm using Logic 10.6.0

- I have tried recording using the built in audio and like gwick2400 i did not have this audio problem. It's only using the interface and microphone. But I can't record the quality of audio that I need to with my built in microphone. I'm wondering if a Presonus and a Scarlett Focusrite are part of the problem, then what can be done in order to use these usb interfaces to record in Logic?

Link to comment
Share on other sites

Hi JakobP, yes I've installed and run Focusrite Control, which works with the 3rd gen Scarlett.


I have checked for and deleted old drivers. The only driver I've ever downloaded was the Black Hole audio driver (https://existential.audio/blackhole/) and I went through the steps to fully delete that. Although after Finder>Go> I'm really just following instructions. But, I can't find any traces of Black Hole on my computer, to my knowledge.


I have created another user account and tried recording from there. I still had the same audio problem.


The Focusrite Class Compliant app that was at the bottom of the article above is new to me! (https://support.focusrite.com/hc/en-gb/articles/115002523165-Are-Focusrite-USB-interfaces-Plug-and-Play-on-Mac-) It appears to have been updated since the first time I referenced this article about 4-6 months ago. I have downloaded the Class Compliant app and restarted the computer. I will make a recording in the next few days and see if it makes a difference. Here is hoping!

Link to comment
Share on other sites

I tried another test and the class compliant seems to have helped, but there is still skipping when I record audio. You can hear it here at about 6 seconds:



This does seem better or at least less frequent but it's still not a fix in my mind, as this problem could still make a take unusable.


I also borrowed a friend's computer and tried using this same configuration with a different computer and this problem doesn't happen. The same microphone and cables with the Scarlett 2i2 3rd gen and here are the computer specs : Logic 10.4.8, Mojave OS 10.14.5, 2012, 2.9 GHz Intel Core i7, 8GB 1600 MHz DDR3, Intel HD graphics 4000 1536 MB.

Link to comment
Share on other sites

Hi all,

Just an update... After JakobP asked if I was using any 3rd party apps, I went through my computer and tried to delete any apps I haven't been using. I deleted all of my Adobe files and apps, as I am not using them and I wondered if their Creative Cloud App might be contributing to my audio problems. I also ran Focusrite's Class Compliant app a few times, just to see if that would help.


Where I am at now is, the skipping while recording audio still happens every few seconds with the Scarlett 2i2 3rd Generation. While the skipping only happens about once a minute with the Scarlett 2i2 2nd Generation. During this extensive testing of the audio I did get this message once "error while trying to synchronize Audio and MIDI." Which I hadn't gotten before.


I'm wondering now if any of my Avid/ProTools apps could be contributing to this problem? Like I said before this same configuration of Scarlett (same usb cables) and Mic (same xlr cables) doesn't cause this same audio problem with other computers and this audio problem doesn't happen when I record with the internal mic. I have appreciated all of the questions and suggestions and they seem to have helped a little bit. Please take your time but if anyone else has any input, I'm down to try anything. Thank you!

Link to comment
Share on other sites

Hi David, I have ProTools, iLok License Manager 3.1.5, and Avid Application Manager 17.8 (I also have the AvidAppManHelper ). None of these open at start up and they aren’t running when I use Logic (when I am getting the skipping.)
Link to comment
Share on other sites

And yes, it says it’s compatible with my OS, which is Catalina 10.15.6.


Any reason you didn't update to 10.15.7?


Also, did you try updating to Logic 10.6.2? (Create a copy of 10.6.0 before you do)



After this comment I updated to macOS Big Sur 11.4 and updated to Logic 10.6.2 (creating a copy of 10.6.0) to see if that would help. I ran the Focusrite Class Compliant app again and did 4 test recordings with the updated OS and Logic 10.6.2 . The updates did not get rid of the sound problem. Each of the tests had some glitching within the 2 minute recording.

Description of 4 test recordings:

1 - Recording for 2 minutes with Focusrite 3rd Generation to an external drive

2 - Recording for 2 minutes with Focusrite 3rd Generation to mac hard drive

3 - Recording for 2 minutes with Focusrite 2rd Generation to an external drive

4 - Recording for 2 minutes with Focusrite 2rd Generation to the mac hard drive

I used the same mic and xlr cable that I have been using for each test. Tests 1 and 2 used the usb cable that goes with the 3rd generation, tests 3 and 4 used the usb cable that goes with the 2nd generation.


Here is what the sound problem sounds like now. It sounds less like a "skipping" forward. It doesn't seem to cut out small sections of the song like before. There is definitely still a sound problem that keeps the audio from being reliable/usable. This short clip edits together the 3 sections where the audio problem occurred within the 2 min recording. There is a little fade out between each section.

Link to comment
Share on other sites

Sounds like digital clicking.

Where are you plugin into? Back of the computer/laptop side, or to a hub?


I'm plugged into the side of my laptop. I've tried both sides of the laptop and it has the same results. Thanks for asking.

Link to comment
Share on other sites

  • 2 weeks later...

hi all,


Just giving an update. I've tried resetting the score audio [ process: typing "sudo killall coreaudiod" in terminal .] No change in the audio recording problem.


I've also tried to get a recording of what it sounds like in the headphones as I am recording and it's very difficult to capture on my phone. If I describe what it sounds like in the headphones, there is: the skipping clipping you can hear in the previous recordings plus faint 4-5 sec beeping/whining noises and at the beginning of the recording there is no latency to be heard and by about 2 minutes in to recording there is almost 1-2 seconds of latency. I have taken the computer to a computer repair store that specializes in audio visual gear and they have been able to experience the problem first hand and they say they have no idea what the problem is. I'm curious if there is anyone has any more insight or things I might try.


Take your time in replying and thanks again for all your help!

Link to comment
Share on other sites

hi triplets and mania,


I have tried those things before but I thought I would try again. I just did a test using a usb hub, with no wifi or bluetooth on and I double checked to make sure the sample rate in Focusrite Control and on Logic were both 44.1hz and still the problem persists. Thank you everyone for your suggestions.

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...