Jump to content

Remove a midi/controller device from input list

Go to solution Solved by ScottB601,

Recommended Posts

I guess they should disappear if you delete them in the Audio/MIDI Settings app.

That's very logical. They don't.

:D I should stop guessing as much as I do obviously... On my system I can only see the devices currently connected, and it updates immediately if I connect an additional one. Can't explain why it's not working at your end...

Link to comment
Share on other sites

  • Solution

Found out what was wrong and got it fixed.

I had deleted the devices, after I sold them, in Audio MIDI Setup, but, somewhere, AMS remembered them. They were nowhere to be found from my explorations.

So, I created a new configuration and manually added only the keyboards/drums I actually have now. Started up LPX and went to MIDI preferences > Inputs, and the offending devices were still listed, but this time I was able to single-click on the item name in the Port column, and the backspace key deleted them. So, all good now. Basically, it seems, AMS was giving LPX the wrong information.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...