Jump to content

Step Record Midi only sends Midi Channel 1?


Recommended Posts

This is the first time I've really noticed this. The part is too fast to play for my lack of piano skills.


I select MIDI channel two on my Keystation. If I real time enter the midi notes it follows what midi channel I have the keyboard set to.


But when I'm step recording it seems to default to channel one.

Not a big deal as I then just go to the Event List and change them all to the proper MIDI channel.

Just wondering if theres a way to assign MIDI channels while step recording?



Link to comment
Share on other sites

Though is it possible to specify the incoming midi channel from a master keyboard?


The Step Input Keyboard is fine for the odd set of notes - but say your Treble Keyboard part was played in from a master keyboard on Channel 1 - and you wanted to play in a Left hand Part directly to the bass clef ( via Step In or Capture Last Recording after playing in real time) ...


What would be the Logic Midi Setting to do this? I have never been able to make the Master Keyboard play in only on a specific channel - it always seems to trigger Channel 1. This becomes a problem when you already have notes on the treble stave and you play in bass part and it lands up clashing with the notes on the treble stave, making it very fiddle to select and switch the notes to the bass clef Midi Channel


The work around I have used is to play in the Treble Keyboard part on one midi track ( making that the master track with a treble and bass piano score style)


Then play in the bass piano part on a separate track - ( it gets written by default on Midi Channel 1) - then select all the notes and change midi channel and cut and past them to the above master track


Would be much better if I knew how to change the Logic Midi Input filter - playing incoming notes only to a given midi channel...


Try to open the Step Input keyboard and change the MIDI Channel there?
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...