Jump to content

LPX 10.6.2 keeps rescanning just a few plugins?


Recommended Posts

Hello LPH,


Wondering if anyone has any ideas?


I finally moved up to Catalina and 10.6.2 a couple of days ago and now every time I start up LPX it rescans 6 (and only 6) plugins.


All of my plugins (including those 6 whatever they are) are validating and I also tried deleting the AU cache but no joy.


Is there any way to find out which 6 plugins (of my 100's) are rescanning? I tried to watch Console but stuff is just flying by and, to be quite honest, I'm not sure what I'd be looking for anyway! :shock:






Link to comment
Share on other sites

Any 3rd party stuff you installed recently before Catalina?


Nope. Nada. If anything I pulled things out that weren't compatible then deleted the AU cache and then rescanned but all to no avail.


I wish there was a way to see (in Console or something) the scanning process.



Link to comment
Share on other sites

So basically I narrowed it down to two things!


1. A chap over on Gearslutz said he'd run into this once when, and I'll quote, "This can happen if you have two copies of the same plugin, one in the system components folder where they normally live, and one in the user version of that folder: /Users/[user name]/Library/Audio/Plug-Ins/Components' and lo and behold I found HornetVU in both folders. Not sure how it got there, maybe an installation gremlin, but deleted the instance in my User folder and I was down to four plugins still acting up.


2. The remaining plugs were all leftovers from my Mojave install that didn't seem to have the proper security signing/clearances that Apple brought in with Catalina. Somehow they could still be validated in the AU scan (not sure how?) but it was holding it up for a moment (hence the consistent rescanning on start-up) before launching.


I found that if I "aborted" the scan during launch (I had to be quick because it would only flash for a second or two) it would ask if I wanted to continue without the plugins and I would hit yes (or 'continue' or whatever it said) and then if I immediately went to the Plugin Manager I could see which plug was causing the problem.


I repeated this four times deleting each plugin and then restarting and relaunching and voila finally no rescan at launch.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...