Jump to content

BPM Counter plug in not showing up


EARMONSTER
 Share

Go to solution Solved by David Nahmani,

Recommended Posts

Hi, I'm running Logic Pro X 10.5.1 on Mac OS X Mojave 10.14.6 and everything has been working for a long time. Yesterday I noticed I could not find the BPM Counter plug in under the "metering" category. I found this to be very strange because it's a plug in native to Logic. I've been using the following "favorites" plug in folder trick for a while now, and was able to go in and add the BPM Counter to it, and then it showed up in the favorites folder menu, but it won't pop up where it belongs in Metering.

 

 

I have no idea how many plug ins might be misbehaving this way, but I tried a fresh install of Logic Pro 10.5.1 and am at a loss. I am wondering, after checking how many 32 bit plug ins I am using, if I should focus on installing Catalina and Logic 10.6.2 and see if that works? Or if this is a fixable situation with my current set up.

 

I also tried re-validating the BPM Counter plug in and everything shows up as working but doesn't work properly. I am also having an issue where a plug in I use in Ableton Live 11.0.2 isn't passing validation in Logic Pro X 10.5.1 which has never happened before. Not sure if that's useful information here in general or a separate issue.

 

Thanks!

Link to comment
Share on other sites

I’m on Catalina with Logic 10.6 and all the delivered plugins work fine. When I made the move to Catalina a year ago only a couple 3rd party plugins were unavailable for 64 bit. I gotta think by now every plug-in is 64 bit compliant. Make the upgrade. It’s worth it just to run the latest version of Logic.
Link to comment
Share on other sites

Ok this is fascinating. Can you share a screenshot of your plug-in menu? Did you try resetting your plug-in manager to the default? I have no idea what this issue is but we already had a discussion about this topic...:

 

Logic Pro 10.6 Plugings missing

 

I checked out that other thread, and I also took the time to upgrade to Catalina (can't do Big Sur on my setup, although I swear my hardware could handle it...) and I installed Logic 10.6.2 AND after much time spent cleaning out older plug ins, and getting ready for the next production push, I noticed some important plug ins (including software instruments) showed up as being validated in the manager window but don't show up in the drop down. If i drag the successfully validated plug in to a category on the side panel it shows up and works fine. This is really crazy!

 

Thx so much for the help, any ideas?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...