Jump to content

Clicks when exporting regions


Antonfage
 Share

Go to solution Solved by Antonfage,

Recommended Posts

Hello! I'm running Logic Pro X 10.4.1 and I've sampled a piano and I'm trying to re-export the samples since I noticed clicks at the beginning of about half of them. There's fades (currently 6ms at the start), I tried to cut them at a zero-crossing, checked my levels and tried exporting with and without an Izotope Voice De-Noise on the insert. The only thing I've noticed that seems to fix the problem is when I manually bounce each region (selecting them using cmd + u) instead of choosing Export Regions as Audio Files. The clicks always appear at the beginning of the sample.

 

Should there really be any difference between using "Bounce Project or Section" and "Export Regions as Audio Files"? If anyone has any thoughts on how to solve this I'd love to hear them! Bouncing every region manually would take me hours...

 

Thank you!

Link to comment
Share on other sites

There's a difference between Bounce and Export.

Bounce will include all the sends and auxes for that track.

Export only what's on the track's channel strip.

 

That makes sense! Since I don't have any routing (except to stereo out) or plugins on another channel I can't see why that would cause clicks though. Export includes fades, right? I'm thinking that there's some kind of time difference between the two options where the export for some reason cuts off a little bit of the beginning, but that's only speculation. It would make sense that the Izotope plugin caused it, but that doesn't seem to be the case.

Link to comment
Share on other sites

  • Solution

Thought I'd come back here and share my solution. I wasn't able to get the Export function to work properly and instead I decided to select one sample at a time using CMD + U and manually bounce each one. This of course took a lot of time, but initially fixed my issues with clicks. However, when I started bouncing my release samples for the library I noticed that some of those samples had clicks in the beginning. My solution to this was to change the bounce mode from Offline to Realtime and turn on "Bounce 2nd Cycle Pass".

 

If someone else encounters the same problem in the future, it might be worth bouncing the samples using 2nd Cycle Pass from the start, as you're reassured you'll avoid clicks without having to go back and forth. Takes a bit longer, but that's probably worth it. :)

Link to comment
Share on other sites

Great, thank you so much for sharing your own solution. Very helpful. :)

 

Unless you have plug-ins in your Mixer that are not included in the audio path when exporting, the results should be the same as when bouncing.

 

For an issue like this you would have to keep checking the shape of the waveform at the very beginning of the sample, before and after bouncing (or exporting) to make sure you don't see anything unusual that could result in the click sound. If there's a click sound present a little after the beginning of the sample (even just a few ms) then a short fade may not get rid of the click. Zero crossing isn't going to help either. You have to get rid of the click by removing that piece of waveform, or redrawing it. If the click is produced by an abrupt waveform start at the very beginning of the region, then a short fade should take care of it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...