Jump to content

Newb pulling hair out over MIDI channels!


zmblnc
 Share

Recommended Posts

Hi,

 

Relatively new to Logic, totally new to MIDI. My scenario is this: I have a Roland TR-8S playing it's patterns all on channel 10. I have Serum synth on MIDI channel 3. Even though they are on different channels all the MIDI info is being sent from the Roland to Serum (or any other inst on another channel).

 

In practice this means I have a drum loop playing, all good. Then I click on the Serum channel in Logic and suddenly all the drum notes start playing on Serum. And for the life of me I can't figure it out. I had enough grief getting the TR to work. Now this, felling so frustrated...

 

I would be eternally grateful for any help.

Link to comment
Share on other sites

Hi,

 

MBP with a Presonus iostation coupled with a TR-8s as an aggregate device. The TR is set up to transmit on channel 10 for midi and audio channels for each output. That kinda works (though it’s always a few ms out but that’s another issue)

 

If I play a pattern on the TR while that track is selected in logic it plays but the minute I click on another midi track all the drum notes start playing on that too even though it’s set to its own channel.

Link to comment
Share on other sites

Thanks David! Naturally google searches always lead to you so it is set up that way. The TR is set to 10 on the gadget itself as well as in logic. Interestingly in macs audio midi setup the TR is shown as sending on channel one (in fact all midi devices are) but the option to change it on all of them is greyed out.
Link to comment
Share on other sites

Thanks David! Naturally google searches always lead to you so it is set up that way. The TR is set to 10 on the gadget itself as well as in logic. Interestingly in macs audio midi setup the TR is shown as sending on channel one (in fact all midi devices are) but the option to change it on all of them is greyed out.

Make sure you use Snoize's MIDI Monitor (https://www.snoize.com/midimonitor/) to double-check the MIDI channel of the notes sent by your keyboards. Make sure both tracks stay R-enabled at all times.

Link to comment
Share on other sites

David. I spent 12 hours yesterday on this. Almost cried at one point. Got up early over here in the UK and have been screwing around to no avail for about 5 hours, getting progressively sick of my own beats...

 

Then I read this piece of advice and, you being you, of course it bloody worked!!!

 

Thanks a billion!!!!

Link to comment
Share on other sites

David. I spent 12 hours yesterday on this. Almost cried at one point. Got up early over here in the UK and have been screwing around to no avail for about 5 hours, getting progressively sick of my own beats...

 

Then I read this piece of advice and, you being you, of course it bloody worked!!!

 

Thanks a billion!!!!

Great! You're welcome, good to hear you ended up making it work, and ... glad to help. :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...