Jump to content

MIDI shifted forward on after recording


logic8mine
 Share

Recommended Posts

I have a recurring issues in Logic X. After recording MIDI, the notes in the region are shifted forward– before the beat (say, from 20,1,1,30 to 19,4,4,176). Very noticeable and early. After moving to the correct position, if I overdub the region both new notes and previously corrected notes are again shifted forward. No Quantize, MIDI Delay, etc. are turned on. Any ideas?
Logic Pro 10.7.0, 15", 2018 MBP - i7 Quad Core- 2.2Ghz, 16GB Ram w/ 250GB SSD, Yamaha XS8 w/mLAN, OS X 11.6, G-Tech 1TB Ext. HD, Lacie 2TB HD, Samsung T5 500GB SSD, Focusrite Clarett- 4Pre Thunderbolt, Roland VS-2480
Link to comment
Share on other sites

Plugin delay compensation perhaps?

LogicPro 10.7.4, MainStage 3.6,
MBPro 17", Core2Duo, 8G, OSX 10.12.6, MacPro, Xeon 6Cores, 64GB, OSX 10.16.1,
ULN8, MOTU MIDI TP-AV, C4, MCU Pro, KorgNano, Novation SLMkII, Several vintage gear
AAS, NI, Celemony, Spectrasonics, Korg, Arturia, etc..., PC, iPadPro 5th gen 12.9”(Duet D., V-Control & LogicRemote), AtariST(Notator SL),

Link to comment
Share on other sites

  • 6 months later...

Just want to bump this because I have the same issue--it's not plugin delay related. Happens without plugins. 

During recording, the notes are fine but during playback they are shifted forward. Happens with audio too. 

[EDIT: even at lower buffer/sample with no plugs this happens]

Edited by Space_Crush

Computer Deets: macOS Monterey 12.4 MacBook Pro (13-Inch, 2019) 2.4 GHz Quad-Core Intel Core i5 8GB
Hardware Deets: UA Apollo Twin-X USB-C | UA Apollo Quad Thunderbolt-2 | Behringer X32 Rack

Link to comment
Share on other sites

In Logics audio preferences, general, make sure the Recording Delay slider is set to 0 samples ?

Logic Pro 10.5.1 • OS X 10.14.6 • MBP 15" Early 2013 • 2.4 GHz Intel Core i7 • 8GB RAM • iMac 27 Late 2013 • 3.4 GHz Intel Core i5 • 16GB RAM • Focusrite Saffire 6 USB • cheap midi keyboard • Korg NanoKontrol • Roland UM-One mkII • Behringer FCB1010 • Gibson ES335
Link to comment
Share on other sites

On 6/15/2022 at 7:17 PM, Space_Crush said:

Just want to bump this because I have the same issue--it's not plugin delay related. Happens without plugins. 

Does it happen in a new factory template ? What interface are you using ?

Logic Pro 10.5.1 • OS X 10.14.6 • MBP 15" Early 2013 • 2.4 GHz Intel Core i7 • 8GB RAM • iMac 27 Late 2013 • 3.4 GHz Intel Core i5 • 16GB RAM • Focusrite Saffire 6 USB • cheap midi keyboard • Korg NanoKontrol • Roland UM-One mkII • Behringer FCB1010 • Gibson ES335
Link to comment
Share on other sites

Any and all, from time to time.

Computer Deets: macOS Monterey 12.4 MacBook Pro (13-Inch, 2019) 2.4 GHz Quad-Core Intel Core i5 8GB
Hardware Deets: UA Apollo Twin-X USB-C | UA Apollo Quad Thunderbolt-2 | Behringer X32 Rack

Link to comment
Share on other sites

Does this happen to your external instruments only? Or does this happen to your software instruments too? Had the same problem. It was simply turning on the "Auto Compensate Latency***" checkbox on the External Instrument :)

Edited by Pepillo
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...