Jump to content

Logic Remote lag


fromoutwest
 Share

Recommended Posts

Conceptually, this is fantastic but I find it lags a bit too much to be fully useful. In particular, moving between tracks isn't as instant as using hardware controllers (e.g. Launchpad). Moving too fast builds up lag that can take a few seconds to catch up as well. Further to this, not sure how to stop the Logic plugin window from opening when I select a track. Is there not a way to disable? This contributes to the overall slowness.

 

My setup includes a Mac Mini 2012 (16gb), running LPX 10.6.4 on Catalina with latest Logic Remote on iPad Air g3.

 

Thanks,

Jason

Link to comment
Share on other sites

I don't get any lag here. Selecting a channel strip in the Mixer in Logic Remote selects the track on the Mac pretty much instantaneously. I'm not sure what you mean by "moving too fast": what are you moving?

 

No Logic plug-in window opens when I select a track here. Maybe you have an empty linked plug-in window already opened before you select the track?

 

Can you reproduce those issues in a new empty project with only a few tracks? Trying to determine if this is project-specific.

Link to comment
Share on other sites

Hi David. To get to the bottom of this, I deleted com.app.logic.pro.cs along with Logic Remote on iPad to see if this changed anything. I also updated to the latest version of iPadOS.

 

Surprisingly, I found it was the install of my Komplete Kontrol S61 Mk2 which changed the behavior of the Logic Remote on iPad to automatically open the plug-in window on track selection. This only happens when selecting via iPad, and not through the keyboard or any other control surfaces. Ironically, it doesn't happen when using Logic Remote via my iPhone either. Don't think I can resolve this one and will have to wait for updates from NI or Apple most likely.

 

Another very odd thing I noticed - the Channel EQ plug-in comes up blank in the Logic Remote. In the mixer view, I can see the curve profile, and even see it moving realtime if changed in Logic directly. If I then open to edit on the iPad, completely blank. All values are 0 and no graph. As noted above, I've re-installed several times with no luck.

 

As for lag, I was just referring to general moving around randomly selecting tracks, moving faders, opening plug-ins etc. Is ok for the first 10 seconds or so then almost if a buffer overflowed, all subsequent clicks in Logic Pro execute at glacial pace with 2-3 seconds between actions. I have to re-start the app. Tried connecting direct through lightning cable too (vs WiFi), same issue. Perhaps some kind of mis-match between my version of Logic and the iPad remote?

Link to comment
Share on other sites

  • 10 months later...

I get this lag too.  I’m using Logic Remote (LR) 1.5.3 on an iPad Pro 12.9” 2nd generation with a 2020 iMac Mini M1 8 gb RAM running Monterrey 12.5 and LPX 10.7.5 though I also get the same lag issues on mid-2011 iMac with the latest High Sierra and LPX 10.4. I also tried with an iPad Air 5th generation and same computers.  

The issue is that after about 10-15 minutes of LR running perfectly I’ll notice that the faders on LR simply stop affecting LPX. I’ll swipe up and down on the fader, pans, sends, basically any knob or slider but it doesn’t affect LPX.  Then the LR channel names stop updating properly when swiping through the channels on the mixer. When I tap on a channel in LR it will select a different channel on LPX.  Sometimes some LR faders will be stuck at the bottom of the channel at negative infinity db though LPX shows the fader is at whatever I set it too (not negative infinity db).  The pans for some channels will be hard left.  Other times in the mixer I’ll try to swipe over to another channel but it slingshots me back to where I’m swiping from.  This happens when I use the black bar as well.   Other times some meters simply don’t update properly. Everything else in LR works perfectly fine, it’s just the mixer window that goes wonky.

All of the above craziness sometimes stops after about 5-10 minutes; other times I just give up and come back later.  

I’ve tried restarting the app but it still resumes where it left off. I’ve tried completely restarting my computer and that usually fixes it.

One major thing I noticed is that LR on my iPhone works perfectly the entire time and never bugs out.  The mixer in the LPX template in TouchOSC mk2 also works perfectly the whole time and never bugs out. The only iPad controller that does this crazy lagging for me is LR on iPadOS

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...