Jump to content

Isotope plugins not working properly


Recommended Posts

I recently downloaded Nectar 3, Ozone 9, Rx and a few other plug-ins onto my 2019 MacBook Pro. When I add something like Nectar 3 to a vocal summing bus in order to affect all the tracks within the folder, the tracks that are panned become centered. Even when I remove the plugin completely from the track, the tracks remain centered and all the vocals become compressed and peak through out. It's like a sort of bug that's left behind when I remove the plugin.

I've tried the following:

1. Making sure the plugin is in stereo as well as the summing bus

2. Removing a reading plug-in

3. Rescanning all Izotope plugins

4. Restarting Logic and MacBook

At this point I think the Izotope plug-ins are bugged on my end or something along those lines. If someone could please give me a solution, I'd love to finally be able to use all the Isotope plugins that I've acquired.

Link to comment
Share on other sites

and are your izotope plugins all up-to-date? open the izotope product portal and make sure...


are you working from a template? you could try opening a blank generic logic file, play with that, see if the problem continues.


it does sound like some sort of routing issue; you could post a screenshot of your mixer here...

Link to comment
Share on other sites

I did create my own template before using my newly acquired Izotope plugins. The screen shot I shared shows how my vocal summing folder is set up (this is how I set up all the folder, difference. being different aux sends). I don't know if I set up things incorrectly which is what's causing Izotope to bug out. I have not yet tried using the plugins on an empty project.


Link to comment
Share on other sites

to my eye (and there are people here far more advanced in their logic use & understanding), everything looks ok. but, what are you trying to do (for example) with nectar3? you're routing all your vocals to it? to create harmonies? use some auto-tuning? anyway, you could try creating a new send, and route the tracks you want to that, with (for example) nectar.


save your project. make a copy. experiment with the copy (so you don't lose anything). and you could route everything to the bus nectar 3 is on, and have no output on your vocal master..


otherwise, someone else needs to step in here and make some suggestions...

Link to comment
Share on other sites

So after running through everything, I discovered the issue. Whenever ever Pitch Correction on Nectar 3 is enabled, it causes the vocals to center. When I disable the Pitch Correction on Nectar 3 everything works and is panned completely fine. It's great that everything else works on Nectar, but I'd of course love to utilize the Pitch Correction. I have no idea why Pitch Correction is forcing the vocals to pan, regardless if the plugin is on the summing bus or a single track within the folder. If someone could find a solution for this I'd much appreciate it.
Link to comment
Share on other sites

I expect pitch correction is a mono process, so it's forcing/summing stereo signals to mono at that point when enabled. Check the manual to be sure...


this. it's not as advanced as you'd like it to be, can only do pitch correction on one monophonic voice... at a time. you're better off using flex pitch on vocal tracks (or one instance of nectar per track). but glad you got it sorted!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...