Jump to content

Intermittent unresponsive UI elements (10.7.2)


Recommended Posts

I have this quite infuriating issue happening lately (since 10.7.2), where every now and then certain parts of Logic's UI becomes unresponsive to mouse input. It is mostly the buttons in the track headers (mute, solo, record enable etc), regions in the tracks view and automation points.

Usually not all of them becomes unresponsive at the same time, so I might sit there trying to make a new automation point, or edit an existing one, screaming guttural, primal sounds and tearing my hair out with my free hand as my frenzied clicking fails to do anything, while the regions on the track still get highlighted if I click on them. :x


I think it only affects stuff in the tracks area, but I can't say that with 100% certainty as I usually don't go around clicking too much on the mixer all the time. I can't recall it has ever happened in the piano roll or the audio file editor (or any other window, like plugins). I think it does affect the buttons on the channel strip in the inspector, though.


Also, all key commands still work while this is going on, so I can e.g. still mute or solo tracks with commands while the buttons are unresponsive to mouse clicks.

I have tried using the trackpad on my MBP, a wireless mouse and a cabled trackball, all experiencing the same issue.


Logic runs fine doing everything else while this is happening, no CPU spikes or overloads, playback is still smooth etc etc.


This issue appears seemingly at random, and lasts for everything from a couple of seconds to tens of seconds before stuff becomes responsive again. It happens in empty projects as well as projects almost bursting at the seams with stuff.


I haven't really installed anything new or been using anything new since this issue started happening (apart from Logic 10.7.2).


The issue occurs only in Logic, so it's not something general going on with my mac (though it's a wonder that old hag is still alive). It is a first-gen touchbar 15" 2016, Running macOS 11.6


So am I alone in this? Can't really find any other topics on this, except the slightly similar one with the unresponsive buttons when clicking fast. Except in my case I can click as slow as myself on a sunday, and it still won't register.

Link to comment
Share on other sites

Booting won't really solve the problem, as it takes longer time than to wait for the unresponsiveness to go away. And I have booted it since this issue appeared, hehe, but it is still happening.

I will, however, try resetting this other stuff and see if that makes a difference!

Link to comment
Share on other sites

  • 2 weeks later...

Yes, I'm having this exact issue.

Latest Monterey, Brand new, virgin MBP 2021. 10.7.2. 16g ram

During working, I'll click on some take folder etc and nothing will happen. I can click other regions on other tracks and the rest of the UI seems to work. It's interfering with my flow.

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...