Jump to content

Logic Pro 10.4.4 multiple AU plugins show "validation result: couldn’t be opened"


Recommended Posts

Hello everyone,


A problem surfaced when I tried to update a plugin which results in Logic plugin manager showing "couldn't be opened".

After a reset& rescan of the plugin AUVal Tool shows this:



(note that the update works fine on OSX 10.12.6 as the same upgraded AU opens up just fine in Ableton Live 10 DAW.)


I've proceed to rebuild the "com.apple.audiounits.cache" file which only resulted in even more plugins that used to be working showing up as "couldn't be opened", and rescan with AUVal tool yields similar error like the screencap above.

* * PASS




FATAL ERROR: OpenAComponent: result: -1,0xFFFFFFFF



validation result: couldn’t be opened


I've tried doing full re-install of some of the offending plugins but same problem persisted. AU runs fine in Ableton, but "couldn't be opened" in Logic.


The big OSX system change I remembered was updating iTunes to a few days ago. I don't know if this contributed to my problem.


Thanks for reading, I am currently in a pickle as I only have a carbon copy of my hard drive instead of time machine which I can revert back to :( Here's to hope someone will be able to help me out.


Thank you all in advance!




Link to comment
Share on other sites

I do remember vaguely of an iTunes update that upgraded some system component that caused some plugins that relied on that system component to fail a long time ago - I don't know if this is what's happening in your case, but it's not implausible.


You might want to contact Sound Radix for support to see if they can sort out your issue, perhaps?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...