Jump to content

Logic 10.7.3 is out


evil_cliff

Recommended Posts

Well I'd like to report that this update has been a game changer for me. On an M1 for over a year now, I had several 3rd party AUs that were still Intel native crash Logic when just trying to load a project that contained them ("AU plugin has reported an error that might cause the system to become unstable etc.") In fact any project that ONCE contained them, even if I removed them and re-saved would still crash 5 out of 6 times when I opened it.

 

Now I just click "Recover" if this happens. No crash. Wonderful, wonderful!

Link to comment
Share on other sites

I was sent a beta version of Omnisphere from Spectrasonics support to test, and it seems to have resolved the broken/missing automation issue on my Intel-based machine running Logic Pro 10.7.3 on Big Sur.

 

I assume this means each plugin developer will need to (decide if they will) address the issue on their end, if/when they become aware of it.

Same here!

Jake (from Spectrasonics tech support) told me they are working on implementing same on their other apps (Keyscape, Trillian, Stylus RMX), which would be included in the next update coming soon (few weeks)…

Spectrasonics really do have stellar support!

Link to comment
Share on other sites

If I'm correct, before 10.7.3, we could preview audio pads in the pattern sequencer when the pattern was playing by ckicking on the arrow instrument icon.

Now this feature is available only if pattern is stopped.

Is it correct ?

No, it was never possible to preview pads by clicking the instrument icon in the step sequencer (just to make sure I tried it in 10.7.1 and indeed that does not work).

 

On the other hand if you open Drum Machine Designer and hover a pad with your mouse, the icon is replaced by a speaker icon, and you can click the speaker to preview the pad. Perhaps that's what you're remembering?

Link to comment
Share on other sites

Anyone else have ultrabeat keep trying to download content on EVERY load?

Apple loops that use it also report duplicate paths and then show an empty box.

 

Again this is a brand new 2022 MBP with a virgin user and Logic install.

 

Also, some plugins (3rd party) at random, at some point during a session, seem to suddenly not be able to load their GUI's

A window appears on clicking, but small and empty.

1505138783_Screenshot2022-03-30at14_51_32.thumb.png.a123099031ffdbf71b03b93c2b82d32a.png

Link to comment
Share on other sites

Anyone else have ultrabeat keep trying to download content on EVERY load?

Apple loops that use it also report duplicate paths and then show an empty box.

 

Again this is a brand new 2022 MBP with a virgin user and Logic install.

 

Also, some plugins (3rd party) at random, at some point during a session, seem to suddenly not be able to load their GUI's

A window appears on clicking, but small and empty.

Did you relocate the library? I had that problem at every update when my library was on an external drive. Since I moved it back to the main SSD, all is well. It was a bug fix mention some time ago but if it‘s the cause of your problem, it’s not fixed obviously.

Link to comment
Share on other sites

If I'm correct, before 10.7.3, we could preview audio pads in the pattern sequencer when the pattern was playing by ckicking on the arrow instrument icon.

Now this feature is available only if pattern is stopped.

Is it correct ?

No, it was never possible to preview pads by clicking the instrument icon in the step sequencer (just to make sure I tried it in 10.7.1 and indeed that does not work).

 

On the other hand if you open Drum Machine Designer and hover a pad with your mouse, the icon is replaced by a speaker icon, and you can click the speaker to preview the pad. Perhaps that's what you're remembering?

 

Over here clicking on the pads while the Step Sequencer is idle does indeed result in the playback of individual sounds. But does not appear to work during playback. Sometimes I have to click on the icons a couple of times to "wake" Logic Pro up to play the individual sounds.

 

Edit: A row has to be selected first in the Step Sequencer before playback of a sound will commence. Still only while playback is not occurring.

Link to comment
Share on other sites

Did you relocate the library? I had that problem at every update when my library was on an external drive. Since I moved it back to the main SSD, all is well. It was a bug fix mention some time ago but if it‘s the cause of your problem, it’s not fixed obviously.

 

No relocate. Just a totally virgin install. I may try relocating and switching back... But that will take some time and a spare disk...

Link to comment
Share on other sites

If I'm correct, before 10.7.3, we could preview audio pads in the pattern sequencer when the pattern was playing by ckicking on the arrow instrument icon.

Now this feature is available only if pattern is stopped.

Is it correct ?

No, it was never possible to preview pads by clicking the instrument icon in the step sequencer (just to make sure I tried it in 10.7.1 and indeed that does not work).

 

On the other hand if you open Drum Machine Designer and hover a pad with your mouse, the icon is replaced by a speaker icon, and you can click the speaker to preview the pad. Perhaps that's what you're remembering?

 

No David, If I click on the icon (arrow on the picture) the clap sound is triggered when the step sequencer is stopped but not if it runs.

It seems that before 10.7.3 this was possible to trigger the sound that way even if sequencer was runing.

945006424_logicstepsequencer.thumb.jpg.0641f974d45f5c777b742eb9efadd69f.jpg

Link to comment
Share on other sites

No David, If I click on the icon (arrow on the picture) the clap sound is triggered when the step sequencer is stopped but not if it runs.

It seems that before 10.7.3 this was possible to trigger the sound that way even if sequencer was runing.

I stand corrected, you're right, that works! I'm not sure why it's not working during playback then.

 

BTW it's best if you start one new individual topic for each new topic you wish to discuss, as it can help garner more attention, and find the topic again (for example here I did not remember where I had seen your response and couldn't figure out how to find this again in order to respond to you).

 

So please do start a new topic for this and we can move it to the Bug forum. Also let's report this directly to Apple: https://www.apple.com/feedback/logic-pro.html

Link to comment
Share on other sites

Actually, scrap that. It requires Monterey and I'm still on Big Sur. So I will wait for a while. I have a sneaking suspicion that 10.7.4 will be M1 only.

Alan.

 

And so the Corporate mongul lifts it's ugly head again bullying consumers around. I swear I am so gonna eventually end up using a Windows system against my desire b/c of the idiocracy of Apple. As the saying goes, "a fool and his money are soon departed". Greed is gonna cost them eventually.

Link to comment
Share on other sites

Actually, scrap that. It requires Monterey and I'm still on Big Sur. So I will wait for a while. I have a sneaking suspicion that 10.7.4 will be M1 only.

Alan.

 

And so the Corporate mongul lifts it's ugly head again bullying consumers around. I swear I am so gonna eventually end up using a Windows system against my desire b/c of the idiocracy of Apple. As the saying goes, "a fool and his money are soon departed". Greed is gonna cost them eventually.

 

what bullying? do you mean 'minimum system requirements'? and greed? apple is a corporation; corporations exist to succeed mightily, and make money... the fact that apple does this with (mostly) exceptional products is a great thing. so "greed is gonna cost them eventually"?... don't hold your breath.

 

but yes, go to... windows, where there are no issues, and you can deal with the humanistic corporation that is microsoft.

Link to comment
Share on other sites

what bullying? do you mean 'minimum system requirements'? and greed? apple is a corporation; corporations exist to succeed mightily, and make money... the fact that apple does this with (mostly) exceptional products is a great thing. so "greed is gonna cost them eventually"?... don't hold your breath.

 

but yes, go to... windows, where there are no issues, and you can deal with the humanistic corporation that is microsoft.

 

If you read the quote I was referring to when I made the statement you'll see it was stating that the system requirement was Monterey. So my statement was based on that assessment. I understand the Corporate structure and how it survives but I don't agree with forcing a requirement of updating the O/S to support the application within such a short period of time. Big Sur hasn't been out that long IMHO to force users to upgrade the OS to support updates to the Logic app. It's already difficult enough for other vendors to keep pace with making their plugins compatible every time Apple launches a new OS and as a user I don't want to be forced to update my OS simply to support an update to the app.

 

That's what I meant.

 

Shortly after my post I see -> "Logic 10.7.3 does not require Monterey, it requires Big Sur minimum. Check the system requirements." Which makes more sense and is closer to what I'd expect as more reasonable.

Link to comment
Share on other sites

If you read the quote I was referring to when I made the statement you'll see it was stating that the system requirement was Monterey. So my statement was based on that assessment. I understand the Corporate structure and how it survives but I don't agree with forcing a requirement of updating the O/S to support the application within such a short period of time. Big Sur hasn't been out that long IMHO to force users to upgrade the OS to support updates to the Logic app. It's already difficult enough for other vendors to keep pace with making their plugins compatible every time Apple launches a new OS and as a user I don't want to be forced to update my OS simply to support an update to the app.

 

That's what I meant.

 

Shortly after my post I see -> "Logic 10.7.3 does not require Monterey, it requires Big Sur minimum. Check the system requirements." Which makes more sense and is closer to what I'd expect as more reasonable.

 

yes, big sur... altho your rant still seemed over the top. in theory (at least), apple updates their apps that then require a certain OS to work, it's not simply planned obsolescence (or an attempt to personally piss you off). it's not always easy, but many of us enjoy progress.

 

& yes, i know all about the people who run workarounds to install newer OSes on older macs; more power to them.

Link to comment
Share on other sites

Omnisphere isn't showing up in the automation track view when launching Logic on a M1 Mac under Rosetta. In native mode it's working as it should. Just tested it on two M1 Macs.

 

UPDATE:

 

Léo (Arturia Support)

Apr 9, 2022, 9:08 GMT+2

Hi,

 

I'm sorry for the inconvenience,

Do note however that the fix has to be issued by LOGIC in contrary to what my colleague mentioned,

It is indeed strictly on their end that the issue appeared and they did acknowledge that the fix is theirs to release,

 

Yours Musically.

Léo - Arturia Support

Link to comment
Share on other sites

Omnisphere isn't showing up in the automation track view when launching Logic on a M1 Mac under Rosetta. In native mode it's working as it should. Just tested it on two M1 Macs.

 

UPDATE:

 

Léo (Arturia Support)

Apr 9, 2022, 9:08 GMT+2

Hi,

 

I'm sorry for the inconvenience,

Do note however that the fix has to be issued by LOGIC in contrary to what my colleague mentioned,

It is indeed strictly on their end that the issue appeared and they did acknowledge that the fix is theirs to release,

 

Yours Musically.

Léo - Arturia Support

How come then that Spectrasonics managed to find a fix for Omnisphere?

Link to comment
Share on other sites

I don’t know but they drive me crazy. I called Apple Logic tech support and they told me Arturia needs to fix it and Arturia says Logic needs to fix it.

 

Same for the TC Electronic Clarity M stereo plugin, in LP 10.7.3 it quits Logic when I’m using it and they say Logic needs to fix it and Logic says TC Electronic needs to fix it…

Edited by seq998
Link to comment
Share on other sites

OTOH, how come some plugins suffer from that (alleged bug) while others aren't?

 

that's kinda the million-dollar question, isn't it? seems that apple broke something; but none of my synths (seem to) be affected by this issue. apple should fix it. yet if they're sending people to the developers, then arturia et al may have to figure it out. one way or another, it should get sorted.

Link to comment
Share on other sites

OTOH, how come some plugins suffer from that (alleged bug) while others aren't?

 

that's kinda the million-dollar question, isn't it? seems that apple broke something; but none of my synths (seem to) be affected by this issue. apple should fix it. yet if they're sending people to the developers, then arturia et al may have to figure it out. one way or another, it should get sorted.

The good thing to do here would be to have both (all) of them to talk to one another. To come with a solution (faster).

That would make the users (their customers) happy ones...

Happy customers are the ones that come back, frustrated ones are the one that quit.

My 2 cents...

Link to comment
Share on other sites

This must be the worst update I've experienced by Logic. Let's keep sending reminders to all parties that a solution has to be made asap. At least some form of "working on this" newsletter would be nice.

 

Anyone having issues with plugins (3rd party) not saving the settings after 10.7.3 like me? (Arturia and Plugin Alliance)

..and making Logic and most of my plugins practically useless. Considering setting all plugin subscriptions on pause until 10.7.4 is out...

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...