Jump to content

Region guide mispositioned when in flex mode or transposed


Ellzo
 Share

Recommended Posts

 

This has been an ongoing problem for YEARS, spanning all updates, but couldn't be arsed to anything about it. Now that I'm working with audio more, it's becoming quite frustrating. As the video demonstrates, whenever I transpose or flex audio files, the playhead (when moving regions) will be placed randomly, not at the start as it should be. This then messes up the alignment when moving audio and is very inconsistent.

 

I have a feeling it could be down to a plugin that I've installed, but I'm not sure which one & I'm not sure if its the case anyways.

ezgif-3-baed4060a3.gif.79520ad3fb4e7f4d2f4d74a44da42f98.gif

Edited by Ellzo
Link to comment
Share on other sites

What you're seeing is not the playhead, but a guide that shows you the position of the audio region. When you're in Flex editing mode normally there's no anchor in the audio region and the guide shows you the position of the left region border however this seems buggy (see my screen capture below).

 

It may still be tied to the position of the anchor in the audio region (when Flex is turned off)? I'm not sure. I would turn Flex off for the track and try setting the anchor at the beginning of the region and then turn Flex back on and see if that helps.

 

Or it could be just because the project start marker is not at its default 1 1 1 1 position (as in my example below), which triggers all kinds of bugs in Logic Pro:

 

vertical-guide.gif.60ad79fb571f5fc015f51b95700c25a2.gif

My new Logic Pro Book is out!

Link to comment
Share on other sites

What you're seeing is not the playhead, but a guide that shows you the position of the audio region. When you're in Flex editing mode normally there's no anchor in the audio region and the guide shows you the position of the left region border however this seems buggy (see my screen capture below).

 

It may still be tied to the position of the anchor in the audio region (when Flex is turned off)? I'm not sure. I would turn Flex off for the track and try setting the anchor at the beginning of the region and then turn Flex back on and see if that helps.

 

Or it could be just because the project start marker is not at its default 1 1 1 1 position (as in my example below), which triggers all kinds of bugs in Logic Pro:

 

vertical-guide.gif

 

Thanks for clearing up on what to call it. It's quite a similar bug to your example, however for me, the guide never goes outside the audio region in every case I've had, so I'm thinking it must be something else. The issue still continues (see gif below).

 

Tried setting the playhead to it's default position, but sadly doesn't fix it. I'd turn flex off and SOMETIMES the guide will line up correctly on the left, but most times it'll still bug, even after turning flex off.

 

I think you're onto something with the anchor though. Seems to be buggy when switching to flex mode, it'll disappear when I try to toggle (unless that's meant to happen, never really used the feature).

 

anchor.gif.edcfabcb865903f95913431a6199c5f6.gif

Link to comment
Share on other sites

Yes the anchor isn't available while in Flex mode, I suppose that's by design as it would create issues when flexing (Logic would have to move the region accordingly in order to keep the anchor at the same position, or to move the anchor position along with your flex edits, which I can imagine would create all sorts of issues).

My new Logic Pro Book is out!

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...