Jump to content

Very high CPU usage when Logic is idle


noisyneil

Recommended Posts

Posted (edited)

I've had high idling CPU activity for a few years now, but it's suddenly got a lot worse.

I'll open a session and hit play. The CPU monitor it probably sitting at about 10-20%. I'll work for about half an hour, editing, mixing or simply listening. CPU use gradually climbs up to 4 or more of my 8 cores being at 100% and playback grinds to a halt.

I make sure an audio track is selected, disable all plugins, move the playhead to an empty portion of the arrangement and try playing again. The cores are maxed no matter what I do, and remain so for several minutes, until they suddenly fall back down to normal levels. Doesn't seem to matter whether it's a simple or very involved session. 

Anyone else?

image.thumb.gif.f0a53e2f13a07e6c1daa8142c18d65cc.gif

Edited by noisyneil

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

  • noisyneil changed the title to Very high CPU usage when Logic is idle

Some 3rd party plugins are very CPU demanding as soon as instantiated (even when turned off or bypassed).

Have you tried SMC & NV/PRAM resets?

  • Like 1
  • Sad 1

LogicPro 10.7.4, MainStage 3.6,
MBPro 17", Core2Duo, 8G, OSX 10.12.6, MacPro, Xeon 6Cores, 64GB, OSX 10.16.1,
ULN8, MOTU MIDI TP-AV, C4, MCU Pro, KorgNano, Novation SLMkII, Several vintage gear
AAS, NI, Celemony, Spectrasonics, Korg, Arturia, etc..., PC, iPadPro 5th gen 12.9”(Duet D., V-Control & LogicRemote), AtariST(Notator SL),

Link to comment
Share on other sites

Posted (edited)

You say the activity meter behaves like that, *with all plugins bypassed*? All plugins in your project?

If so, something is very wrong.

Likely though, you *do* have plugins active, and remember that all your plugins on busses and the main mix bus will be active and processing all the time, regardless of whether Logic is in playback mode or not (because you could play an instrument, and audio signal in Logic through the mixer at all times, not just during playback.)

You'll need to assess how CPU heavy your various plugins are, and choose how to use your plugin resources accordingly. Freezing may help in a lot of cases, though not with bus/master plugins of course.

Edited by des99

mu:zines | music magazine archive | difficultAudio | Legacy Logic Project Conversion | Logic 10.7.4, MBP 16" M1pro

Link to comment
Share on other sites

21 hours ago, Atlas007 said:

Some 3rd party plugins are very CPU demanding as soon as instantiated (even when turned off or bypassed).

I'm aware of that, but that doesn't explain this behaviour. 
 

 

21 hours ago, Atlas007 said:

Have you tried SMC & NV/PRAM resets?

NVRAM yes, SMC no. I'll try that now. 

 

21 hours ago, des99 said:

You say the activity meter behaves like that, *with all plugins bypassed*? All plugins in your project?

In the example gif, I haven't bypassed everything, but I've tried doing so and it hasn't quelled the CPU. What I don't know is if the issue will present while all plugins are bypassed, as that would require specific testing. I suspect it wouldn't. 

 

21 hours ago, des99 said:

Likely though, you *do* have plugins active, and remember that all your plugins on busses and the main mix bus will be active and processing all the time, regardless of whether Logic is in playback mode or not (because you could play an instrument, and audio signal in Logic through the mixer at all times, not just during playback.)

Yep, I'm aware. Bypassing or even resetting the master buss strip doesn't help. I still have to wait several minutes for it to drop off, as I described. 

 

21 hours ago, des99 said:

You'll need to assess how CPU heavy your various plugins are, and choose how to use your plugin resources accordingly. Freezing may help in a lot of cases, though not with bus/master plugins of course.

Yeah this is Logic 101. For context, I've been using Logic since 2006, and I'm quite perplexed by this. The key issue here is that the session will play fine for a while, barely consuming any resources, and then it will start to ramp up to the point that it's unmanageable, for no obvious reason. Of course I've dealt with CPU overloads in the past, but ordinarily the meter would calm down at least somewhat when you stopped playback or bypassed plugins. This seems to be a bit more unprovoked. 

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

Posted (edited)

It might be worth monitoring your MBP temperatures when this happens - is your machine overworked and hot? If the machine is hot and cooling isn't efficient, it's possible the CPU is throttling down - although I'm not convinced this alone could explain what you describe...

Also, if you haven't for a while, it might be worth clearing out your fans, as they get clogged over time and the cooling performance goes way down. I used to clean out my MBP when I started noticing it was getting hotter than usual, and this was usually maybe once a year after a while...

Does Logic *always* behave like this, regardless of the session? Or is it limited to particular sessions?

Edited by des99

mu:zines | music magazine archive | difficultAudio | Legacy Logic Project Conversion | Logic 10.7.4, MBP 16" M1pro

Link to comment
Share on other sites

1 hour ago, des99 said:

is your machine overworked and hot?

Oddly, no. Weird, huh? I'm pretty pleased with the thermals on this 16" MBP, and even when it freaks out in Logic, the fans don't suddenly go crazy and it's not especially hot to the touch. 
 

1 hour ago, des99 said:

it might be worth clearing out your fans

That's good advice regardless. I cleaned out my old machine and it did make a marked difference. 👍🏼

1 hour ago, des99 said:

is it limited to particular sessions?

Hard to say as it's only recently started to get to the point that I can't work around it. What I will say is that it's happened on very old sessions and brand new ones. I'll keep an eye out for any linking factors. 

Thanks again for taking an interest. 

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

  • 2 weeks later...
On 5/7/2022 at 1:57 PM, David Nahmani said:

Moving this to the Logic Pro forum. 

Thought it already was. My bad. 

This is driving me nuts. I've run countless large sessions over the last two years without issue and, for some unknown reason, my system has recently become unusable. Nothing playing, audio track selected, one core constantly spiked. 

image.gif.ac83d7438bb7c4c9da0af6502be97d19.gif

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

Posted (edited)

@des99 That's the thing. I can turn off every track and disable everything on the mix buss, and it stays spiked. Three or four minutes later it will drop to zero, but trying to play again will cause the same behaviour. Obviously, over the past fifteen years using Logic, I've dealt with hungry plugins before and have managed to whittle down the culprits, but this is happening with every session, in random configurations and feels different; so much so that I've run diagnostics and a RAM test with Rember. Everything came back fine. I'm gently considering wiping my entire system and doing a fresh install. I can't really afford the downtime at the moment, but may be left with no choice. 

Edited by noisyneil

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

Posted (edited)

I know you can turn everything off and it stops, but that's not what I'm talking about - I'm trying to determine if there is one or a few particular causes of this. Say, if you deactivate the mix buss, and want, does the core usage drop to nothing, or not? If it does, then you've narrowed some of the problem. If it doesn't, you can rule that out.

Now it's possible there is something more complex going on in your system which isn't just an "it's this plugin" thing, but those troubleshooting steps are the start to identifying problem areas to explore further.

(Remember, I don't know exactly what you have or haven't done investigating this issue - it's possible you've done all this steps, but I don't yet have any information about what your process revealed, other than you don't know what's going on. Also, I don't always go back an reread every detail of a long troubleshooting thread to get back up to speed, especially when days or weeks go by, so it's possible I've missed stuff you've already posted - you'll just have to bear with me.)

So, in this state:

- Make sure you have a new, "no output" track selected, with no plugins, or bus or output routing.
- deactivate master bus plugins, and wait. Does the core use drop to nothing, drop a little, or not change at all.
- deactivate the plugins on one bus track, and do the same observations
- repeat until all bus plugins are deactivated. Is there still active core usage now?

If you can document here what the exact results of those steps are, we can continue troubleshooting.

Also, let me know what your CPU temps are when you start a project with you 20% usage, and what it is when the usage climbs and maximises out, and whether it eases off once the core activity reduces. Honestly, the behaviour you describe in the OP sounds more like thermal throttling issues than anything else. It might be worth googling around macOS and i9 thermal throttling to see if there is anyway this can be monitored. Did you clean out your fans in the end?

Edited by des99

mu:zines | music magazine archive | difficultAudio | Legacy Logic Project Conversion | Logic 10.7.4, MBP 16" M1pro

Link to comment
Share on other sites

Note - if you do want to try a fresh install, I recommend to not do it just by wiping and reinstalling.

Backup your system drive, so you can check out a new system, but if it doesn't help, just mirror your backup back to the system drive and you're back to where you were. Or install a new system to a test drive, leaving your current system intact.

mu:zines | music magazine archive | difficultAudio | Legacy Logic Project Conversion | Logic 10.7.4, MBP 16" M1pro

Link to comment
Share on other sites

I'd take a sample of the Logic process with Activity Monitor when the high CPU usage is seen. Look at the stack traces, you might get lucky and see some labels that point to a specific plugin.

I've seen some plugins ([cough] Amplitube [cough]) continuing to use CPU even after the tracks which instantiate them are disabled. 

  • Like 1

2019 6-core iMac, 32 GB / macOS 12.4 / Logic Pro 10.7.4 / Focusrite Scarlett 8i6 3rd Gen / too many VI plugins / not enough guitars

Link to comment
Share on other sites

It might be some plugin that's not even in use causing a conflict… 

Try the old 50/50 — disable half the plug-ins in Plug-in Manager.

If the issue persists, re-enable that half and disable the other half. 

If the issue persists, it's not a plug-in. 

If the issue goes away, the issue is one of the disabled plug-ins. Re-enable half the disabled plugins. 
If the issue re-appears, disable half of the plugins you just re-enabled. 
If the issue disappears, re-enable half of those plugins. 
If the issue re-appears… etc.

 

Much faster than disabling plugins one by one, if you have a lot of plugins. 

Link to comment
Share on other sites

All very good suggestions. Thankyou all. 
 

I've just done an OS reinstall via Recovery mode, so I'll report back. 
 

🙏🏼

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

22 hours ago, des99 said:

I know you can turn everything off and it stops, but that's not what I'm talking about

Actually, you turn everything off and it doesn't stop. That's my point. Before the OS reinstall, once a core peaked, it stayed there. Now it does drop down somewhat. Here's every track powered off and all mix buss plugins disabled. Four cores still seeing moderately heavy use. Is that expected behaviour? I don't remember this ever being the case previously, but I could be wrong. image.thumb.png.957b223fd23668e801e154aef356bfe8.png

22 hours ago, des99 said:

let me know what your CPU temps are when you start a project

This is another thing that confounds me. Again, here it is after crapping out, nothing playing. Nowhere near throttle territory.

image.png.097873a8f009d0e8a15a4e056c574bb8.png

 

 

 

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

Posted (edited)
50 minutes ago, noisyneil said:

Actually, you turn everything off and it doesn't stop. That's my point.

Ok, wires crossed, I thought you said when you hit stop, after a period of time the cores settled down.

50 minutes ago, noisyneil said:

Here's every track powered off and all mix buss plugins disabled.

I'm confused, because in your screenshot you clearly haven't deactivated your bus plugins, they are all active (in blue, at least on the selected track I can see, the vocals bus), and therefore processing audio - resulting in the CPU use you see, which is entirely normal.

See my very first post to your query up at the top of this post, which states:

On 5/2/2022 at 9:37 PM, des99 said:

Likely though, you *do* have plugins active, and remember that all your plugins on busses and the main mix bus will be active and processing all the time, regardless of whether Logic is in playback mode or not (because you could play an instrument, and audio signal in Logic through the mixer at all times, not just during playback.)

Can you please actually deactivate the plugins so they *aren't* processing or using CPU, and see what happens to the core activity? (The plugin inserts go grey when they are deactivated.)

Edited by des99

mu:zines | music magazine archive | difficultAudio | Legacy Logic Project Conversion | Logic 10.7.4, MBP 16" M1pro

Link to comment
Share on other sites

Posted (edited)
35 minutes ago, des99 said:

Ok, wires crossed, I thought you said when you hit stop, after a period of time the cores settled down.

Well they do eventually but it's like 3-4min, whereas it used to be 3-4sec.

35 minutes ago, des99 said:

I'm confused, because in your screenshot you clearly haven't deactivated your bus plugins, they are all active (in blue, at least on the selected track I can see, the vocals bus), and therefore processing audio - resulting in the CPU use you see, which is entirely normal.

The vocal buss is powered off and the project is idle. My understanding was that powered-off busses didn't use CPU. Apologies if I'm mistaken. Ok then, let's try that again...

All buss processing disabled and all tracks powered off. 

tracks.png

mixer.png

I should add that I have removed all components that aren't being used in this session from my plugin folder, so it's not an unused plugin. Was worth checking of course. 

Edited by noisyneil

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

Posted (edited)
8 minutes ago, noisyneil said:

The vocal buss is powered off and the project is idle. My understanding was that powered-off busses didn't use CPU. Apologies if I'm mistaken. Ok then, let's try that again...

It doesn't matter what's happening in the main window, that's just stopping processing things that happen on the track (which aren't relevant for busses anyway), it's not related to the actual bus objects and plugins for busses. If plugins are active on those busses, they will be using CPU.

8 minutes ago, noisyneil said:

All buss processing disabled and all tracks powered off. 

Ok, you still seem to have significant load somewhere, so it would be good to rule out something we can't see in screenshots.

Can you select "All" in the mixer, not "Tracks", so we can see all the channels in use in your project, rather than just the ones you've added to the arrange window, and also unfold any track stacks to make sure they aren't contributing any CPU load too.

(Also, it might be worth zipping up a copy of the project and adding it here - without media - so I can take a look at it and see what the behaviour with that project is like for me here...)

Edited by des99
  • Like 1

mu:zines | music magazine archive | difficultAudio | Legacy Logic Project Conversion | Logic 10.7.4, MBP 16" M1pro

Link to comment
Share on other sites

Posted (edited)
1 hour ago, des99 said:

If plugins are active on those busses, they will be using CPU.

Ok, riddle me this. This is an template with no midi or audio in it. The tracks are all powered off but all buss plugins are active and the session is playing. Zero CPU use. By your logic, shouldn't the buss processing tax the CPU a bit?

image.gif.c84176329a1517f66f197b21d208eda6.gif


Anyway, that's that's a side-topic, isn't it...
 

1 hour ago, des99 said:

Can you select "All" in the mixer, not "Tracks", so we can see all the channels in use in your project

Ok this threw up something I didn't expect, but I wouldn't think it would be causing CPU spikes. There are a bunch of Grand Piano midi channels. No idea where they've come from! I'll have to post the screenshots in a separate post...

Edited by noisyneil

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

Sorry about the size of the last image... Not sure how to make it upload with the same height as the others. 
1.thumb.jpg.1e68067acdf23902eefa79f726544d28.jpg2.thumb.jpg.7d5688a5587387ecdb957e33261bccbf.jpg3.thumb.jpg.1f5f57c6e46a7168416bf9a52dbc098a.jpg4.thumb.jpg.7c5917ed90976fb8d8827537b49d2d58.jpg

...and finally here's the session file: https://file.io/Da3GoPJ0XP5E

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

Posted (edited)
31 minutes ago, noisyneil said:

Ok, riddle me this. This is an template with no midi or audio in it. The tracks are all powered off but all buss plugins are active and the session is playing. Zero CPU use. By your logic, shouldn't the buss processing tax the CPU a bit?

I'll have a look at your project. Generally, Logic tries to not process plugins when there is nothing for them to do, but with busses the situation is a bit more complex. I can't make any definite statements about what's going on in your project yet - so I don't have a response to that specific query.

best guess - when you hit play after you load a project, if tracks have zero audio or activity, Logic doesn't even turn the plugins on, until you at least send some audio through it - so in this case, it might be that simply Logic hasn't needed to actually turn anything on yet. Try and add a short sample something that sends to the outputs and through some busses, and you might then see CPU ramp up.

31 minutes ago, noisyneil said:

Ok this threw up something I didn't expect, but I wouldn't think it would be causing CPU spikes. There are a bunch of Grand Piano midi tracks. No idea where they've come from!

Probably just generic environment objects in your session, and likely nothing to worry about.

Bear with me, and I'll see if your project throws up anything...

Edited by des99

mu:zines | music magazine archive | difficultAudio | Legacy Logic Project Conversion | Logic 10.7.4, MBP 16" M1pro

Link to comment
Share on other sites

Posted (edited)

I had a quick look, and I can't find anything that looks suspicious. Of course - there's probably a good half of the plugins used in that project I don't have, so I'm not going to see the same load you see anyway.

With the few active Valhalla reverbs, the small CPU load from those busses continues for a few seconds after I press stop which the reverb is processing, but then I guess those plugins stop processing once the tails are done and there's no more audio at the inputs. Then it goes to just a slight flicker of activity in stop, as most of the plugins are deactivated in the loading state of the project etc.

Out of interest, when you are running that project, what's your memory pressure? (check Activity Monitor's memory tab).

1 hour ago, noisyneil said:

All buss processing disabled and all tracks powered off. 

I noticed in this screenshot, you have your Keys track selected, which I think is a software instrument layer with a lot of plugins - make sure you *don't* have an instrument track with live plugins selected, as those plugins will also be active and ready for live playing, and thus consuming CPU.

Select a non-active audio track instead - does that make a difference to the CPU load you see?

 

 

Edited by des99
  • Like 1

mu:zines | music magazine archive | difficultAudio | Legacy Logic Project Conversion | Logic 10.7.4, MBP 16" M1pro

Link to comment
Share on other sites

Thanks for sticking with me on this. It's very much appreciated!

Here's something I didn't expect. All these instruments are on tracks that are powered off, but they're using tons of CPU when idle. Of those instruments, Ovox seems to be a real CPU-muncher! I don't get it though... these tracks are powered off!

all.gif

ovox.gif

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

16 minutes ago, David Nahmani said:

For animated .gifs I use LiceCap and that produces normal size animations: https://www.cockos.com/licecap/

I use Screenflow, which is fine. I was talking about the screenshot, not the gifs. Thanks though, I'll check it out. :-)

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

Posted (edited)
13 minutes ago, noisyneil said:

Thanks for sticking with me on this. It's very much appreciated!

No worries - it helps us all learn stuff sometimes too!

13 minutes ago, noisyneil said:

Here's something I didn't expect. All these instruments are on tracks that are powered off, but they're using tons of CPU when idle. Of those instruments, Ovox seems to be a real CPU-muncher! I don't get it though... these tracks are powered off!

If an *instrument track* is powered off, it means no regions on that track will be sent to the plugin to play. If it's not in live mode (selected), there will be no CPU use.

However, if you have *selected* that track, then the instrument will be ready for live playing at any time (in "Live Mode") - and thus consuming CPU. Turning a track off does not prevent the instrument from being played via a keyboard, and does not stop CPU use.

lpx2.gif.ed53b990b8770702098da10061039975.gif

 

Only deactivating the plugin on a selected instrument track will turn the plugin off completely and consume no CPU.

Edited by des99

mu:zines | music magazine archive | difficultAudio | Legacy Logic Project Conversion | Logic 10.7.4, MBP 16" M1pro

Link to comment
Share on other sites

4 minutes ago, noisyneil said:

I was talking about the screenshot, not the gifs. Thanks though, I'll check it out. :-)

The only one I see that's not the normal size is a .gif. 

Oh if you meant the one of the MIDI channel strips that is narrow and tall, that's normal, that's not reduced in size because there's enough width in the forum to display it. 

My new Logic Pro Book is out!

Link to comment
Share on other sites

6 hours ago, des99 said:

what's your memory pressure?

bead9cfa926592fadbc6cfa4258bb0262ee4bc2c.jpg.0622cb5a8e6fac3c069d173df48085ec.jpg

This is with all tracks enabled. I have 32GB RAM. 

6 hours ago, des99 said:

those plugins will also be active and ready for live playing, and thus consuming CPU.

Even when all those tracks are powered off? Seems like I don't really understand what powered off actually means!

 

6 hours ago, des99 said:

make sure you *don't* have an instrument track with live plugins selected

In the example you're referring to, all the tracks are powered off. The powered-off keys stack was selected, but I've had the same results when purposely selecting a powered-off audio track too. (See below.)

Screenshot_2022-05-18_at_16_27_35.png

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

14 minutes ago, des99 said:

However, if you have *selected* that track, then the instrument will be ready for live playing at any time

Yeah, which is why I'm surprise that Ovox, which isn't selected, is spiking the CPU like that. 

Logic Pro 10.6.3 - 16" Macbook Pro - 2.4 GHz 8-Core Intel Core i9 - 32GB RAM, 2TB SSD - AMD Radeon Pro 5500M 8 GB - macOS Catalina 10.15.7 - UA Apollo 8P

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...