Jump to content

Audio when recording way out - needs low latency mode


Stoobysnax

Recommended Posts

I’m a 15 year Logic Pro professional user, and never in my 15 years have I stumbled across this, but on my new M1 / Monterey system, if I’m recording any audio, a vocal let’s say, after recording the audio is way off. 

If I turn on low latency mode while recording, everything works and lines up.  But I’ve never had to do that before and it’s annoying because if you forget, some takes line up and some don’t. Any ideas why this is all of a sudden happening? Solutions?

Link to comment
Share on other sites

This is happening because you're using a plug-in that creates latency, which you may have never done before. You've described the solution to your own problem: the Low Latency mode, that is designed to solve that issue when recording while using latency-inducing plug-ins. The only alternative is to not use any latency-inducing plug-ins during recording. 

Link to comment
Share on other sites

4 hours ago, David Nahmani said:

This is happening because you're using a plug-in that creates latency, which you may have never done before. You've described the solution to your own problem: the Low Latency mode, that is designed to solve that issue when recording while using latency-inducing plug-ins. The only alternative is to not use any latency-inducing plug-ins during recording. 

No this is the point I'm making. I'm using the same methods, doing the same things I've always done. opening the same sessions. On my previous systems, I've never ever had to engage Low Latency while tracking audio. Only used low latency to be able to play soft synths without a huge noticeable latency. 

All of a sudden on this system, I'm having to use it. Something has changed, and I can assure you it's not that I'm using higher latency plugins all of a sudden. 

Are you saying you've always had to use Low Latency mode engaged when recording any audio in order to avoid this?

Edited by Stoobysnax
Link to comment
Share on other sites

Just now, Stoobysnax said:

Are you saying you've always had to use Low Latency mode engaged when recording any audio in order to avoid this?

No, I use Low Latency mode only when I have latency-inducing plug-ins in the project and I'm recording something. For me, this happens rarely, as I generally try to complete all recording before using latency-inducing plug-ins. If it happens it's because I'm already in the advanced stages of mixing and determine there's something more that I need to record (or fix). 

Can you measure exactly how much delay you're getting when recording? You can for example record your Metronome back into your current session or an empty session to run some tests. In the Tracks area, choose View > Secondary Ruler and in Logic Pro > Preferences > Display, set Display Time as to Hours : Minutes : Seconds . Milliseconds. Then drag the Marquee tool to select the delayed section and get a reading in ms (for example 7ms here): 

image.png.6cbb7c4defd8e1fd531ffc782bd0a88e.png

  • Like 1
Link to comment
Share on other sites

31 minutes ago, David Nahmani said:

No, I use Low Latency mode only when I have latency-inducing plug-ins in the project and I'm recording something. For me, this happens rarely, as I generally try to complete all recording before using latency-inducing plug-ins. If it happens it's because I'm already in the advanced stages of mixing and determine there's something more that I need to record (or fix). 

Can you measure exactly how much delay you're getting when recording? You can for example record your Metronome back into your current session or an empty session to run some tests. In the Tracks area, choose View > Secondary Ruler and in Logic Pro > Preferences > Display, set Display Time as to Hours : Minutes : Seconds . Milliseconds. Then drag the Marquee tool to select the delayed section and get a reading in ms (for example 7ms here): 

image.png.6cbb7c4defd8e1fd531ffc782bd0a88e.png

I can do that for sure when I'm in the studio. But it's not a slight "just a few hundred or thousand" samples thing... it's like, an entire 1/4 note, noticeably completely off of the grid.

And I regularly am cutting vocals near the end of a project, with a ton of plugins including latency inducing plugins on the master bus. And like I said, I have never had to turn it on before and things have always lined up just fine. but now on the M1, it's way out. Just trying to sort out what is different. (Monterey, apple silicon, etc?)

Link to comment
Share on other sites

37 minutes ago, David Nahmani said:

Ugh... yes indeed that's a LOT. 

Yes it's a ton... Sometimes even half a bar off. Now, I run big sessions, with lots of UAD, and lots of stuff on the master bus that is latency inducing... But the point is, prior to this, that wasn't an issue with recording audio. It somehow compensated for that and dropped it in perfectly in time. Not the case anymore.

I guess what I'm wondering is, is this a Monterey thing? A logic thing? An M1 thing? or a setting thing in logic? It's driving me nuts cuz I hate having to constantly remember to turn on / off Low Latency... if you are quickly going back and forth between tracking and mixing, its so easy to forget and then you lose the proper timing of the performance. 

Edited by Stoobysnax
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...