Jump to content

Logic 10.7.3 and plugin keystroke handling problem

Go to solution Solved by spride,

Recommended Posts

In Logic 10.7.3 (and maybe below but I've only been using Ableton for the last year or so), if I have a plugin window open and then try to perform keyboard actions within it, for example, searching for a preset using the plugin's search feature, or naming a new preset as I save it, the keystrokes are not sent to the plugin window but to Logic itself, thereby triggering unwanted actions such as play/stop and even deleting regions. 

I've checked a number of plugins from different mainstream manufacturers (Arturia, Cherry Audio etc) and they all behave similarly. Is anyone else seeing this behavior? 

MacBook Pro M1Pro /  macOS 12.3.1 / 32GB RAM / Logic 10.7.3 / all plugins up to date.

Link to comment
Share on other sites

Can you give some specific examples of plugins that do this? (Rather than listing manufacturers with many plugins).

Usually keyboard handling when a plugin window is focused is the responsibility of the plugin to handle (they usually "steal" the key presses that they handle, and then pass the unrecognised key presses on to the host).

I have the Arturia stuff, and a couple of Cherry stuff like the Quadra, and I've not noticed this behaviour as such, so if you can give me one or two to check out, I'll take a look...

  • Like 1
Link to comment
Share on other sites

So I have some more information which may be useful. This seems to occur when you have the plugin window on a different display than Logic. 

Steps to reproduce:

  1. Open the Plugin window
  2. Move it to a different display from the one where Logic is running
  3. Try to enter text and the keystrokes go to Logic, not the plugin window, despite the fact that the plugin window has the white focus outline

Steps to resolve:

  1. Move the plugin window back to the same display as Logic
  2. Close the plugin window
  3. Open the plugin window
  4. Text entry behaves as normal

Can anyone with two displays or more confirm what I'm seeing?

Edited by spride
Link to comment
Share on other sites

I'll check shortly...

Edit: I couldn't reproduce this, and I tried both ways.

Regardless of which display Logic was on (MBP screen, or external monitor), with the plugin on the other one, the plugin always received my text input when it was focused.

Edited by des99
Link to comment
Share on other sites

15 minutes ago, spride said:

Curiouser and curiouser. I'll try to make a video to show the effect.

I'm not doubting you're seeing this, btw.

11 minutes ago, spride said:

and of course I can't reproduce it now

Which suggests this issue is not a simple, easily reproducible one that affects everybody, but is some bug where Logic, or some plugin, gets into a weird state that causes this issue - which makes it a lot harder to track down, and find a way to 100% repeatably reproduce it.

Link to comment
Share on other sites

It's a popular framework in service management and related disciplines for determining root causes of problems when there's no obvious one.  It asks questions like:

  • Where is it happening?
  • Where is it not happening?
  • Where could it be happening but isn't?
  • When is it happening?
  • When is it not happening?
  • When could it be happening but isn't?


The idea is to force you to look at all aspects of the problem rather than yielding to your biases and habits.

  • Like 2
Link to comment
Share on other sites

  • 8 months later...

Having the same problem, but with Komplete Kontrol / Kontakt 7 for the search feature when using within Logic. It activates Logic commands and nothing gets typed in the search bar. This doesn't happen when launching either Komplete Kontrol or Kontakt software as standalone apps. It works fine then. Have rebooted a few times to no avail.

Link to comment
Share on other sites

3 minutes ago, des99 said:

Yes, Kontakt 7 for sure behaves like this. You should report it to NI as a bug...

Funny...that's where I started...on the NI forum. There is a post there about it as well. But thank you. I will definitely trying to contact them.

  • Like 1
Link to comment
Share on other sites

I emailed support at NI and they responded that it's a known issue and that developers are currently working on it. They recommended closing and reopening either the Browser or Kontakt window and that it would restore focus. That hasn't been the case so I suppose it's up to them at this point.

Screenshot 2023-01-30 at 12.36.07 PM.png

  • Like 2
Link to comment
Share on other sites

Update from Native Instruments regarding this...



Niall (Native Instruments) 

Jan 31, 2023, 11:48 GMT+1 

Hi James,
when we were able to reproduce this here, the first search would function, but the next search would trigger the transport controls. But closing and reopening the Kontakt window would allow us to make a search again. 
If I understand you correctly, you are saying that you cannot complete even one search.
I'll certainly pass on this info to the devs.
I don't have a time-frame for a possible fix but it is a high priority topic so shouldn't be too long.

Best regards,


  • Like 1
Link to comment
Share on other sites

  • 1 month later...

I have the same problem here with Kontakt 7.2 and Logic 10.7.7. 
First input to search field works, after that keyboard input is forwarded to Logic.
Does anyone know any workaround or solution in the meantime ? (except closing the kontakt window and reopening it).

Edited by HoraceWimp
Link to comment
Share on other sites

  • 2 months later...

Well it's the 2nd of June 2023 and the problem is still there in multiple plug ins.

Kontakt 6 & 7
Arturia Pigments and Analog Lab but not in Jupiter V (haven't tried them all)
All of Cherry Audio are working fine, so are all of the U-he plugs.

Haven't checked all my plug ins but it's bizarre it happens in some and not in others especially from the same manufacturer.

And no fix inside or even acknowledgment from the mothership.

On a side note, I'm glad we now have Logic for iPad, because we all love working with tiny screens.... 🤪

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...