Jump to content

Settings for switching PDF pages in Mainstage


ahutnick
 Share

Recommended Posts

Hi, I assigned one of my pedals on my Casio PXS-3000 the soft pedal to switch to the next page in Mainstage. I did get it to work but when I press the pedal once instead of going to the very next page it goes 2 pages instead of one. I did try changing some of the settings but it didn’t make any difference. Any help and or suggestions of settings would be greatly appreciated. Thanks!

Link to comment
Share on other sites

Posted (edited)

If you followed the proper range mode in the procedures, I’d guess that your pedal is probably triggering the page-turn once on pedal down and another one on pedal up (release)…

If that is the case, I would explore ways to modify (or filter out) the pedal release event, or transform it altogether.

Edited by Atlas007

LogicPro 10.7.4, MainStage 3.6,
MBPro 17", Core2Duo, 8G, OSX 10.12.6, MacPro, Xeon 6Cores, 64GB, OSX 10.16.1,
ULN8, MOTU MIDI TP-AV, C4, MCU Pro, KorgNano, Novation SLMkII, Several vintage gear
AAS, NI, Celemony, Spectrasonics, Korg, Arturia, etc..., PC, iPadPro 5th gen 12.9”(Duet D., V-Control & LogicRemote), AtariST(Notator SL),

Link to comment
Share on other sites

Thanks for your reply to my question. I wonder if using USB instead of MIDI might be causing this issue. I also tried using the button on my Korg NanoControl to switch pages with the same result as using the pedal.

Link to comment
Share on other sites

What (precise) MIDI event is used to trigger the page-turn?

LogicPro 10.7.4, MainStage 3.6,
MBPro 17", Core2Duo, 8G, OSX 10.12.6, MacPro, Xeon 6Cores, 64GB, OSX 10.16.1,
ULN8, MOTU MIDI TP-AV, C4, MCU Pro, KorgNano, Novation SLMkII, Several vintage gear
AAS, NI, Celemony, Spectrasonics, Korg, Arturia, etc..., PC, iPadPro 5th gen 12.9”(Duet D., V-Control & LogicRemote), AtariST(Notator SL),

Link to comment
Share on other sites

Controller 67 soft pedal. After following the instructions in the manual depressing that pedal still skips a couple of pages. I’m using The Sheet Music Page Turner file. I don’t have a MIDI keyboard presently to check if it’s using USB that’s causing the issue. I was using a cheap Insiginia USB powered hub so I switched to IConnect MIDI 4 with no difference. I’m using a MacMini M1 running Big Sur 11.6.6

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...