Jump to content

Simple MIDI piano project... pedal going crazy!


Recommended Posts

Hey guys

My partner is a piano teach and has been recording some piano accompaniments in Logic over the past few months. 

I've set her up with a simpler setup than my studio... just Logic (latest version) running on her 2018 MacBook Pro. Her projects are very straight-forward, often just one track in the project - using the Native Instruments Grandeur piano. Sometimes she'll record additional tracks with other MIDI (for example, a guitar).

In several of her recent projects, she's gotten part way through recording the piano MIDI part, perhaps edited some of the MIDI (although not always), and then started recording additional piano on the same track. She is always very careful to ensure that there isn't a "pedal-on" event before the point where she's dropping in the new MIDI.

The issue that keeps occurring is basically a failure of the pedal-on/pedal-off messages to happen at the right place. So a whole phrase with quick on/off of the pedal might only record a long pedal. Or sections which were supposed to have pedal have nothing at all. The result is that the new section sounds like a mess, pedal-wise. With no way to rectify the problem, we have to simply start a new project. Sometimes, the piano parts are complex, and as a new Logic user, my partner's finding it discouraging!

We've checked her hardware (including a pedal swap-out), and it doesn't seem to be hardware-related. Some whole projects are fine, without this occurring. 

I know my way around Logic well, having used it for several years, and I'm completely stumped by this issue. 

I'd love ANY suggestions as to where we can start. 

Thanks heaps guys,

Mike

Logic Pro X 10.5 | MacBook Pro 2.4GHz 8 core | RME UFX | Event Opals  Yamaha HS8s | Nord Stage 2 | Novation Summit | Korg Kronos 73 | Kurzweil PC361 | Nord Wave | Kurzweil Forte | Wurly 200A | Roland TD-12 | Mason & Hamlin grand piano

Link to comment
Share on other sites

Try turning off Midi Chase for sustain in project settings ? It's known to be buggy...

Logic Pro 10.5.1 • OS X 10.14.6 • MBP 15" Early 2013 • 2.4 GHz Intel Core i7 • 8GB RAM • iMac 27 Late 2013 • 3.4 GHz Intel Core i5 • 16GB RAM • Focusrite Saffire 6 USB • cheap midi keyboard • Korg NanoKontrol • Roland UM-One mkII • Behringer FCB1010 • Gibson ES335
Link to comment
Share on other sites

21 minutes ago, JakobP said:

Try turning off Midi Chase for sustain in project settings ? It's known to be buggy...

Thanks heaps - I've just done that. (Seems sustain chase is a subset of note chase, now... but I've unticked the box). 

I'll see if that makes a difference. Thanks for the suggestion!

Mike

Logic Pro X 10.5 | MacBook Pro 2.4GHz 8 core | RME UFX | Event Opals  Yamaha HS8s | Nord Stage 2 | Novation Summit | Korg Kronos 73 | Kurzweil PC361 | Nord Wave | Kurzweil Forte | Wurly 200A | Roland TD-12 | Mason & Hamlin grand piano

Link to comment
Share on other sites

1 hour ago, Sequentialist said:

Thanks heaps - I've just done that. (Seems sustain chase is a subset of note chase, now... but I've unticked the box). 

 

Since sustain = midi cc64, this is the box to uncheck: 

126764886_MIDIChase.thumb.png.c36ee89807c73a22a5b017f834a3e851.png

  • Like 1
Logic Pro 10.5.1 • OS X 10.14.6 • MBP 15" Early 2013 • 2.4 GHz Intel Core i7 • 8GB RAM • iMac 27 Late 2013 • 3.4 GHz Intel Core i5 • 16GB RAM • Focusrite Saffire 6 USB • cheap midi keyboard • Korg NanoKontrol • Roland UM-One mkII • Behringer FCB1010 • Gibson ES335
Link to comment
Share on other sites

Done!

Let's see if that helps. 

Thanks so much!

Mike

 

Logic Pro X 10.5 | MacBook Pro 2.4GHz 8 core | RME UFX | Event Opals  Yamaha HS8s | Nord Stage 2 | Novation Summit | Korg Kronos 73 | Kurzweil PC361 | Nord Wave | Kurzweil Forte | Wurly 200A | Roland TD-12 | Mason & Hamlin grand piano

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...