Jump to content

Customize Control Bar options greyed out.


Cappy
 Share

Go to solution Solved by Cappy,

Recommended Posts

For some reason many of the options in the transport area of “customize control bar and display” are now greyed out. I cannot select capture recording (although I discovered that shift R still captures regardless of play head moving when using a midi keyboard, pretty cool). I feel like I had this problem years ago but can’t remember the fix. I miss having the additional record button with the circle around it for this function. Any help appreciated. 

Link to comment
Share on other sites

  • Solution

Thanks for the reply. I too have a nektar keyboard (panorama). What ended up working seems like a total glitch. I went to preferences > advanced and disabled and immediately enabled “show advanced tools”. Now all of the transport functions under “customize control bar and display” are totally selectable. I ended up updating to the most current version of logic which required going from Catalina to Monterey (it needs at least Big Sur). The new wording for show advanced tools is “enable complete features”. Hope this helps you not have to disable your control surface in the future. My Nextar’s control surface has been great otherwise. 

  • Like 1
Link to comment
Share on other sites

  • 3 months later...
On 5/30/2022 at 8:34 PM, Cappy said:

Thanks for the reply. I too have a nektar keyboard (panorama). What ended up working seems like a total glitch. I went to preferences > advanced and disabled and immediately enabled “show advanced tools”. Now all of the transport functions under “customize control bar and display” are totally selectable. I ended up updating to the most current version of logic which required going from Catalina to Monterey (it needs at least Big Sur). The new wording for show advanced tools is “enable complete features”. Hope this helps you not have to disable your control surface in the future. My Nextar’s control surface has been great otherwise. 

I have the same problem here. It comes randomly and force me to disable and enable the advanced mode. I have no idea why logic is acting like this.

Link to comment
Share on other sites

I believe it is because you are choosing to customize the control bar and display when it is configured for for one of the other options. If the display is configured for custom - and then you choose customize the  then all options should be selectable.  See images below -  and if that is a solution to the described problem or if it is another issue beyond what is pictured below. 

Screen Shot 2022-09-26 at 3.29.28 PM.png

Screen Shot 2022-09-26 at 3.29.16 PM.png

  • Like 1
Link to comment
Share on other sites

Funny how this thread popped up a day or two after I've been dealing with the *exact* same issue in another thread (and I found the same workaround above)!

I had the same thought about the control bar being in another mode and trying to customise it, but that is not the issue. It does seem this is a genuine bug...

Link to comment
Share on other sites

well it very well may be a real bug - when I tried to reproduce without being in the custom display mode ( which is only because I am at work and normally always use the custom display setting and wouldn't have noticed it) - I was surprised when it was dimmed but toggling advanced on/off didn't produce a different result - so thought it could be different problem

Link to comment
Share on other sites

It seems to be related to the advanced features - in other words, it thinks some sections of the advanced features haven't been enabled, so those functions are greyed out as not present. It's possible the bug was introduced when they bundled all the advanced features into a single on/off checkbox, and that in certain cases the transport controls are not being correctly enabled.

People experiencing this should definitely report it to Apple, hopefully it will get fixed in the next version...

Link to comment
Share on other sites

 

I feel it is a bug. As the default, my Logic is always on custom mode. It sometimes doesn't show all the features I chose before. When I go to customize the control bar I see they are all grayed out. I have to go back to preferences and toggle off and on to make them available.

I feel it is related somehow to sleep mode or something like that. 

I attached 2 screenshots. see enable complete features is checked and the control bar is on custom but in the next screen shot you will see some of the options are grayed out.

 

Screen Shot 2022-09-29 at 11.45.54 AM.png

Screen Shot 2022-09-29 at 11.46.19 AM.png

Edited by reza sadeghi
Link to comment
Share on other sites

Ok, I think I have found the problem. When my computer goes to sleep mode or screensaver, this issue appears. I opened a new project with all the customized control bar options. I left my computer to go to the screensaver. I came back and realized logic shows no longer the customized bar and all are grayed out.

By the way, the sleep mode is off on my computer and just have a screen saver.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...