Jump to content

Logic freezes on startup, even with no plugins in folder

Go to solution Solved by Atlas007,

Recommended Posts


I am having an issue where Logic Pro X always freezes on startup. It gets to the "choose a project" window and a spinning beachball of death happens until I force quit.

Common wisdom on the internet is that it's a plugin issue. However, I've dragged all components out of the Components folder and am still having the problem.

When this initially happened, I was able to temporarily fix it by deleting "com.apple.logic10.plist" in (hidden) Library > Preferences. This worked for several days. In that time I have bought and installed new plugins. Logic seemed to work fine for a couple days. Now it's happening again, and the fix didn't work. 

This time I've:

  • Moved all components from the Components folder to a different folder.
  • Deleted "com.apple.logic10.plist" file and "com.apple.logic10" folder in (hidden) Library > Preferences.
  • Deleted "AudioUnitCache" folder in (hidden) Library > Caches
  • Restarted computer after doing all of these things

I still have the same problem, although if I delete the preferences file it will take me through a few beginner windows before crashing. One says, "Logic Pro is now testing 38 installed Audio Unit plug-ins to maximize system stability. This AU validation can take some time. Subsequent launches of Logic Pro do not require that test and will be much faster."

I am running a late 2021 16" Macbook Pro with an M1 Pro chip. I am running Monterrey 12.4. Logic is on the newest version as well. 

Any ideas or help would be appreciated!

Edited by Delta
Link to comment
Share on other sites

Booting in safe mode worked! It now seems to be working even when not in safe mode. Thank you!

What does it mean that this solution worked? Does suggest a way I could prevent the problem in the future?

Edited by Delta
Link to comment
Share on other sites

As explained here, it pretty much depends of which option used (among the three) that have solved your issue...



Start without audio
This can be helpful to rule out issues with a specific Core Audio driver, especially if you're using an external audio interface. In some cases, Logic Pro may stop responding or quit unexpectedly while initializing the Core Audio driver. If Logic Pro opens, you might need to update or service your external audio interface.

Audio Units safe mode     
If you have enabled Audio Units that have previously failed the Audio Units validation scan, open Logic Pro in this mode. In this mode, Logic Pro only loads validated Audio Units. The validation scan takes place automatically when Logic Pro is first opened, when an updated version of Logic Pro is installed, and when you install new plug-ins or update existing ones.

Open without automatic startup actions
This opens Logic Pro without automatically loading the most recent project, the Open dialog, Templates dialog, or any other option as set on the Project Handling pane of the General Preferences window. This can help rule out issues that might be caused by the currently loaded project. For further troubleshooting, press the Option key then choose File > New to load an empty default project.



  • Love 1
Link to comment
Share on other sites

I actually think the safe mode thing was a fluke (I used AU safe mode. "Worked" only once). But I think I've found the real problem and essentially solved it.

The problem happens when I have peripherals plugged in, and the computer goes into sleep mode while Logic is running. Then if I close Logic, it will freeze when I reopen it. The problem will persist until I force quit Logic, unplug my peripherals, and open Logic again. Then it works fine and can plug my peripherals back in and use them.

I haven't narrowed down which peripheral it is. It's either my audio interface or USB hub with MIDI controllers plugged in. It's probably the latter because I would assume 2 MIDI controllers on the same USB port isn't be ideal.

Edited by Delta
Link to comment
Share on other sites

I'm starting to see that now, haha. I think not letting it go into sleep mode has fixed some quirky CoreAudio issues I had too. Too bad there's not a way to disable sleep mode only when a particular app is open. Either way, thanks Atlas!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...