Jump to content

Did Smart Tempo break Flextime?


Recommended Posts

I work on lots of music with multiple tempos and it seems that whenever I turn on flextime in these sessions, the tracks go crazy, changing to weird, seemingly random tempos. The solution is that I have to do "Remove Original Recording Tempo" on every track before turning on flextime, which takes a bit of time as logic seems to reload all of my plugins. I typically end up getting it to work but it's really unstable and sometimes takes me over an hour just to get things working right. 

This never seemed to be a problem in the era before "Smart Tempo". I personally have never found Smart Tempo to be useable in any way and I wish there was just a way to turn it off altogether or make it so that "Original Recording Tempo" is just always removed. 

I'm posting this here partly to complain but more hopefully to see if anyone has a better solution for using flextime in sessions with multiple tempos. Is there something I could be doing better?

Screen Shot 2022-06-27 at 9.19.12 PM.png

Link to comment
Share on other sites

a typical workflow would be:

  • I start by recording an artist without a click. The tempo in logic is probably at default 120.
  • Then I open Beat Mapping, analyze transients and manually align bar lines to the correct transients for the whole song.
  • At this point I need to "remove original recording tempo".
  • Next I EITHER move on and start tracking other instruments with the new tempo map. 
  • OR I decide I want to make subtle changes to the tempo of the live take, in which case:
  • I turn on flex time.
  • Hopefully it works and then I have control over the tempo by editing the global tempo line.
  • Now I move on and start tracking other instruments.
  • In either case it seems that new tracks I record often run into issues when I turn on flex and I need to "Remove original recording tempo" again and again. 

This is something that has been happening to me for years and I'm just now posting about it, so I can't say exactly that I'm following that workflow but I think it's pretty much what I do.

Thanks for the response!

Link to comment
Share on other sites

So yes that seems to make sense as the basic premise when working with Flex is that you have to have the current project tempo curve written to the audio file when you analyze the file for the first time (which is done the first time you enable Flex on the track). If you don't have any tempo information embedded then Logic automatically embeds the current tempo curve, which is why it works when you remove tempo information from the file. 

But if the tempo embedded in the file is different from the current project tempo (for example you've recorded at a tempo then you've changed the tempo curve as in your first two steps) then Flex will try to match the tempo in the file with the project tempo, which results in unwanted behavior in your case. 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...