Jump to content

EXS24 Samples Behaving as One-Shots But One-Shot Mode is Not Enabled


ew1
 Share

Recommended Posts

I am using the Roland TR-909 kit in the EXS24

 

The majority of the samples are behaving as if they are in one-shot mode even though in the editor, one-shot mode is not selected for those samples. I want to control the length of the hi hat with the length of the midi notes.

 

Why is this happening and how can I make those samples stop behaving like one shots?

 

Thanks

Logic Pro 9.1.8 • OS X 10.10.5 • 2013 iMac • 3.1 GHz Intel Core i7 • Memory 16GB • Apogee Duet 2

Link to comment
Share on other sites

1 hour ago, David Nahmani said:

Can you attach a project that displays that issue here? 

I have tried but the forum tells me that 1.95 MB is maximum attachment size

Logic Pro 9.1.8 • OS X 10.10.5 • 2013 iMac • 3.1 GHz Intel Core i7 • Memory 16GB • Apogee Duet 2

Link to comment
Share on other sites

1 hour ago, David Nahmani said:

Can you attach a project that displays that issue here? 

I assume that for the session to be of any use, it needs to have the 909 ESX instrument samples contained within it. Those samples are what is making the compressed file too large. If I remove those samples, I imagine the session won't be of much use to diagnose the problem. However, in case I am wrong, here is the session without the samples.

EXS24 problem.logicx.zip

Logic Pro 9.1.8 • OS X 10.10.5 • 2013 iMac • 3.1 GHz Intel Core i7 • Memory 16GB • Apogee Duet 2

Link to comment
Share on other sites

Posted (edited)

For the Roland 909 instrument this is controlled by the Envelope 1 Release ("R") Offset parameter of the group the sample zone is in. For the HiHat it's set to 800, so set that value to 0 if you want to end sample playback quickly when releasing the key.

Edited by polanoid

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.4 / Logic 10.7.4

Link to comment
Share on other sites

On 7/2/2022 at 3:18 PM, polanoid said:

For the Roland 909 instrument this is controlled by the Envelope 1 Release ("R") Offset parameter of the group the sample zone is in. For the HiHat it's set to 800, so set that value to 0 if you want to end sample playback quickly when releasing the key.

That worked. Thanks. The only annoying thing about it is that when you change anything in EXS24 editor, Logic wants you to save that as a new instrument. That's kind of cumbersome  and I've found that when I've done that in the past, sessions have often lost the saved instruments. Is there any workaround for this? It would be great to not have to save the instrument. 

Logic Pro 9.1.8 • OS X 10.10.5 • 2013 iMac • 3.1 GHz Intel Core i7 • Memory 16GB • Apogee Duet 2

Link to comment
Share on other sites

42 minutes ago, ew1 said:

It would be great to not have to save the instrument. 

I don’t understand. Whar would be the alternative?

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.4 / Logic 10.7.4

Link to comment
Share on other sites

On 7/7/2022 at 10:19 PM, polanoid said:

I don’t understand. Whar would be the alternative?

Typically, you are able to save such changes by saving a new patch within the sampler. You would simply go to "save as" within the instrument. I think you can do that with Ultrabeat. But EXS24 requires you to save a new "instrument" any time you make any changes to the sample envelopes.

 

In fact, in many cases you don't even need to save a new patch by doing "save as" within the instrument. If you just save the session, the edit will be saved as session data. I'm pretty Ultrabeat works like this too.

Logic Pro 9.1.8 • OS X 10.10.5 • 2013 iMac • 3.1 GHz Intel Core i7 • Memory 16GB • Apogee Duet 2

Link to comment
Share on other sites

EXS24 does not and can not save its instruments inside the project data. If you want to keep it together with the project make sure it’s saved inside the bundle/project folder.

  • Like 2

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.4 / Logic 10.7.4

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...