Jump to content

Controller Madness

Luminous Muse

Recommended Posts


I've been having multiple problems assigning controllers to Spitfire plugins in Logic over several months. I had them on my M1 MacBook Air and they've persisted on the MacBook Pro m1 Max.

Often after I remove the previous assignment the plugin doesn't see the info coming in from my midi keyboard though It's coming into Logic. Even the mod wheel won't assign - and the virtual mod wheel in the plugin moves.

In libraries using Kontakt whatever I assign a parameter to the plugin volume gets linked - so if I try to control dynamics, for example, the volume slider moves with it. If I remove whatever assignment the volume has it still moves with the other parameter.

Today when I tried to assign controllers to dynamics or expression the virtual slider flashes up anbd down, but no assignment.

I've been on many calls with Apple and Sweetwater, who sold me my keyboard ( a Nektar Impact 88)

I'd love any ideas for a fix!

Link to comment
Share on other sites

How are you assigning your controllers? There are basically two ways to do it: 

  1. Using Logic's control surface assignments.
  2. Using your plug-in's assignment parameters.

Both are not compatible, so make sure you haven't for example used method #1 for a control that you now want to assign using method #2.

To test this you can bypass your control surfaces (under Logic Pro > Control Surfaces > Bypass All Control Surfaces) which disables any assignments you've made using method #1 and makes the MIDI data sent by all your controls available to the plug-in so that you can use method #2. 

Link to comment
Share on other sites

We have had a variety of threads going into this stuff in the past, how there are different ways to use controllers to control Spitfire plugins/instruments (using automation vs using MIDI), and how those methods differ and the consequences of each.

I'm happy to go into this in more detail if you get still seem to have problems getting your system reliable, and I'm sure we can get this resolved and working for you (in addition to learning a bit more about how it works etc).

Link to comment
Share on other sites

Good question. I was try to assign in the BBCO Library and it didn't work with the bypass option either way (though with the bypass on Logic still gets info from the keyboard.) But then I loaded in Albion One and everything worked perfectly. Yesterday it was BBCO that was working and not Albion One.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...