Jump to content

Force legato in MIDI editor works, but only trims notes 99% of the way


gjstuckpig
Go to solution Solved by des99,

Recommended Posts

i tried to figure this out by looking into the forum, but the first thing i found was that Mr. Nahmani posted screenshots of his examples for trimming "Note End To Selected Notes" and "Note End To Following Notes" and his screenshots show the same inconsistency as mine do.  attached is David Nahmani's screenshots from one of the forum pages, my notes trim the same way.  if you focus closely on the screenshots you'll see that the notes go *almost* to the next note but not quite, you can definitely see it when you zoom into the editor.  it's kind of an OCD thing but it's mostly because i can hear the tiny tiny gap in audio with certain sounds.  i know that once i quantize all the notes to the grid, then trim to note end, i can simply drag the ends to trim note ends to my snap value or to the next note and this will fix the tiny gaps.  but it seems like something's wrong with the program or the function.  why would logic trim *almost* to the note end on purpose?  

so just grab 2 notes in the MIDI editor and trim them either way (selected or following) and i bet the note ends will do what i'm describing.  

Screen Shot 2022-08-30 at 11.58.39 AM.png

Screen Shot 2022-08-30 at 11.58.13 AM.png

Link to comment
Share on other sites

ha yeah all my stock logic instruments or Serum or Brainworx or Kontakt or whatever they all trigger when i make the notes meet, i've never needed that gap.  that sucks that logic would make that decision for you without giving you the option.  or that they would call it trim to note but not actually go all the way in the first place.  

so the solution is "deal with it" lol, well thank u polanoid if anyone has a better option i'd love to hear it

Link to comment
Share on other sites

  • Solution

Because if the note off and the next note on happen at the same time, for the same note, it confuses instruments and can cause glitchy and undefined behaviour depending on how the receiving instrument handles that situation - especially with external MIDI instruments, where it takes time to transmit the three bytes for each event over the MIDI bus.

  • Like 1
Link to comment
Share on other sites

sure i understand - but again, surprised there's not at least an option to do a full 100% trim, or a description of what Force Legato actually is.  makes more sense to me to learn that MIDI works better sometimes with small gaps between notes, then have an option to manually create small gaps instead of automatically creating them.  

sidenote - i doubt i can actually hear the small gaps in audio, probably just my mind playing tricks.  

Link to comment
Share on other sites

of course looking wrong is more the issue, because i would alt+shift+drag to make notes same length, then snap to grid at the next note.  then i hear about Force Legato and i think "great here's the super easy way to achieve the same results" and it's not quite there.  i know i'm just being a geek about it but i wish i had the option because it's worked for me up until this point with all instruments.  

however it is easier to accept my fate - i am now an "8 TICK MIDI GAP MAN".  if that causes any issues for me i'll report back.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...