Jump to content

Synthmaster Player with LogicProX - issue each time I launch Logic


reflectingme
Go to solution Solved by des99,

Recommended Posts

Here's a strange one.  I have had a small break from music making and when I returned to use LogicProX once again, I appear to have a Synthmaster Player plug-in causing me grief. Each time I launch LogicProX, I get this message appearing but the unusual thing is, the text entry areas won't allow me to type anything!! I then have to click the red close icon and click a further OK button to get it to disappear.

I've not bought it, as it's the free version of the player, but I have no idea how to remove it and stop this annoying pop-up from appearing every time I launch Logic.

Any ideas please?

Thanks

Screenshot 2022-09-12 at 07.44.54.png

Link to comment
Share on other sites

  • Solution

The dialog box seems pretty self-explanatory. The plugin requires registration, and you need to enter your registration details for it to work.

If the window is not accepting text input, you could try opening the plugin in another host and registering  it there, or maybe updating it if this behaviour is fixed in a newer version, or if you want to delete it, remove its plugin from your plugin folder and it won’t bother you again.

  • Like 1
Link to comment
Share on other sites

Yep it is pretty self explanatory but If I wanted to register and use it, I couldn't lol, because as I mentioned the window is not accepting any keyboard input. Seems pretty useless to me and either a bug or a rather bizarre way of getting someone to pay for the full version!

I have found the offending plug-in and removed it from the relevant library / audio folder 👍

Link to comment
Share on other sites

16 minutes ago, reflectingme said:

Seems pretty useless to me and either a bug or a rather bizarre way of getting someone to pay for the full version!

Yep, clearly it's a bug, either caused by Logic (so only happens in Logic), or in the plugin itself, hence why I suggested to try a different host than Logic to register it, or try to update the plugin in case that bug was fixed in a newer version. Or maybe because your software versions are fairly old (Logic 10.3, El Cap etc).

Basically, I was giving you options in case you wanted to try to get it working, as well as telling you how to kill it...

Edited by des99
Link to comment
Share on other sites

  • 1 year later...

Hey!

Might be a bit late, but had the same problem today when trying to load the plug in into Logic. What worked for me was typing my email on the notes app, copying it and pasting it in the window that won't let you type. Did the same thing with the "name" and didn't have any problems registering it.

Hope it helps!

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...