Jump to content

Automation not getting copied between tracks the usual way.


GeneralDisarray
Go to solution Solved by polanoid,

Recommended Posts

I have smoke coming out of my head like a cartoon right now. That's how frustrated I am. I have two very short regions, they're both audio effects from the FCP ones that you can access in Logic. One region per track, these are audio tracks. I made a simple region volume and pan automation, just 3 keyframes each, one at the beginning, another at the middle, and another one at the end. Then applied some curves using the curve tool. 

I need to copy that to the other region in the track below. But, nothing works. First off, the automation selection tool doesn't work as usual. Instead of dragging like a marquee and selecting the whole automation, you need to click on the different segments of it, one click the first time, and then press shift and click the others. 

But, even after it's selected and copied, what pastes into the other region is not just the automation, it pastes the whole region. I tried this in another project, and it behaves normally. I don't even need to open automation in the tracks in the main timeline, I open the editor for one, select all the keyframes with the pointer, Cmd+C, select the other track, make sure the same parameter is selected, and Cmd+V, and it's done. Then I do the same for the other parameter.

But in this particular project, for some reason, that doesn't work. It behaves really weird. Can you guys think of anything that could be causing this in just one project? I have done this many times, and this is the first time it happens.

 

Link to comment
Share on other sites

2 hours ago, GeneralDisarray said:

First off, the automation selection tool doesn't work as usual. Instead of dragging like a marquee and selecting the whole automation, you need to click on the different segments of it, one click the first time, and then press shift and click the others. 

 I get that behavior when using the Automation Curve tool instead of the Automation Select tool... Both of these tool's pointers look alike...

2 hours ago, GeneralDisarray said:

But, even after it's selected and copied, what pastes into the other region is not just the automation, it pastes the whole region.

I get same result with audio regions.

I circumvent that by converting the region automation (RBA) to track automation (TBA), before proceeding with the copy (Cmd+C) - paste (Cmd+V) commands. If required the TBA could be converted back to RBA afterward.

Link to comment
Share on other sites

12 hours ago, GeneralDisarray said:

First off, the automation selection tool doesn't work as usual

One question: Why are you using the Automation Select tool at all? What benefit does it give you over the regular Pointer Tool? (I'm asking because I suspect the Automation Select tool is used so rarely that it might have undiscovered bugs that no one reported...) Personally I hardly ever use the Automation Select tool.

Edited by polanoid
Link to comment
Share on other sites

12 hours ago, GeneralDisarray said:

what pastes into the other region is not just the automation, it pastes the whole region. I tried this in another project, and it behaves normally.

As far as I know it is not possible to copy Region Automation from one region to another in the Tracks Area, so I'm wondering how that works in another project. I might be misunderstanding you though. Can you provide a video showing what you do?

Link to comment
Share on other sites

3 hours ago, polanoid said:

One question: Why are you using the Automation Select tool at all? What benefit does it give you over the regular Pointer Tool?

Well, I think I omitted something from my post. I normally never use that tool. I use the pointer. I open the editor for that region, drag the pointer to select all the points, Cmd+C, then select the other region (usually in another track right below), and Cmd+V. That's all it takes in any other project. 

But I've been doing some more testing on this, and I narrowed it down to the way Logic treats Track vs Region automation. If I'm in track mode, everything works the way it should. You select automation points, copy them, and paste them on another track just fine.

But what if you want to automate a region, so then you can move that region anywhere in the timeline and it will carry its automation points with it? And what if you have, in another track, another region that may be another loop, but you want the same automation points that you have in the first region, so you can move both together any way you see fit, carrying the automation with them?

So you would do the automation you want for the first one, and then copy and paste it to the second one. But the way Logic works doesn't seem to allow this. I created a new project, and put just these two loops, in two tracks.

Selecting, copying and pasting track automation is a piece of cake.

But, if I create the automation points in region mode, then select them and try to paste them into the region in the track below, it pastes the loop from the first one. Meaning, it didn't just copy the automation points, it copied them along with the audio clip, and pastes both, overwriting whatever was at the playhead.

Maybe I missed something, and after work I'm going to read the manual section on automation to see what I'm missing, but that seems to be the problem.

Link to comment
Share on other sites

  • Solution

So, basically what I wrote: You cannot copy Region Automation in the graphical editors. But that doesn't works in any project, not just in some. Hence my confusion about your initial post.

To copy Region Automation to other Regions you'll need to resort to workarounds.

One way would be what @Atlas007proposed: Convert to Track Automation and back.

Another possibility is to paste into the Event list which I found to be kind of working (it will paste the events at the original position, which is often outside the region, so you will have to drag it to the desired location after pasting).

But generally, it's not easy to copy Region Automation between regions.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...