Jump to content

Comping - beginner lesson! Logic 10.7.4


Go to solution Solved by David Nahmani,

Recommended Posts

Hello again.  Just learning from scratch and learning comping.  I can't see how to select a part of a take with my trackpad.  I've found command + swiping with one finger selects part of the take then when I select part of another take the first one disappears. If I click on my selection I get a yellow keyline around it.  Is that what I should do?

I also found control shift doesn't disable snapping.

Also - I can't see where the Take folder pop-up menu is.

My version doesn't say LogicPro X - just Logic Pro 10.7.4. I'm learning from David Nahmani's book.  Is it a different version?

Thank you. xx

 

 

 

 

 

 

Link to comment
Share on other sites

2 hours ago, Chokkyhen said:

I can't see how to select a part of a take with my trackpad.

You should be able to hold down the left lower corner of your track pad and then swipe left to right on the section of the take you want to add to the main track. This would be similar to the same gesture you'd use to highlight text.

Just make certain that Quick Swipe Comping is selected before you attempt that or your entire take will be selected by default.

950695040_ScreenShot2022-10-06at8_04_37PM.png.937a3cda6c4089035a2c94d215d8f07d.png

Edited by Maestro777
  • Like 1
Link to comment
Share on other sites

Thank you so much!  Mine says 'snap quick swipe comping' but I guess its the same thing.

When I swipe with one finger left to right it moves the entire region and all the takes.  I wonder if my trackpad is set up wrong then?

 

It now occurs to me that Logic Pro X is then same thing as Logic Pro 10!!!!!  Was confused!

 

 

xxxx

Link to comment
Share on other sites

11 hours ago, Chokkyhen said:

I can't see how to select a part of a take with my trackpad.

First, make sure you're in quick swipe comping mode:

Screen Shot 2022-10-07 at 10.29.55 AM.png

... then just swipe. There's no modifier to hold. With the default trackpad settings you should be able to press your thumb on the trackpad and keep it pressed while you drag your index finger to select a part of the waveform.

Personally I prefer to avoid having to press with my thumb. In the system preferences under Accessibility >  Pointer Control > Trackpad Options I enable dragging and set it to three-finger drag. Now I swipe with the index, middle and ring fingers to select a part of the waveform. 

Command-dragging is when you want to use the Marquee tool. That's not for quick swipe comping, it's for classic editing (if you want to select a part to delete it or move it for example). 

11 hours ago, Chokkyhen said:

My version doesn't say LogicPro X - just Logic Pro 10.7.4. I'm learning from David Nahmani's book.  Is it a different version?

If you have my last book (just called "Logic Pro") then the exercises should work as expected with Logic Pro 10.7.4. The "X" was removed from the "Logic Pro X" name with Logic Pro 10.6, same as they turned Mac OS X into macOS. 

Link to comment
Share on other sites

Thank you!  I've just tried thumb and another finger and that's my zoom.  Thumb and two fingers doesn't do anything.  I did as you said with settings (three finger drag) and it achieves the same as one finger.   Now I find two fingers scrolls and four fingers takes me to another page on the mac.

 

 

xx

Screenshot 2022-10-07 at 09.34.39.png

Link to comment
Share on other sites

17 minutes ago, Chokkyhen said:

I think the reason I can now slect with one finger is that I now have the marquee tool and not the pointer tool.

Yes, that's it, you need to revert to the Pointer tool (press T twice). Does it work now? 

5 minutes ago, Chokkyhen said:

I suspect tricky moments like this will pop up as I'm learning and beyond.

No worries, do not hesitate to ask your questions here. 

5 minutes ago, Chokkyhen said:

I may need some one to one help online if you know of a teacher.

Yes, I can offer online teaching sessions. I'll contact you privately. 

Link to comment
Share on other sites

Dare not get too excited just yet but I think it works!  I hadn't waited for the vertical line!  Think that's OK now - I just want to know where this pop up menu is please.

Another problem I had before was removing unwanted audio files as that's a mouse thing as well.  Need that on my lesson list!

xx

 

  • Like 1
Link to comment
Share on other sites

If I right click where you say I get the menu attached (no 'flatten').  Left click gets scissors.  However - I do find 'flatten' when I left click on 'A' as in track A.

Is my version older than yours perhaps?  Anyway - problem solved for now.  I will need to come back if I still can't work out how to delete unused audio.

You have been so kind and I really appreciate it.

 

xxxx

Screenshot 2022-10-07 at 12.24.50.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...