Jump to content

Bug? Setting MIDI In Port -> Control Surface Faders Unresponsive


Marcus Aurelius
Go to solution Solved by Atlas007,

Recommended Posts

Hello, all -

Experiencing strange behavior here which seems like a bug.  Can anyone else reproduce this?

This is using a Mackie Control Universal Pro control surface with Logic latest version (10.7.4)

If I set the MIDI port on a track to a specific source (e.g. a MIDI keyboard controller or whatever), then that channel's fader and pan no longer responses to the Mackie Control fader and pan knob movements.  Oddly, the other direction of communication still works (from Logic to the automation of the fader and pan control on the Mackie Control).  Furthermore, other channel controls still work properly in both directions :  Mute, Solo, Automation On/Off.

Would obviously like to be able to use all the controls even for tracks with MIDI In Ports assigned to other than "All".

Any advice appreciated. 

Link to comment
Share on other sites

According to the documentation:

 

Control change message 7/10 sets Volume fader/Pan knob for channel strips checkbox: When selected, MIDI Control Change message #7 controls channel strip volume and MIDI CC#10 controls channel strip pan position. Enabling this setting might interfere with MIDI plug-ins and Smart Control mappings.

Honestly, I don’t know. Perhaps that is for some (old) control surface or synths used as such?

 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...