Jump to content

Stop music.app randomly *AUTO* launching. How?


Go to solution Solved by David Nahmani,

Recommended Posts

Now and then I find it useful to quickly go through audio files from the Finder using spacebar. Simple easy effective, without having to launch another application which is especially useful if Logic is up. Been doing that for years without issue. But recently while doing that, out of nowhere and at random this music app thing takes over and launches in front of whatever Im doing and there's apparently no way to stop it or prevent it happening from its Preferences. Infuriating and intrusive.

I've never used this app and dont plan on starting.

If anyone has a simple fix to permanently stop it Id be really appreciative.
Thanks.

Link to comment
Share on other sites

  • Solution

The music app launches when you open an audio file - not when you press the space bar. The music app is the default app that opens for audio files and you can change that for another app if you'd like, however you should first try to find out why you're accidentally opening your file instead of pressing the spacebar? 

Link to comment
Share on other sites

@David Nahmani

Thankyou for your response,

The only (default) ways I know of to play an audio file from the Finder is Spacebar, Double Click or Command/O. Im definitely using spacebar to play files. If its something Im doing then all I can think of is an accidental double click when selecting a file with the mouse first before hitting the spacebar as Im a fast doubleclicker.

I agree its better to find whats triggering this before things like considering 3rd party apps.

So far Ive tried:
- to think of everything including if my recent injury is linked, but this behaviour with music app predates that.
- disabling musicapp by restricting it in Screentime but the timer doesn't allow for 24hrs (unfortunately)
- altering the mouse speed so will have to see what difference that makes, if any.
 

Link to comment
Share on other sites

On 10/18/2022 at 5:26 AM, Dynamic_Notes said:

If its something Im doing then all I can think of is an accidental double click when selecting a file with the mouse first before hitting the spacebar as Im a fast doubleclicker.

That's most likely the cause. Happens to me sometimes when clicking between Finder windows and suddenly a double click happened before I hit the spacebar.

  • Like 1
Link to comment
Share on other sites

Thanks for your responses guys. Really appreciated.

Another thing I looked for around the system was if I could change double cllick behaviour, but no, haha that one is well and truly hardwired I think. Hope someone is going to tell me Im wrong and can change it after all.

Id thought of changing the default app in Get Info, but also thought Id have to have a third party app. to make use of that. Didn't think of QT. Of course I'll be trying that. I just hope it gives me an option NOT to auto play. ( Not at my Mac right now). In any case, if it loads then it looks like Im the culprit. In the meantime I'll try and take particular notice what I do when selecting files and see if I can catch myself out. If the files are close together in the finder, I'll just arrow up/down (since hand injury), but if they're spaced apart in a list then its selecting by mouse.

When I researched this a bunch of people were getting annoyed about various things making musicapp randomly auto start, thats what got my antennae up. What they described wasn't exactly my situation. Interrupting phone calls and such, or when they put earphones in, but these were posts 2 or so years ago. I dont use those devices.

Link to comment
Share on other sites

7 hours ago, Dynamic_Notes said:

Yes I looked into some freebie apps and saw vox amongst them. However, QT seems to be all I need. Dont see a preference to not auto start, but it doesn't do that anyway, so good workaround.

i only use vox for the times when i want a playlist, ie 2 or more songs i want to check out (since QT is a single-file player). but QT is my default too, and great not to have every single audiofile imported into the Music app...

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...