Jump to content

Logic Pro 10.7.5 is out!


David Nahmani

Recommended Posts

 

- Resolves an issue where Logic could quit unexpectedly while stepping through presets in the Soundtoys EffectRack.

The last few versions and Soundtoys' M1 plugin updates have had a few issues with presets. The last version fixed most of them, and it was good to see this fix in the 10.7.5 version.

However, it's made it much worse for me 😞

Now, trying to recall any Effects Rack aupreset settings instantly crashes Logic hard, every time. I then checked and found a new Soundtoys minor update, so installed that, hoping perhaps this was addressed, but I still get the same behaviour. However, Effects Rack also does the same recalling it's own rack presets, so I'm hoping this is a Soundtoys issue... will follow up with their support.

But for me, Effects Rack at least is a no-go in 10.7.5 (my other Soundtoys plugins work as expected though.) It recalls presets without crashing in 10.7.4. Edit: And this is just running natively. Running under Rosetta, preset recall is fine.

But hey - this is why we back up previous Logic versions, in case stuff like this happens...

Edit: 10.7.6 resolved this issue, no more crashes on preset switching.

 

Edited by des99
  • Love 1
  • Sad 1
Link to comment
Share on other sites

Oh yeah - as expected because of Ventura and iOS... "Preferences" is no more.

It's now "Settings".

So we have "Settings" and "Project Settings" to deal with, which will no doubt cause a great deal of confusion when explaining where various pref... options... ugh *settings* are.

Yes, your Settings are still stored in the Preferences folder as before. Nothing like enforcing consistency at the expense of, well, consistency, I guess... 😝

  • Like 1
  • Haha 2
Link to comment
Share on other sites

Didn't the plugin delay used to be shown in samples and milliseconds? Now it's only showing ms at a 0.1 resolution, so a hundred milliseconds which is a lot of latency. I can't tell if they've fixed this but not enough or still haven't fixed it. 

Sucks when something has been broken for so long I can't remember how it was, I just remember I'm not happy about it!

Link to comment
Share on other sites

1 minute ago, guavadude said:

Didn't the plugin delay used to be shown in samples and milliseconds? Now it's only showing ms at a 0.1 resolution, so a hundred milliseconds which is a lot of latency. I can't tell if they've fixed this but not enough or still haven't fixed it. 

I can see both samples and ms here: 

Screen Shot 2022-11-02 at 2.10.21 AM.png

Link to comment
Share on other sites

Yes I have that but they changed from milliseconds to seconds, that's what it is. 

You used to be able to tell the latency in ms regardless of how small it was. It's important to me because I try to only use plugins with less than 5ms of latency so I don't ever have to use low latency mode. 

 

  • Like 3
Link to comment
Share on other sites

I'd prefer to know the actual number, in milliseconds like it used to be. It's easier and I work within a range. I'll also prefer certain plugins over others depending on what the reading is at the time. No good reason to dumb it down for people when it used to work fine. 

 

  • Like 3
Link to comment
Share on other sites

Just now, guavadude said:

I'd prefer to know the actual number, in milliseconds like it used to be. It's easier and I work within a range. I'll also prefer certain plugins over others depending on what the reading is at the time. No good reason to dumb it down for people when it used to work fine. 

I agree. The reading in milliseconds was preferable. Not sure why they changed it. 

  • Like 3
Link to comment
Share on other sites

the nested track stacks are great! i can put my lead vocal stack & my background vocal stack (for instance) under one main vocal stack. love that.

and i'll probably use the stompboxes more, now that i can just bring one in without thinking about the whole process.

been playing around for a few hours; no weirdness or crashes or anything (but it's only day 1). still, a great update.

  • Like 2
Link to comment
Share on other sites

Please leave feedback for me on the latency readout. I'm getting tired of using the sample to ms calculator. 

In other news, the free tempo recording is so good and very well implemented. I wish though you could easily get back to all of the options. Seems like you can't get the Average tempo choice back or am I missing something? When I undo it doesn't take me back to the four choices again. 

The free tempo is the kind of thing in a week I'm going to forget it never used to be there. 

  • Like 2
Link to comment
Share on other sites

7 hours ago, Mania said:

Couldn't they make the gain adjustment available without selecting a tool, just like in other DAWs? Or does anyone know if it's possible to adjust the gain without the gain tool if I enable Marquee click zones? (just like the fade adjustment?)

+ Absolutely. defeats the point of fast workflow a bit. To have a 'show click zone' option like Fade, Marquee etc would be great.

 

And after all this time it would have been great to have it like Protools and Studio One implementation with break points. Maybe they are holding it for a future release.

I will probably still use the inspector for overall gain and Region automation with gain plugin.

Link to comment
Share on other sites

21 minutes ago, wonshu said:

Hallelujah!! Keyboard Maestro channel strip loading macros here we come!! 😍

When I am in search mode, up/down arrows to load patches do not seem to work. It always returns to first patch in the list after loading. So only way to change it is with mouse.

Anybody has it different?

Link to comment
Share on other sites

3 hours ago, wonshu said:

Hallelujah!! Keyboard Maestro channel strip loading macros here we come!! 😍

All this new key command does is move focus to the search field, which isn't the hard bit. I've tried pretty much every conceivable route and the one I've opted for is Strip Search, which you'll find HERE.

Looks like they fixed the ⌥-click Channel Strip Settings button bug, where patches wouldn't show up for single instrument tracks. Now that might be very helpful! I see a macro rewrite in my future!

 

Link to comment
Share on other sites

"The Solo Lock key command now toggles off solo lock when pressed a second time."
does this work for anyone? Not here for me, everything is the same here - so pressing the SoloLock KeyCommand a second time has no effect. To disable SoloLock I still have to press Solo, like before.

Link to comment
Share on other sites

41 minutes ago, HoraceWimp said:

"The Solo Lock key command now toggles off solo lock when pressed a second time."
does this work for anyone? Not here for me, everything is the same here - so pressing the SoloLock KeyCommand a second time has no effect. To disable SoloLock I still have to press Solo, like before.

No, that does not work here either. 😞

Link to comment
Share on other sites

14 hours ago, des99 said:

Oh yeah - as expected because of Ventura and iOS... "Preferences" is no more.

It's now "Settings".

So we have "Settings" and "Project Settings" to deal with, which will no doubt cause a great deal of confusion when explaining where various pref... options... ugh *settings* are.

Yes, your Settings are still stored in the Preferences folder as before. Nothing like enforcing consistency at the expense of, well, consistency, I guess... 😝

the way it now is for all apple apps (and undoubtedly, eventually... everything). mail, pages, etc etc all show 'settings'; i expect the next final cut update will do that as well, just as, previously, the system and apps showed 'preferences'. we'll get used to it (i am already, thanks to months of OS betas). 

life is change (or something like that) 🙄

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...