Jump to content

Logic Pro 10.7.5 is out!


David Nahmani

Recommended Posts

24 minutes ago, fisherking said:

the way it now is for all apple apps (and undoubtedly, eventually... everything). mail, pages, etc etc all show 'settings'; i expect the next final cut update will do that as well,

Yep, I know - I'm aware of these things. And I did indeed check last week's Ventura-related FCP update, and was actually surprised it still said Preferences...

7 minutes ago, MikeShapiro said:

Does 10.7.5 require Ventura?

No, as previously mentioned in the thread (and on the App Store), 10.7.5 requires Monterey 12.3...

SCR-20221102-m8u.png.6579edc6a287584492d6c2108b8852fd.png

Edited by des99
  • Like 2
Link to comment
Share on other sites

this is really annoying: all my custom templates lost the 'key signature / project end' info in the control bar. i added it back, resaved the templates... and it's still not there when i reopen the template. (i did reboot).

anyone else seeing this?

will report on the beta feedback app (where it might be seen), and the logic feedback page (aka 'the circular file')...

Link to comment
Share on other sites

54 minutes ago, fisherking said:

all my custom templates lost the 'key signature / project end' info in the control bar. i added it back, resaved the templates... and it's still not there when i reopen the template.

I believe when opening a template, your user default setting for the control bar is used, so try resaving the defaults for control bar ?

Link to comment
Share on other sites

6 minutes ago, JakobP said:

No, was just thinking it could be related to changes made to the CB, e.g. the new record button...

if it's not happening to you... will investigate further. it's on my main 2 templates. will try creating a new template, see if that works. hopefully i can figure something out.

Link to comment
Share on other sites

2 minutes ago, fisherking said:

if it's not happening to you... will investigate further. it's on my main 2 templates. will try creating a new template, see if that works. hopefully i can figure something out.

Oops, feel I'm misleading you here, I'm still on 10.5.1... Sorry for that ! 😄 

Link to comment
Share on other sites

i just made a NEW template, and the display shows. so it's only in my previously-made templates. ugh.

i tried duping one of my templates, and using that, but that display is still not there. i made the control bar settings i want 'as default', set that, saved the template... and it's STILL not showing.

anyone else? and anyone have any suggestions? thanx!

EDIT: i imported EVERYTHING from one of my templates into a completely blank one, saved that... and am getting the 'key sig/project end' showing again. annoying, but fixed.

i have to reselect that parameter to show every time i open a pre-10.7.5 project. still, not a life&death issue... 🙃

Edited by fisherking
Link to comment
Share on other sites

I'm just quickly in to express HOLY F***KING s#!+ NESTED STACKS!!!!! YIPE KAY YE!!!

mfritze and Mike Audio and the rest of the team, you did it!!!!!! WELL DONE GUYS actually looks like i'll be using Logic until I die. soooo happy i stayed with this app while for a decade now others had better nesting but not as good editing. the editing and composing in LP is unsurpassable, now you have the routing too, mixing just levelled up immensely, clap clap clappetyf**kingclap. 

christmas early this year. this is Logic 11 for me!! soooo happy!!!

 

  • Like 2
  • Haha 2
Link to comment
Share on other sites

The only problem I had with this new version so far, is that it's the first time that I have ever seen a wiped plugin cache other than an OS upgrade. It all re-validates (aside from Waves issues) but seems kinda weird how overwriting the Logic app with the update would do that.

Edited by xgman
Link to comment
Share on other sites

19 minutes ago, David Nahmani said:

Definitely, they ARE reading them (I have to confess I'm not sure who "Mike" is). 

Over the years I have received a response from someone named “mike” about 10% of the time I submitted bug reports.  I think it’s a fictitious name used to respond, and not all the time; it’s usually when they are asking for more info such as a test project

Edited by Dewdman42
  • Like 1
Link to comment
Share on other sites

I must say, I like the nested folder-idea, but it doesn't work that well for me. First thing: It's only two levels deep, right? Don't get why it isn't possible to nest even deeper. 

Also, when I'm inside a folder and create sends they sometimes mess the routing up, especially when I „create track" for that send. Suddenly there's a folder of the send with tracks inside. It'a annoying. 

For now I keep my old way: using old school busses for anything routingwise and use folders just for collecting audio, like two or more signals of the same source. That does work. 

Nothing too bad, Logic is a great DAW for the most part and works very efficient. But there are some rough edges, still. Like surround mixing. Like: panning. I/O naming. 

My biggest wish lately would be a batch export function for making stems. It's annoying and inefficient to do everything manually. And an easier way to bounce external MIDI-Instruments.

So, waiting for the next one, while making some music…

 

Cheers

Jan

Edited by jnchristp
  • Like 1
Link to comment
Share on other sites

9 minutes ago, jnchristp said:

I must say, I like the nested folder-idea, but it doesn't work that well for me. First thing: It's only two levels deep, right? Don't get why it isn't possible to nest even deeper. 

Also, when I'm inside a folder and create sends they sometimes mess the routing up, especially when I „create track" for that send. Suddenly there's a folder of the send with tracks inside. It'a annoying. 

For now I keep my old way: using old school busses for anything routingwise and use folders just for collecting audio, like two or more signals of the same source. That does work. 

Nothing too bad, Logic is a great DAW for the most part and works very efficient. But there are some rough edges, still. Like surround mixing. Like: panning. I/O naming. 

My biggest wish lately would be a batch export function for making stems. It's annoying and inefficient to do everything manually. And an easier way to bounce external MIDI-Instruments.

So, waiting for the next one, while making some music…

Cheers

Jan

this all works well (so far) with summing stacks (i have to admit, i've never used folder stacks)...

Link to comment
Share on other sites

5 hours ago, fisherking said:

i just made a NEW template, and the display shows. so it's only in my previously-made templates. ugh.

i tried duping one of my templates, and using that, but that display is still not there. i made the control bar settings i want 'as default', set that, saved the template... and it's STILL not showing.

anyone else? and anyone have any suggestions? thanx!

EDIT: i imported EVERYTHING from one of my templates into a completely blank one, saved that... and am getting the 'key sig/project end' showing again. annoying, but fixed.

i have to reselect that parameter to show every time i open a pre-10.7.5 project. still, not a life&death issue... 🙃

This happened with my templates too.

  • Sad 1
Link to comment
Share on other sites

One new feature I heard about that video s very cool is they finally updated the new track with next midi channel so that when you get to channel 16, doing next channel will increment the port number and rotate back to channel 1.  This now makes it very straightforward to create super large AU3 templates for vepro.  I haven’t tested this yet I just heard about it.  I wonder if they also fixed the problem where too many multi timbral tracks blows up the environment?  I’ll test it tonight 

Edited by Dewdman42
Link to comment
Share on other sites

12 hours ago, dundergufs said:

I'm just quickly in to express HOLY F***KING s#!+ NESTED STACKS!!!!! YIPE KAY YE!!!

mfritze and Mike Audio and the rest of the team, you did it!!!!!! WELL DONE GUYS actually looks like i'll be using Logic until I die. soooo happy i stayed with this app while for a decade now others had better nesting but not as good editing. the editing and composing in LP is unsurpassable, now you have the routing too, mixing just levelled up immensely, clap clap clappetyf**kingclap. 

christmas early this year. this is Logic 11 for me!! soooo happy!!!

Glumly retracting my enthusiasm after actually trying it. Only two levels of nested stacks? Eehhhhh

Okay, two is better than one, but, really, this is just that workaround hack for stacking we found ages ago made "official"! This was a low hanging fruit, devs 😉

 

Hello old friend the feedback form, it's me again. 

10 hours ago, Dewdman42 said:

Over the years I have received a response from someone named “mike” about 10% of the time I submitted bug reports.  I think it’s a fictitious name used to respond, and not all the time; it’s usually when they are asking for more info such as a test project

Same here, I've always assumed it's a pseudonym with a mild pun ("mike", audio, feedback..?)

  • Sad 1
Link to comment
Share on other sites

Hello! New guy here. 😀 Am I the only one – or do others also have a problem pasting Channel Strips to multiple tracks? I have voice over projects with hundreds of tracks, where I need to Export All Tracks as single audio files with each track having its own set of more or less identical channel strip settings. Up until 10.7.4 I could copy the settings from one strip, Select All (cmd+A) in the mixer, and use the key command Opt+Cmd+V to paste these settings to all the tracks at once. A real timesaver. In 10.7.5 that seemingly doesn't work anymore on my Mac (MacBook Pro 2021, M1 Max.)

Anybody else noticed this? Ideas?

Thanks in advance!

Link to comment
Share on other sites

3 minutes ago, Kjell Inge said:

Hello! New guy here. 😀 Am I the only one – or do others also have a problem pasting Channel Strips to multiple tracks? I have voice over projects with hundreds of tracks, where I need to Export All Tracks as single audio files with each track having its own set of more or less identical channel strip settings. Up until 10.7.4 I could copy the settings from one strip, Select All (cmd+A) in the mixer, and use the key command Opt+Cmd+V to paste these settings to all the tracks at once. A real timesaver. In 10.7.5 that seemingly doesn't work anymore on my Mac (MacBook Pro 2021, M1 Max.)

Anybody else noticed this? Ideas?

Thanks in advance!

Not in front of it right now, but this could be as simple as a Key Command changing name convention or similar.

Do a quick search in the Key Command editor to see if it's changed. I have seen this happen previously.

Cheers,

Matt

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...