Jump to content

Record Enable behaviour in Logic 10.7.5


hbadger30
 Share

Go to solution Solved by David Nahmani,

Recommended Posts

Hi there,

 

I just wanted to see if anyone else is experiencing Record Enable behaviour changes. I'm used to Record Enable acting in an XOR type way - when you select record enable on a track, the previous record enabled track is cancelled. However in Logic 10.7.5 the previous record enabled track is not being cancelled meaning I'm recording over tracks by mistake.

If anyone can shed some light as to why this is happening that would be most helpful.

Thanks!

Link to comment
Share on other sites

20 minutes ago, hbadger30 said:

Hi there,

I just wanted to see if anyone else is experiencing Record Enable behaviour changes. I'm used to Record Enable acting in an XOR type way - when you select record enable on a track, the previous record enabled track is cancelled. However in Logic 10.7.5 the previous record enabled track is not being cancelled meaning I'm recording over tracks by mistake.

If anyone can shed some light as to why this is happening that would be most helpful.

Thanks!

The question is - why do you manually record enable tracks at all when the focused track automatically rec enables as soon as you start the recording?

  • Like 1
Link to comment
Share on other sites

23 minutes ago, polanoid said:

that sentence is not correct.

hbadger is describing the XOR type behavior he's used to with that sentence.

So @hbadger30 for software instrument tracks, you can still get that behavior by selecting the track (not actually clicking the R button). For audio tracks however, you can't automatically R-enable the track only by selecting it, you either have to actually start recording on the selected track, or manually click the R button. 

Link to comment
Share on other sites

Hi all,

Thanks so much for the interest and help on this topic. Perhaps the attached video would help show what I'm experiencing better than I can explain it. For this video I just used mouse clicks, no shortcuts in order to record enable tracks. I tried clicking on the 'R' on the track header and then just clicking on the track to select it as per your suggestion @David Nahmani. See how the behaviour is not consistent? It just doesn't seem to be repeatable and that's just between 4 software instrument tracks - imagine a 100+ track session! Is there something I'm obviously doing that's wrong? Apologies the forum restrictions limit the file upload to 1.95Mb and so I can't really show my whole screen.

 

Any help would be most appreciated - thank you!

Link to comment
Share on other sites

When you click an R button, the track stays R-enabled. When you select a track, it becomes R-enabled and doesn't stay R-enabled if unselected. 

Meanwhile Logic determines when to make the R-enabled in "Live Mode" (white "R" letter in a red button) or "Not in Live Mode" (red "R" letter in a light gray button). 

That is the behavior I'm seeing on your video. 

Link to comment
Share on other sites

Hey David,

Thanks for replying! Ok is what you see in the video I posted "Logic working as expected" then? For example at 31 seconds Logic changes the third track from being R-enabled in "Live Mode" (at 26 seconds) to R-enabled "Not in Live Mode" (at 31 seconds) which is not a change I made. At 29 seconds (when the second track is selected) the third track is not R-enabled at all but at 33 seconds (when the fourth track is selected)  the third track is R-enabled in "Live Mode". Apologies if that's normal 'as expected' behaviour but I do not understand the logic behind it.

 

In any case, I'm looking to click 'R' on a track (or select it if I have to) to R-enable in "Live Mode", record on that track, stop recording and then click 'R' (or select if I have to) on the next track down and have the new track R-enable in "Live Mode" but cancel the previous track's R-enable in "Live Mode" status - Is that possible??

Thanks so much!

Link to comment
Share on other sites

29 minutes ago, hbadger30 said:

Ok is what you see in the video I posted "Logic working as expected" then?

It is as far as R-enabling, not necessarily as far as Live Mode given that we don't really know what goes into determining why a track is or isn't put in Live Mode. I can't explain these Live Mode behavior, and I'm not sure if they're bugs or just Logic doing its thing. 

32 minutes ago, hbadger30 said:

For example at 31 seconds Logic changes the third track from being R-enabled in "Live Mode" (at 26 seconds) to R-enabled "Not in Live Mode" (at 31 seconds) which is not a change I made.

I agree that that looks odd and unexpected, but because we don't know what goes into Logic deciding to put a track in Live Mode or not it's hard to tell what's going on. 

34 minutes ago, hbadger30 said:

At 29 seconds (when the second track is selected) the third track is not R-enabled at all but at 33 seconds (when the fourth track is selected)  the third track is R-enabled in "Live Mode".

You manually R-enabled track 3 at 26 seconds, so it stayed R-enabled, so that part is expected. Why it goes into Live Mode at that point however, I'm not sure. 

36 minutes ago, hbadger30 said:

In any case, I'm looking to click 'R' on a track (or select it if I have to) to R-enable in "Live Mode", record on that track, stop recording and then click 'R' (or select if I have to) on the next track down and have the new track R-enable in "Live Mode" but cancel the previous track's R-enable in "Live Mode" status - Is that possible??

Not exactly, but what you could do is select a track and put it in live mode by some other means than clicking its R button, for example press a sustain pedal or send any MIDI info to the track or start and stop playback. Then record, stop recording, and select another track and continue. I know it's not exactly what you want, but that's the closest I can think of. 

Link to comment
Share on other sites

8 minutes ago, triplets said:

The expected behavior should be select the Midi track and it will automatically go into Live Mode.

Thank you for adding that. This is what I was remembering that was different from the current behavior. And since...

1 minute ago, polanoid said:

The erratic Live Mode behavior, by the way, is not new in 10.7.5

.... then that explains why I wasn't able to reproduce what I was remembering in 10.7.4 either. 

But yes I do remember being able to XOR R-enable software instrument tracks into Live Mode by selecting them only as @hbadger30 is expecting in earlier versions of Logic Pro — as long as the transport is stopped. Now I remember that it used to be, the only way a track would not be in Live Mode is is you selected it during playback. 

Link to comment
Share on other sites

Thanks David! That's a really good explanation! Ok I'll let it lie with regards "Live Modes" for the moment. I would love to know what's going on under the hood of Logic here though.

Thanks for the workaround for the end of my post. It just seems so unintuitive! I can't believe I'm the only person finding this is an issue....... I'm feeling like perhaps my workflow is the issue!! How do you record multiple software instrument tracks quickly, flipping from one to another? Is there a better way entirely?

  • Like 1
Link to comment
Share on other sites

1 minute ago, hbadger30 said:

I'm feeling like perhaps my workflow is the issue!! How do you record multiple software instrument tracks quickly, flipping from one to another? Is there a better way entirely?

No, apparently the live mode behavior is indeed a bug after all, and selecting a track should put it in live mode as it used to. 

Link to comment
Share on other sites

2 hours ago, David Nahmani said:

I do remember being able to XOR R-enable software instrument tracks into Live Mode by selecting them only as @hbadger30 is expecting in earlier versions of Logic Pro — as long as the transport is stopped.

I took the time and went through the previous Logic releases and found that it always behaved quite differently than you describe:

- simply selecting/focusing a track did never (at least not after 10.4.5 which seems to be the oldest version that doesn't simply crash on start under the Ventura OS) put a track into Live Mode, regardless of playback or stop mode

- a track always went into Live mode as soon as it received any MIDI data. This is still the case in 10.7.5

- a track that is in Live mode seems to try to retain that mode for some time at least. So, if you bring another track into focus and then go back to the previous track, it's still in Live mode. This is the case in all versions form 10.4.5 until (including) 10.7.5

- Live mode does not seem to be retained indefinitely. Focusing other tracks back and forth quickly using the up and down cursor keys will eventually deactivate Live Mode for a track. Reproducible in all versions from 10.4.5 to (including) 10.7.5

I can only repeat myself here, there is no change in behaviour regarding Live Mode in 10.7.5 compared to previous versions.

Feel free to try in older versions.

2 hours ago, David Nahmani said:

I believe so, yes!

So how would we even report it when the behaviour hasn't even changed?

Link to comment
Share on other sites

Seems I have to slightly correct myself here: Indeed 10.4.5 (and probably older versions if you still have an OS that supports them) through 10.4.8 behave differently:

As soon as a track is in Live Mode (because it received as least one MIDI event), focusing another track will bring that track into live mode.

This behaviour has changed in 10.5.0 (and all later versions). Changing focus from a track that is in Live Mode to another track will not put the latter automatically into Live mode anymore.

So, bug, I guess, but hardly a new one...

Edited by polanoid
Link to comment
Share on other sites

4 hours ago, hbadger30 said:

Perhaps the attached video would help show what I'm experiencing better than I can explain it. For this video I just used mouse clicks, no shortcuts in order to record enable tracks. I tried clicking on the 'R' on the track header and then just clicking on the track to select it as per your suggestion @David Nahmani. See how the behaviour is not consistent?

Here is my video made with 10.4.5. How is that behaviour any more consistent? 

10.4.5 Rec Button.gif

Link to comment
Share on other sites

9 hours ago, polanoid said:

I took the time and went through the previous Logic releases and found that it always behaved quite differently than you describe:

- simply selecting/focusing a track did never (at least not after 10.4.5 which seems to be the oldest version that doesn't simply crash on start under the Ventura OS) put a track into Live Mode, regardless of playback or stop mode

Here it is in 10.4.8. That is the XOR R-enable behavior I remember that @hbadger30 is describing. 

r-enable.gif

Edit: I now see you corrected yourself in a subsequent post. 

Link to comment
Share on other sites

45 minutes ago, David Nahmani said:

Here it is in 10.4.8. That is the XOR R-enable behavior I remember that @hbadger30 is describing. 

That only happens here when I input at least one MIDI note at one point. Is that what you're doing in that video, too? Without any MIDI input it looks like this in 10.4.8 

no live mode.gif

which means my statement "simply selecting/focusing a track did never (at least not after 10.4.5 which seems to be the oldest version that doesn't simply crash on start under the Ventura OS) put a track into Live Mode, regardless of playback or stop mode" is still correct and does not even need to be corrected.

Edited by polanoid
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...