Jump to content

MIDI Feedback Loop Hell using external hardware synth!


caml
 Share

Go to solution Solved by des99,

Recommended Posts

I recently had my old Roland JP-8000 refurbished and was hoping to incorporate it into my Logic set up. However it's been unusable due to what seems to be a midi feedback loop issue. I've researched this online but get nowhere. I have an old Emagic Unitor 8 midi interface (maybe that's one of the issues?). Obviously it is an older piece of gear. Whenever I try to record the JP 8000 into Logic and touch any parameter (cutoff filter etc.) the synth goes absolutely bonkers making all sorts of crazy sounds. It also tends to freeze (the notes). I read online about putting the JP on Local Off but when I do that I obviously can't hear the synth. Is there any setting in Logic Pro that blocks sending midi data back into the JP which seems to be causing this issue? Many years ago when I was using the JP 8000 with Logic I never had any of these issues. I just hooked things up and it worked perfectly. Thanks for any suggestions or comments. I'm not a techy sort of guy which is also part of the problem ;)

Link to comment
Share on other sites

21 minutes ago, caml said:

I read online about putting the JP on Local Off but when I do that I obviously can't hear the synth.

That sounds like you haven't got the Logic routing correct, as with a proper setup, and the synth in Local off, Logic echoes the notes you play back to the synth so you can hear it, without hearing the notes twice - it's the point of local off mode.

How are you routing your synth to a Logic track currently?

Link to comment
Share on other sites

Thanks for replying des99. I'm not sure if I am going to explain this correctly. I created an external instrument track within Logic and chose the appropriate midi channel (I think). I've included a couple screenshots including the environment window. Am I supposed to create an instrument (for the JP) inside the environment? I haven't used the Logic environment in 20 years. That was back when I had multi-timbral synths. Thanks for any more suggestions 🙂

Image 11-16-22 at 12.30 PM.jpg

Image 11-16-22 at 12.27 PM.jpg

Link to comment
Share on other sites

Ok, that's fine. And you don't need to use the Environment at all in the way you're doing it (which is probably the best way for a few reasons.)

So, with that track selected, and with Local turned off on the JP, what happens is, you play the synth keyboard, the MIDI notes go to Logic and to that selected track, are passed to the External Instrument object and then back out on your AMT8 Port 2, on MIDI channel 2.

Assuming your JP is receiving on that port and MIDI channel, it's sound generator will receive those notes and play the appropriate sound.

If you set it up like this, and are not hearing anything:-

- If you record notes to that track and play the track back, do you hear the synth now?

If you *do* correctly hear the synth playing notes, but moving "controls" locks the synth up, check it's manual as some of these synths echo back the received controller movements back to it's MIDI out (ugh!), causing a MIDI feedback loop - turn off "soft echo" whatever it's called on the synth if that's what's happening.

If the synth doesn't have that option in it's menus, post back and I'll look into it further.

Edited by des99
Link to comment
Share on other sites

Unfortunately no luck. I glanced through the online manual since I lost my physical copy and there doesn't seem to be anything helpful. Of course this manual was written around 1993 when Logic and computers were a totally different kind of beast. I did select Local Off and then went through every midi parameter that I could scroll through on the keyboard (switching things on and off to see if I could get any sound with Local Off) but no luck. Just seems the only way I hear the keyboard is with Local On.

Several months ago I purchased a Sequential Take 5 synth and there were issues with that as well. I've decided to sell it for financial reasons. I did email Sequential describing some of the issues and he said definitely I have a midi feedback loop issue going on. He did mention that my old Unitor 8 "could" be an issue and he recommended trying a different interface. In my gut I feel that isn't going to change anything but who knows. Just seems a bit of a pain to order/purchase a new interface and all. I was able to use the Take 5 though in some ways just fine but when it came to using its step sequencer it didn't work at all.

I have an old Virus rack that seems to work fine. Don't use it much but none of the odd issues I am having with the JP and Take 5. Strange.

Thanks again for your patience

 

Link to comment
Share on other sites

6 hours ago, caml said:

I recently had my old Roland JP-8000 refurbished and was hoping to incorporate it into my Logic set up. However it's been unusable due to what seems to be a midi feedback loop issue. I've researched this online but get nowhere. I have an old Emagic Unitor 8 midi interface (maybe that's one of the issues?). Obviously it is an older piece of gear. Whenever I try to record the JP 8000 into Logic and touch any parameter (cutoff filter etc.) the synth goes absolutely bonkers making all sorts of crazy sounds. It also tends to freeze (the notes). I read online about putting the JP on Local Off but when I do that I obviously can't hear the synth. Is there any setting in Logic Pro that blocks sending midi data back into the JP which seems to be causing this issue? Many years ago when I was using the JP 8000 with Logic I never had any of these issues. I just hooked things up and it worked perfectly. Thanks for any suggestions or comments. I'm not a techy sort of guy which is also part of the problem 😉

 

So just to clarify, are you saying that everything works as expected as long as you don't touch any of the synth parameters.  But the minute you touch a synth parameter, everything goes bizerk?

Are you using any smart controls and/or do you have any midi controllers active?

anything non-stock in your environment?

what plugins are you using?

 

  • Like 1
Link to comment
Share on other sites

11 minutes ago, caml said:

Just seems the only way I hear the keyboard is with Local On.

Ok, there's a number of things to troubleshoot here, so if you can check out and answer all the questions I need info for, we'll troubleshoot this for MIDI Input, MIDI Output, and audio monitoring.

So with MIDI Local turned off, and that track selected, when you play the keyboard, you don't hear anything? (This is the first thing to deal with).

How are you monitoring the keyboard? Through Logic? Can you verify, say with headphones on the keyboard, whether it's playing, or not? Software monitoring will need to be turned on in order to hear the synth through Logic, on the external instrument object - and verify it's connected to inputs 1&2 on your interface.

If you *can* hear it via headphones, that means all the MIDI stuff is working, your problem is just monitoring the synth through Logic.

If you can't hear it via it's own headphone output, make sure your MIDI send and receive channel are both set to 2 on the keyboard (which is what you have set in the external instrument - you can try different MIDI channels if you're not sure), and that the MIDI port #2 output on your Unitor is flashing when you press keys (along with whatever input port should be registering).

Can you record notes to the track in Logic, or do you get nothing recorded? Do you see notes registered in the top right had section of the custom control bar display? What MIDI channel are those events coming in on?

Lastly - are you on an M1 Mac, on an Intel one?

 

Edited by des99
Link to comment
Share on other sites

So another way you can go is to turn local mode on... (is that what you just tried?) and then make sure LogicPro is not sending midi to your synth whenever you are playing your keyboard.  You might have to setup an environment switch.

It sounds to me like the sysex is getting in a midi feedback loop.  If your note functionality is working correctly but moving a parameter is not..that tells me that somehow the sysex you send from your keyboard with you adjust a parameter...goes into LogicPro and echos back out to your keyboard...and that is what is causing the problem.  Have to cut that off somehow or filter it out.

 

  • Like 1
Link to comment
Share on other sites

Thanks des99 and Dewdman42. I'll try to address your questions to the best of my ability.

des99 you asked how I was monitoring my keyboard. I'm not 100% sure to be honest. I'm using an Apollo Twin X as my audio interface. So I don't know if that means I'm monitoring my synth through the Apollo or Logic (excuse my ignorance). You asked if I could hear my keyboard (Local Off) with headphones plugged into keyboard. Nope.

You said that software monitoring has to be on in order to hear the synth. I noticed that my software monitoring was not selected so I turned it on. My "External Instrument" for the JP 8000 shows the inputs are 1-2. I'm still not hearing anything through my speakers or headphones (when plugged into the back of the JP 8000).

I'm pretty sure the JP is set to midi channel 2 (when I hit any key the channel two flashes on the Unitor 8). On the JP there aren't really settings for a send and receive. The only options for midi channels say "perform Ctrl CH" (I have 2 selected) and Remote Ctrl CH (I have 2 selected).

You asked if I could record notes in Logic. I can "record" notes but you can't hear anything during playing or playback. You asked if I could see what midi channel was showing on the transport window. I don't see any display showing the particular midi channel. To the left of the CPU/HD meters I see note activity on the top level but it says "No Out" on the bottom. After I recorded a simple note sequence  things went nuts even after I stopped playback in Logic the top level (Midi In) was going effing bonkers!

I'm on an old 2015 Intel iMac on Monterey 12.3.1.

Thanks again for all your help!

 

Link to comment
Share on other sites

Dewdman42 The only way I can hear my synth at all is in Local On mode but it still goes nuts once I touch any parameter or knob on the keyboard. Also if I put the section I play in loop mode the second it repeats the loops things go absolutely nuts.

I'm not using any smart controls but I do use my Native Instruments Komplete Kontrol 88 keyboard as a controller. I don't think there is anything non-stock in the environment. As far as plug ins I have tons so I'm not sure what you mean exactly. I'm not using any plugs at all right now as I speak.

As far as an environment switch I'm not sure how I would approach that. I tried searching all over on the internet to see if there is a way within Logic itself to block midi info from echoing back into my synth but really found nothing.

Thanks for your help and ideas! 🙂

 

Link to comment
Share on other sites

you have two seperate issues that are getting conflated to make things confusing.

Let's take one step a a time.  Local mode on your synth determines whether you will hear sound when you play it, by itself with no sequencer hooked up or anything.  When Local mode is off, then the midi keyboard is disconnected from the internal sounds on your synth...  when you play the midi keyboard the notes go out over MIDI into LogicPro.  and then you have to setup routing so that the midi notes will go through LogicPro and be output to your synth...and the synth will respond to incoming midi making sounds from that, while ignoring the built in keyboard.  

If you have local mode on, then that means you are playing your keyboard and the sounds are happening internally in the keyboard...regardless of what the midi is doing.  But if you route midi through your DAW...and the midi comes back to your synth....then you can have double notes and weird issues...because you'll hear the notes when you play the keyboard internally as well last he keyboard will be responding to what's coming from your DAW over midi.

Which mode you use on the synth depends entirely on how you setup midi routing in LogicPro.  Typically if you have local mode on, then you need to make sure LogicPro will not be routing the same midi notes out to your synth while you are playing in the parts....but only when you are playing back regions...then they need to go out.  Conversely if local mode is off, then you will only hear your notes if you are properly routing midi through in the right way to get there.

That is your first issue that you need to understand completely and get working.

Secondly you have a problem related to twisting parameter controls on your synth and getting weird results. 

 

Edited by Dewdman42
  • Like 1
Link to comment
Share on other sites

So I thought I'd mention this to you just in case it means something that you two might understand. I had a Logic ES2 soft synth loaded on the track above my JP 8000 which I didn't realize. I recorded (with Local Off) an 8th note pattern on my JP and as usual no sound...but I accidentally clicked on the ES2 track and the ES2 started playing what I had recorded on the JP track WTF? Maybe that doesn't mean anything but I don't get that at all.

Edited by caml
Link to comment
Share on other sites

6 hours ago, caml said:

but I accidentally clicked on the ES2 track and the ES2 started playing what I had recorded on the JP track WTF?

That means the midi you send to the synth is echoed back to Logic. Is there a "mid thru" function to turn off on the synth ? To see what midi goes around in your mac I recommend using Snoize's MIDI Monitor, less guessing needed then...

Edited by JakobP
  • Like 1
Link to comment
Share on other sites

It sounds like the JP’s midi echo is causing issues 

 

 

“The JP-8000 does not have a MIDI THRU function. However, it does echo MIDI 
being sent from another MIDI device on the Remote Control Channel. To set the 
Remote Control Channel:

1) While holding Shift press MIDI PRM.
2) Press MIDI PRM several times to call a Remote Ctrl CH display.
3) Using UP and DOWN select a MIDI Channel you wish to transmit on from your 
external MIDI device.”

 

 

 

 

 

  • Like 1
Link to comment
Share on other sites

8 hours ago, caml said:

I'll try to address your questions to the best of my ability.

Thanks - as you've got a few new people looking at this with you, I'll leave it to them to troubleshoot as it gets confusing when different people are giving different instructions and feedback.

I'll sure you'll get it sorted, it's likely a fairly simple config issue, as nothing much has changed in Logic in this regard for a long time.

Edited by des99
Link to comment
Share on other sites

redgreenblue...Thanks for the response. I did as you said and I had already selected channel 2 as my default on the JP (I'm connected to MIDI channel 2 in and out). Still no change in my issue but thanks for the recommendation.

 

Link to comment
Share on other sites

14 hours ago, caml said:

The only options for midi channels say "perform Ctrl CH" (I have 2 selected) and Remote Ctrl CH (I have 2 selected).

 

I'd try to set the "Remote Ctrl CH" to a different channel than the "Perform Ctrl CH", since your synth will echo back the midi received on the "remote" channel,  according to @redgreenblue's post...

Link to comment
Share on other sites

  • Solution
30 minutes ago, caml said:

JakobP I downloaded the MIDI Monitor and from what I gather it's showing that I'm transmitting on MIDI channel 1 even though I'm connected to MIDI channel 2???

The "2" light on the MIDI In Unitor front panel indicates you are connected on *MIDI Port 2*, not MIDI channel 2. The Unitor has 8 different MIDI ports, each capable of supporting 16 MIDI channels.

It looks like you are transmitting on MIDI channel 1, on port 2, so you need to set your MIDI channels to 1 in your external instrument object, as the synth won't react to MIDI channel 2.

  • Like 1
Link to comment
Share on other sites

GOOD NEWS!!! Thanks so much des99 and JakobP! Setting the External Instrument to MIDI channel 1 worked! Of course there me other issues that pop up from this point on but I really appreciate all the time and patience you gave me. I've been using soft synths (no external synths) exclusively for 20 years or so. Never had any problems or need to understand all this MIDI jargon until now with the hardware synths. Thanks again. Happy Holidays. 😊

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...