Jump to content

Logic 10.7.5 and Monterey == Bugfest! Yikes!


favdave
 Share

Recommended Posts

I upgraded my iMac Pro to Monterey from Big Sur and went up to Logic 10.7.5 and had the worst problems for an upgrade ever.

1. Completely deleted one track randomly.

2. Stripped all Presets chosen from 15 tracks, but not all. Kontakt, Nave, and other synths. Kontakt shows blank (as in no sounds selected) and synths went back to the Init patch.

3. Glitchy playback, which seems to have resolved itself.

4. Takes 3 minutes to open a modest project, whereas before it took < 1. 

4. Saved a file and it shows up as zero kb in size in the finder. Nothing in it.

I wish I had never upgraded. 

 

  • Like 1
Link to comment
Share on other sites

Opening a project in an app simply loads the project data in RAM, it does not overwrite the project on your drive, so unless you saved it in its foobared state, the original project is still left untouched on the drive. 

Try to get a copy of your the earlier Logic version you had before you updated and you can open the project in its initial state - except for that project you re-saved and that shows up as zero kb. 

  • Like 1
Link to comment
Share on other sites

2 hours ago, favdave said:

1. Completely deleted one track randomly.

 

Seriously, I doubt this is the case. Can you upload the project where this supposedly happened?

Also, which Logic version did you update from?

Edited by polanoid
Link to comment
Share on other sites

Thanks. I opened an older save from a backup and Reverted to an older save and it is OK in 10.7.5. So I'll keep using it for now and see if it behaves.

I have previous version of Logic available just in case -- 10.7.4.

I've updated my Mac and Logic for many years, and I've never seen anything this bad. I always wait to upgrade my OS until I'm about to be two major versions behind. That's why I upgraded now -- because Ventura is coming out. 

I may have to just wipe the drive and do a clean system install, then install programs/files from CCC.

  • Like 1
Link to comment
Share on other sites

58 minutes ago, favdave said:

Doubting my problem doesn't fix it.

That's why I asked you to upload the project. Logic doesn't delete tracks by itself, so there must be another explanation. Also, if what you describe were actually true, the bass track would still be there when opening the project with an older version of Logic.

Edited by polanoid
  • Like 1
Link to comment
Share on other sites

4 hours ago, favdave said:

Thanks. I opened an older save from a backup and Reverted to an older save and it is OK in 10.7.5. So I'll keep using it for now and see if it behaves.

I have previous version of Logic available just in case -- 10.7.4.

I've updated my Mac and Logic for many years, and I've never seen anything this bad. I always wait to upgrade my OS until I'm about to be two major versions behind. That's why I upgraded now -- because Ventura is coming out. 

I may have to just wipe the drive and do a clean system install, then install programs/files from CCC.

i've heard others report problems with kontakt; might be worth contacting NI about that. is kontakt/NI software all up-to-date?

Edited by fisherking
Link to comment
Share on other sites

4 hours ago, favdave said:

Uh, the bass track was there when I saved it. When I upgraded and opened it, it was gone.

Is that an audio track? When you say the track was gone, is the track actually missing, or only the audio file? Did you get an alert when you opened the project, before you realized that the track was gone? 

Link to comment
Share on other sites

19 hours ago, David Nahmani said:

Is that an audio track? When you say the track was gone, is the track actually missing, or only the audio file? Did you get an alert when you opened the project, before you realized that the track was gone? 

It was a EZ Bass track. So an instrument track, but not MIDI. The instrument was gone.

And no alert.

I've been using computers forever and weird stuff happens. Logic, Final Cut, Premiere, and more since the '90s. 

I've been using 10.7.5 and that (restored from saved) project for a few days nonstop. There have been no more weird things like that. I did Disk First Aid on all my discs, and even checked for viruses (yeah, pretty unlikely). I also zapped the PRAM since it's an Intel Mac. 

If it goes bad again, I'll do a clean system install and restore files from backups.

  • Like 1
Link to comment
Share on other sites

19 hours ago, fisherking said:

i've heard others report problems with kontakt; might be worth contacting NI about that. is kontakt/NI software all up-to-date?

Yeah, the NI software hub makes it easy to stay up to date, so I do. It's Kontakt 7, the latest. Kontakt always has the odd glitch here and there. 

Since I restored from backup, it's been behaving itself. My iMac Pro with 64 gigs of RAM is only using about half the CPU power in Logic now. Sometimes with a lot of Kontakt and other VST instruments open it overloads the CPU. Which means I have to man up and make a decision about some tracks and bounce them!

23 hours ago, polanoid said:

That's why I asked you to upload the project. Logic doesn't delete tracks by itself, so there must be another explanation. Also, if what you describe were actually true, the bass track would still be there when opening the project with an older version of Logic.

The bass track was there in the backed up version. I actually did not reinstall older Logic and try opening the borked file. Since it's all working now, I won't bother.

Just random computer weirdness, i guess.

  • Like 1
Link to comment
Share on other sites

On 11/23/2022 at 11:22 AM, favdave said:

4. Saved a file and it shows up as zero kb in size in the finder. Nothing in it.

That is a error. The file management routines are incomplete.

1496813624_Screenshot2022-11-25at12_02_29.png.20d79ef2a744bbc2520f003991622da8.png

They occur every time I open a file from somewhere and close it without saving. These should be temporary work files that are created when the project is opened and contain the information that was in the actual project file. Instead, they should appear in the folder where I open the file.
On saving, their information is copied to the actual project file, and on closing, they are deleted. Unfortunately, they are retained. There is no other way but to delete them by hand.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...