Jump to content

Issues with Chapter 9


Recommended Posts

I'm working through the book and learning a lot. Running into some issues with Chapter 9, Editing Pitch and Time.

When I drag "slow drums.aif into the audio track, the tempo changes to 123.0011 but there are not tempo changes at bar 2, or bar 26.

The next step, adding the Apple Loop bass worked as described in the book.

Groovy Guitar.wav is not time stretching. I turned on "Set Imported Files to:" before importing the file.

Any ideas what I'm doing wrong?

  • Sad 1
Link to comment
Share on other sites

22 hours ago, mtto said:

When I drag "slow drums.aif into the audio track, the tempo changes to 123.0011 but there are not tempo changes at bar 2, or bar 26.

Apparently the behavior isn't exactly the same now in 10.7.5 as it was in the Logic Pro version I used when I wrote the book (I believe it was 10.7.1). 

What I'm seeing here if I open a Tempo List editor after dragging Slow Drums.aif in step 4 page 390 is a first tempo event of 123.0011 at 1 1 1 1 and another tempo event of 122.9999 at 26 3 1 1. I wouldn't worry about these discrepancies, they shouldn't affect your work in the rest of the exercice. 

22 hours ago, mtto said:

Groovy Guitar.wav is not time stretching.

That one is more annoying. Unfortunately for some reason this version of Logic creates two tempo flex markers in that file when you import it, that misalign the file. Here's how to fix this issue after you drag and drop Groovy Guitar.wav to the track:

  1. Press Command-F to show Flex view. 
  2. Control-click one of the two blue vertical line you see over the waveform, and choose Delete Flex Marker.
  3. Repeat the procedure to delete the second blue vertical line:
    delete-flex-markers.gif

Now you should be able to drag the region to align it with 1 1 1 1 and proceed with the rest of the exercice. Let me know how that works for you? 

Link to comment
Share on other sites

  • 2 months later...
On 11/29/2022 at 4:36 PM, David Nahmani said:

Apparently the behavior isn't exactly the same now in 10.7.5 as it was in the Logic Pro version I used when I wrote the book (I believe it was 10.7.1). 

What I'm seeing here if I open a Tempo List editor after dragging Slow Drums.aif in step 4 page 390 is a first tempo event of 123.0011 at 1 1 1 1 and another tempo event of 122.9999 at 26 3 1 1. I wouldn't worry about these discrepancies, they shouldn't affect your work in the rest of the exercice. 

 

...

Glad I found this as I was just about to post this same question.  And it looks like I'll likely run into the same issue with the guitar file so thanks for posting a fix for that.

I'm curious as in my case the tempo sinly shows 123.0; I do not see anything else and do not see 123.11 as mtto did.  In custom view in the LCD I do see 123.0011.  However, if I select variable tempo, I do see quit a few tempo changes and markers. I also don't see "tempo list editor" mentioned in the book, is this in an older version or 10.7.5?  Can you explain where to find it?  I would like to see these markers as you noted here.

edit - trying to complete this lesson and I get a different problem.  When dragging the Groovy Guitar.wav file into my project, the tempo adapts again and changes to 100, which throws everything off.  I cannot seem to fix this.

 

 

Edited by JimN
additional info
Link to comment
Share on other sites

5 hours ago, JimN said:

I also don't see "tempo list editor" mentioned in the book, is this in an older version or 10.7.5?  Can you explain where to find it?  I would like to see these markers as you noted here.

 

Go to the List pane and click Tempo: 

Screen Shot 2023-02-23 at 4.11.30 AM.png

6 hours ago, JimN said:

trying to complete this lesson and I get a different problem.  When dragging the Groovy Guitar.wav file into my project, the tempo adapts again and changes to 100, which throws everything off.  I cannot seem to fix this.

In the first exercice in Lesson 9, step 11, you should be setting the Smart Tempo mode back to KEEP, which should prevent that from happening. 

Link to comment
Share on other sites

Thanks David, I've played around with it a bit more, and while I did get the tempo to keep at 62, the guitar is still completely out of sync with the bass and drums.  I followed the advice you give above about deleting the extra flex markers, which did allow me to drag the region to 1 1 1 1 but the it's still a complete mess.  I end up with a 6 3/4 bar guitar region that is just not synced to the bass and drums. 

Screenshot of what I end up with:

image.thumb.png.9625a104aab041cac7b3f004e565a3c1.png  

Link to comment
Share on other sites

6 hours ago, David Nahmani said:

Apparently you've transposed your region by 2 semitones up? (I see +2 appended to the region name)

Yes, as per the lesson on pg 398 step 12.  I wanted to carry on with the lesson steps even though I could not get the tempo issue resolved.

  • Like 1
Link to comment
Share on other sites

Ok got it. 

Now I tried to perform the exercise in 10.7.7 and you're right, Logic does not play nice with that groovy guitar file. First of all, very sorry about that: it's frustrating that each new subversion of Logic changes slightly the way it interprets the audio file and thus makes the exercise no longer perform as it's described in my book. 

However let's look on the bright side: that's an opportunity to learn something more. Here what happens is that Logic think the audio file starts on beat 2, and places the downbeat on the 4th beat in the file (instead of the 5th beat in the file as it should. 

Let's fix that: 

  1. After importing Groovy Guitar.wav and deleting the Flex markers, press E to open the editors and at the top of the Editor pane, click Smart Tempo to open the Smart Tempo editor. 
  2. Click on the waveform on beat 2 of bar 2, beat 2 of bar 3 etc... to add downbeat hint markers (telling Logic those are the actual downbeats). 
  3. Click Apply Changes. 

Now the file should play in tempo? 

Let me know how that works for you. 

gain-adjust.gif

Link to comment
Share on other sites

David, thanks again.  I will come back to this later but I'm sure it will work now with your extended hands-on help here.  At first glance it appears to have worked, yes.

I just wanted to reply quickly to say that it is great to have this forum and you active here to reply to questions we have along the way.  I really appreciate it and I'm really glad I chose your book!

Speaking of which, are there any other books you'd recommend to accompany yours?  I feel like the User Guide along with your book might be enough.  There are a handful of other books I've considered but I'm not sure which, if any, might be a good addition to my library and compliment to yours.

  • Like 1
Link to comment
Share on other sites

Thanks for your kind words Jim! I really aim this website to be the best resource for Logic users looking for help figuring out the software so that they can be creative with it rather than frustrated with technical issues. I am basically building what I wish I had had back when I got started myself. 

I don't know other books about Logic so I couldn't recommend another one, but I really think that if you go through my book and then start being creative, doing what it is that you love doing the most in Logic, whether it's classical music, dance music, blues or rock or whatever, then you're on the path to success. Questions are likely to arise at nearly every turn, and that's what the "Logic Pro" forum is for, any questions you may have, just ask, and we'll be happy to help out. 🙂 

  • Like 2
Link to comment
Share on other sites

edit: I stumbled upon the cause being the size/zoom level of the region display, apparently flex markers disappear at a certain size threshold.

Going through Lesson 9 (still), when I get to the time-stretching example on pg 415, step 4, I do not get the flex markers when clicking the Track Flex button. See screenshot showing that the button is enabled/active but no flex markers on the track.  Maddening

image.thumb.png.b2dcb83abe1c07650e4896a8257757c2.png

Edited by JimN
found solution
  • Like 1
Link to comment
Share on other sites

  • 4 months later...

I too am glad I searched for this topic! I had tried jiggering with this exercise for some time before I searched this community. The Big Lesson for me: If something is not working the way I expect, look for online help early in the debugging process. 

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...