Jump to content

No connection between Logic Remote and Logic Pro


Patrick Beham
Go to solution Solved by elude,

Recommended Posts

Could you post a screen capture of your Control Surface Setup window while trying to connect with Logic Remote. If the Logic Remote icon is already showing up in there, have it selected so we could read the related inspector information…

Link to comment
Share on other sites

I don't think it's the Ipad, because Logic Remote behaves the same on my Iphone and an older Ipad. I see the problem more on the Mac, and very likely directly with Logic (see above).
The fact that the setup settings look different is probably because Logic doesn't connect to the IOS device at all. The picture shows the template for IOS devices from the setup that I had installed on a trial basis.
My AKAI keyboard, for example, is being recognized automatically by the setup. A separate installation from the device menu in the setup is not necessary.

On the question of whether I can change the settings: Not the device settings, the CS-Group as in your setup.

Link to comment
Share on other sites

On 2/11/2023 at 8:18 AM, Patrick Beham said:

On the question of whether I can change the settings: Not the device settings, the CS-Group as in your setup.

I think it relates to the relatives icon position inside of the Cintrol Setup window…

BTW, what macOS is running on your Mac?

Link to comment
Share on other sites

 

My version is the current one, 10.7.7

The icon position does not, as far as I can tell, change the behavior regarding Logic Remote. 
My suspicion remains that something is fundamentally wrong, or that something has fundamentally changed Pro. I have not used Logic Remote permanently, but when I  used it, it has connected without problems. I never had to deal with the setup menu - until now.

 

Link to comment
Share on other sites

  • 2 weeks later...

 

I recently had a conversation with a colleague who pointed out that in previous Logic Pro versions, control via Logic Remote could be "allowed" in the project settings. 
Currently this is no longer necessary, but maybe this could be related to the connection difficulties?
Another possibility occurred to me, which I had not tested yet. I connected my Macbook to the Ipad via USB and cut all network connections at the same time. The result, however, was unchanged. Logic Remote recognized Logic Pro, but would not connect.

 

Link to comment
Share on other sites

My permission status to file described above is read and write.

I contacted Apple support again in the meantime. As a result I removed all 3rd party plugins and finally reinstalled Logic Pro completely. This did not result in any change regarding Logic Remote.
The last suggestion of the support was to reinstall the operating system completely, but here I still hesitate.

To your assumption that another program could influence: 
Surely this is a possibility, but I'm afraid I don't know enough mac-specifically for this. Support has not come up with anything on this question.
 

 

Link to comment
Share on other sites

On 2/14/2023 at 11:39 AM, Patrick Beham said:

My MacOs Version is Ventura 13.0.1

Not 13.2.1 ? Maybe you have reasons for not updating? 

3 hours ago, Patrick Beham said:

Sorry, I'm not sure about that. What do you mean by "AMS"?

 

Audio Midi Setup?

...Under "Utilities" in Applications Folder, 

Not sure why that would solve any communication between the iPad and Logic Pro..

How about updating the iPad to the latest iOS version? I've done it, works great

 

Edited by onewave
Link to comment
Share on other sites

Thank you for your suggestions.
I have now been to the AMS. An additional device is not recognizable. In the Bluetooth and WLAN setup, my IOS devices appear from time to time, but I can't seem to operate active changes regarding Logic Pro.
@onewave: I have already tried all your other suggestions, thanks anyway.

  • Like 1
Link to comment
Share on other sites

I am having the exact same problem and tried all suggestions listed too.

I’m starting to believe this may be a Logic/Logic Remote problem. 

Hopefully things are sorted in the next update. 

Running on a 13in 2018 MBP with Ventura 13.2.1. Fully updated ipad air 4 and iphone 12 pro. Logic 10.7.7. 

 

 

Link to comment
Share on other sites

10 minutes ago, chi said:

I’m starting to believe this may be a Logic/Logic Remote problem. 

Hopefully things are sorted in the next update. 

I'm using Logic Pro 10.7.7 and Logic Remote 1.5.3 like @Patrick Beham and have no problem connecting Logic Remote to Logic Pro here so there must be another factor at play here, that we have yet to determine. 

Link to comment
Share on other sites

  • 3 weeks later...
  • Solution
David Nahmani
This post was recognized by David Nahmani!

"Thanks so much elude for sharing that information with us!"

elude was awarded the badge 'Helpful' and 30 points.

This should solve the Problem for some:

Open up the Terminal and run:

sudo /usr/libexEC/ApplicationFirewall/socketfilterfw --unblockapp /Applications/Logic\ Pro\ X.app

This will enable incoming connections for Logic Pro. Up to the newest Version of MacOS (13.3) there seems to be a bug in the GUI of the Firewall-Settings leading to changes never beeing made even though graphically it looks they are.

  • Like 3
  • Wow! 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...