Jump to content

Logic Pro X keeps Quitting Unexpectedly


Recommended Posts

I updated my MacBook Pro 2009 with a 1TB SSD and maxed the Ram to 8gb and used Time Machine to back up and reinstall everything. Though it’s stuck on El Capitan. But that never effected it before and I can’t update Logic X anyway. SoI booted Logic x and all the sudden it came up with this AU Validation Tool and scanned all my plug ins and found 5 plug ins that couldn’t be read. I tried updating those plug ins, but it didn’t work. I tried rescanning and resetting the AU Validator, but I kept getting an error message, so I unchecked the plug ins it couldn’t read, thinking that would by pass them, but as soon as I pressed continue and it tried to boot my project, Logic Pro X quit unexpectedly and now that’s all it’s doing. I can’t open up any projects with out it quitting unexpectedly and all I can do is try again or send a report to Apple or cancel and I already sent a report to Apple which does nothing. It just keeps quitting unexpectedly no matter what I do.when I clicked the question mark it gave me a list of things to possibly do, which I’ve done most of them. But I can’t seem to find my plug ins in my library when it says to go to finder then go folders and type in ~libraries/folders/plug-ins/compartments, but that goes to an empty folder. So I don’t know what to do to get my logic working again and I have 3 days to finish my music technology homework for Los Angeles Community College with no way to do it unless I can figure out what’s up and fix it. Any logic experts out there, I would extremely appreciate your assistance, I would be grateful beyond words! I’ve included the message I got when it said quit unexpectedly and had the little question mark in the corner saying possible routes I could go, but I’ve hit a wall with it. Any advice helps please, thank you!🙏[quit unexpectedly message and question mark options](https://share.icloud.com/photos/032jTb0O4dBlVMTbVmM0NGCrQ)

Link to comment
Share on other sites

Bit of a wild guess but have you tried deleting the plugin cache? You can try, if it doesn't work it won't break anything either...

First, make sure to close Logic Pro

In the Finder, choose Go > Go to Folder from the menu.


Type ~/Library/Caches in the "Go to the folder" field.

Press the "Go" button

Make sure once inside this folder to delete the "com.apple.audiounits.cache" file.

Make sure to also delete the "com.apple.audiounits.sandboxed.cache" file as well.


1 hour ago, Popproxxx said:


that should be "components" instead of compartments...

Link to comment
Share on other sites

... and actually I think the paths should be:




... where the first is the general location and the second the location for components for current user. 

Note "Library" instead of "libraries" and "Components" instead of "compartments".


Edited by monotom
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...