Jump to content

Snapping to grid in flex mode doesn't work

Go to solution Solved by David Nahmani,

Recommended Posts


I've had this issue since I switched from Logic Pro 9 to X. When in flex mode I can't snap to grid within the audio file, dragging the end works fine (changing the speed of the whole sample) but eg if I want to drag a snare to the exact beat it just doesn't stick and end up in the wrong place.

I've looked around quite a bit and found some people with the same issue but no fix has worked for me yet, I've tried all the different settings recommended (and all other Flex/Snap settings as well for that matter).

It does work sometimes (25% of the time give or take) and when it does I have the same settings as usual and work the same way. Yesterday I worked on a project and was very happy that it did work at first, I took a whole song recorded without BPM and dragged every bar one at a time to the exact position without problems. Without shutting down the project I took a pause after a while and just closed my screen. Later I kept working on it and added a different audio file (same source as the others I added before) and then when I tried to drag the snares to the exact position it didn't work all of a sudden... Since it worked earlier I tried out of curiosity to reset the flex edits I had done in the first file and tried to redo them (to see if the problem was related to the files/tracks themselves or not) but now the problem occurred with that file as well! So the issue isn't related to settings it seems.

One thing I know I did somewhere in between the time it worked and the time it didn't is I pressed a random number to change the view since I had zoomed in very much for another reason, I don't know if that's relevant but other than that I just added and cut up files so I'm very puzzled why it worked at first and then didn't. I tried reentering the view I had when it worked by pressing 1 but it still didn't work and restarting Logic didn't either.

Any help, ideas or thoughts are very appreciated! Thanks a lot in advance 

Edited by EternalMoving
Link to comment
Share on other sites

  • EternalMoving changed the title to Snapping to grid in flex mode doesn't work

Hmm seems like no one has a clue about this.. I read something about a bug in some version that may've been related to this issue, does that ring a bell to anyone? If that's the case it's kinda strange that it works from time to time though

Link to comment
Share on other sites

1 hour ago, Atlas007 said:

Have you checked the snap to zero crossing feature? Try disabling same if enabled…

Thanks for your reply, it's not checked - I only have "Snap to grid" > "Smart" active. I tried checking it but didn't notice any difference. I don't notice any difference between "snap regions to absolute value" and "snap regions to relative value" but it's set to absolute.

It's just like "Snap to grid" isn't active when dragging within the sample even though it is, it works perfectly when I drag the whole sample though


Link to comment
Share on other sites

  • Solution

It works as expected here. Note that the snapping depends on your zoom level, so sometimes it's easier to snap where you want to if you zoom out a bit. Also when "Smart" (which depends on the zoom level) is failing you, try to set your Snap mode to "Beat" or "Division" and you should see consistent results. 

There are key commands to adjust your Snap mode from Smart to Beat to Division etc, however you have to program them yourself. If you're not using Nudge key commands then I suggest you steal the keyboard combination from the Nudge key commands and assign them to Snap instead, like this: 

  • Control-Option-B = Snap Mode: Beat
  • Control-Option-D = Snap Mode: Division
  • Control-Option-S = Snap Mode: Smart
  • Control-Option-O = Snap Mode: Off

Also make sure your project start is set to 1 1 1 1 or the flex markers don't snap in the right position. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...