Jump to content

record arm exclusive?


apricotandpearjam
Go to solution Solved by scg,

Recommended Posts

You should be able to configure track arming however you want/need. If a track is armed that you don't want armed, you should be able to disarm it.

Selecting multiple tracks or using groups can sometimes cause some confusion with things like this (although I don't get the immediate impression that's a factor here).

If you continue to have problems with it, maybe share your Logic version and whether you're recording MIDI or audio, and post a screenshot or video and/or describe in more detail what's happening.

Link to comment
Share on other sites

10 minutes ago, apricotandpearjam said:

what i’m asking is if there is a setting to automatically disarm all other tracks when selecting a new track

I see. The details are a little fiddly, so I won't attempt to summarize them here (I'm also not entirely sure the documentation describes the current behavior correctly or fully). However, I'll offer the following. Typically focusing a track exclusive-arms it, unless (based on my understanding and empirical observation at least) you've armed it via direct interaction with the record button, in which case tracks will/may stay armed even when not focused.

So here's something you might try. For each track of interest, make sure it's not focused, then disarm it if needed by making sure the record button is off (gray with white R for me). After that, as long as you don't interact with the record buttons directly, focusing a track should exclusive-arm it. I probably haven't covered every possible circumstance here, but certainly exclusive arm is possible and normal, and is how it works for me at almost all times when working in Logic (unless I specifically want to record to multiple tracks at once).

Link to comment
Share on other sites

3 hours ago, apricotandpearjam said:

hi. does anyone know if its possible to only have one track record armed?

at the moment when i go to a new track the previous track i was on stays record armed and its causing issues recording over parts.

cheers 🙂

If you never manually record arm any track it should work like you want it to (the focused track - i.e. the one with the highlighted track number - will be automatically armed when you start recording).

  • Like 1
Link to comment
Share on other sites

thanks guys.

the issue im having is that when i click on a new midi track the previous midi track i was on stays record armed.

ideally id like to have a preference which means that only one track can be record armed at once but i dont think its currently possible.

thanks for all your help and suggestions 🙂

Link to comment
Share on other sites

54 minutes ago, apricotandpearjam said:

the issue im having is that when i click on a new midi track the previous midi track i was on stays record armed.

Can you overcome that using the suggestions in this thread? Unless there's a bug or other issue, I don't think you should be stuck with that behavior. (One way to test this would be to try it in a new, empty project without interacting directly with the record buttons at all. In that case you should get the behavior you want. If you don't, there may be something else going on.)

Link to comment
Share on other sites

3 minutes ago, apricotandpearjam said:

it happens a lot for me so maybe there’s a bug?

Perhaps 🙁 If you're seeing the behavior in a new, empty project, with no direct interaction with the 'record arm' buttons, then I don't have an immediate explanation for that.

Link to comment
Share on other sites

As suggested by @scg reboot Logic and start with a fresh new project, not using an existing template. Selecting different tracks, by clicking on the track header, one after the other should make the last selected track the only one to be record-enabled, providing that all those tracks are each assigned to a discrete channelstrip and aren’t grouped

BTW, which Logic (precise) version are you using?

  • Like 1
Link to comment
Share on other sites

9 minutes ago, David Nahmani said:

It happens if you click the R button of a track to R-enable it, then select another track. 

In that case its intended behaviour, not a bug. A manually rec-enabled track should not be rec-disabled just by focusing another track. Also see my first response in this thread. But I guess that case is not what we're talking about here?

Edited by polanoid
Link to comment
Share on other sites

hi all. thanks so much for all of this.

sorry ive been out of the game for a few days with the kids 😉

it feels like its a bug because its only happening in very large sessions.

ill take a screen recording next time it happens but in the meantime the 'record off for all' key command is going to be very useful.

 

Link to comment
Share on other sites

  • 2 weeks later...
  • Solution

It looks like at the beginning of your screen recording, a track is already manually armed. The screen recording is a little hard to follow, but it looks like only at the end do you no longer have any tracks manually armed, and I'm not sure if you try to select any other tracks after that.

In any case, when I make sure no tracks are manually armed, I get the desired behavior. Have you tested that? If not, can you test it?

Link to comment
Share on other sites

7 minutes ago, apricotandpearjam said:

yep you're right, thankyou!

is this new behaviour as ive never noticed this.

so manually arming a track stays armed even if you select a new track?

Yes, since 10.7.5. I wish there were an option for this as it impedes my workflow. I can see why this could be helpful, but for me it is a PITA.

Link to comment
Share on other sites

28 minutes ago, polanoid said:

yes. you switch something on, it stays on until you switch it off. why would focusing (not selecting) a track do that for you?

I don't exactly, I have one of my controllers setup to be a Mackie/Logic control surface, which allows me to select a specific track rather than just scrolling through them to get to the one I want. When I do this it now arms that track and that stays armed unless I manually turn it off, which is inconvenient when I want to go to a different track, which I do quite often. The 'record off for all tracks' trick works but I hate hate hate having to hit another command just to get to the track that I want. First world problem, I know, but as we all know having a good flow is important to creativity and this interrupts my flow, especially after working on Logic for almost 20 years in a certain way. 

My Main Page ends up having soooooo many tracks because of the way that I write so I really need to be able to bank up/down through it, and there isn't any other way to do this that I'm aware of besides using a 3rd party control surface. I will never understand why there isn't a built in keyboard command for going down through banks of tracks. (I want to reach for my trackpad as little as possible and rely on keycommds/shortcuts very heavily)

So far my solution is sticking with 10.7.4. This could be solved if they just had a preference for whether or not a track stays armed after selecting a different track. If there is one that I don't know about I will be fantastically thrilled to be wrong. 

Link to comment
Share on other sites

8 minutes ago, redgreenblue said:

When I do this it now arms that track

I guess it shouldn't do that, IMO that's a bug (because, as far as I understand you, it not only puts the track in focus - again, not select it - it also record arms it, which is different from when you focus the track by clicking into the track header with the mouse).

Edited by polanoid
Link to comment
Share on other sites

11 hours ago, polanoid said:

I guess it shouldn't do that, IMO that's a bug (because, as far as I understand you, it not only puts the track in focus - again, not select it - it also record arms it, which is different from when you focus the track by clicking into the track header with the mouse).

exactly. i don't see the use of it tbh. it must be a bug

13 hours ago, redgreenblue said:

Yes, since 10.7.5. I wish there were an option for this as it impedes my workflow. I can see why this could be helpful, but for me it is a PITA.

what benefit do you see with this being a feature, just out of curiosity?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...