Jump to content

Tempo recording (rubato) doesn't work since 10.7.7


Jonas W
Go to solution Solved by polanoid,

Recommended Posts

I compose and record a lot of piano / orchestral classical style music. To be able to change tempo afterwards is essential to my workflow. The way I do it is to set up a tempo-fader in environment (between input and sequencer) and make sure "allow tempo recording" is on in the project recording settings. This usually worked before. But since 10.7.7 came it doesn't work anymore. Is there some other trick to do or is this functionality gone? Can someone confirm it still works (if that's the case maybe its something in my setup that hinders it)

Link to comment
Share on other sites

 

#oscwilde: The thing I want is to record changes on tempo after I have recorded my music. But its good to know what those modes mean. I never change that setting.

#polanoid: Thank you for the excellent thread about this. The thing I didn't need to do before (of what I know) is to setting up an external midi track to record the cc-changes of the environment tempo-controller. I wasn't aware this was a requirement. I will try this evening and mark as solved if it works!

 

Edited by Jonas W
  • Like 1
Link to comment
Share on other sites

Thanks, I got it working now.

The clue was that the thread talked about using an external midi-controller, pitchbend or the like. Before I just moved the tempo-fader with the mouse but for some reason that doesn't work anymore. Using the pitch wheel or cc1 mod wheel worked! Might be good to know for someone that  try to record tempo changes directly with the fader.

  • Like 2
Link to comment
Share on other sites

In order to record tempo changes (ranging between 50 to 177BPM) in the Global Tempo track, to sum up:

  1. In the Environment create and connect a Tempo Fader object between the Physical Input object and the Sequencer Input object.
  2. Use the MIDI data (either CC or pitchbend emitting device) to remotely actuate that Tempo Fader object.
  3. Enable Allow Tempo change recording in the Project Recording Settings.
  4. Set the project's Smart Tempo mode to Keep tempo in the LCD (or in the Smart Tempo Project Settings.
  5. Start recording on a MIDI track then actuate the emitting MIDI device (to remotely move the Tempo Fader object's slider. This will record the MIDI data and the tempo Meta events in the region of that track.
  6. Once the recording stops, the Meta (#100) events are automatically applied (moved) to the Tempo Global Track (also visible in the Tempo List editor).

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...