Jump to content

How do you disable record on ALL tracks


Amazingly Andrew

Recommended Posts

This is driving me nuts. 

I have say, 40 tracks. They don't all fit on the screen at once. So I will start recording on a track not realizing that another track on the other end of the session was already record-enabled from 10 minutes ago, so now I'm erasing that track unwittingly. Then I have to try to recover the lost tracks. It's a frustrating waste of time.

I just want to make it so that when I'm done recording on a track, I can disable record, and when I go and enable a different track somewhere else, I know that it will be the only track that is record enabled. If this isn't possible, I think I will just switch back to Pro Tools--I can't take it anymore! 😉 

Link to comment
Share on other sites

f

2 hours ago, Jordi Torres said:

Hi Andrew,

You can always invoke the "Record Off for all" command (look for it in the Key Commands window) in case you forget to record-disable any tracks you previously recorded on.

If you have a MIDI controller at hand you could also try this approach:

J.

That is good to know, however it does not solve my problem. Even if a track isn't record-enabled, if it is the selected track (and therefore has a red R) it will go ahead and record anyway, even if I have used the "Record off for all" keyboard command. 

Do you know how I can turn off this "feature" where the selected track will always record even if you haven't record enabled it? (i.e., get rid of that pesky red R)

Link to comment
Share on other sites

Hi Andrew,

 

19 minutes ago, Amazingly Andrew said:

Even if a track isn't record-enabled, if it is the selected track (and therefore has a red R) it will go ahead and record anyway

 

Simply manually click on the R button of the track you actually want to record to and the pesky red R on other selected tracks will turn off.

J.

 

 

 

Link to comment
Share on other sites

4 minutes ago, Jordi Torres said:

Hi Andrew,

Simply manually click on the R button of the track you actually want to record to and the pesky red R on other selected tracks will turn off.

J.

Hi J.,

See video below--I can record enable/disable other tracks all day and the pesky red R stays put. Do you know of a preference I can change so that the red R is no longer a thing?

Thanks for your help!

Andrew

Link to comment
Share on other sites

4 minutes ago, Jordi Torres said:

Thanks for the video Andrew.

Here's how it is for me in Logic 10.7.8:

PeskyR.gif.e7999fa1b3601664fbbd6c7ece6afe8b.gif

In Logic 10.7.7 the red R remains but nothing gets recorded on the selected track if the others have been manually rec-enabled:

PeskyR_10.7.7.gif.222bbc513364ee77749b6e405876202e.gif

What version of Logic and macOS are you running?

J.

Interesting! That's what I want! I have 10.7.4 on Monterey.

Link to comment
Share on other sites

1 hour ago, Amazingly Andrew said:

Interesting! That's what I want! I have 10.7.4 on Monterey.

Here's on that same setup:

PeskyR_10.7.4.thumb.gif.4a9101ee205906e5304eb4b79e448339.gif

Maybe be try resetting your preferences? Logic Pro menu > Preferences > Reset All Preferences Except Key Commands...

If that doesn't do it then quit Logic and move its preferences file to the desktop, then launch Logic again:

/Users/your username/Library/Preferences/com.apple.logic10.plist

J. 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...