Jump to content

Kontakt instruments not showing in Logic but are in GarageBand


ChrisWimlett
Go to solution Solved by des99,

Recommended Posts

I've hit a problem with Kontakt in Logic, that I think only appeared with a recent update (I've not used Kontakt in recent projects).

If I try to load an instrument, the library icons are displayed but no instruments are listed when I select the down arrow - see screenshot 1.  Everything works fine in GarageBand - see screenshot 2.  Standalone and Cubase 12 are also fine.

The Kontakt library is held on an external drive and I've tried both full Kontakt 6 and the Kontakt 7 Player with the same result.  I've checked file locations, Kontakt library settings, etc.  Can anyone help please?

I'm using a Mac Mini M2 Pro running Ventura 13.4

Screenshot 2023-06-11 at 12.25.46.png

Screenshot 2023-06-11 at 12.24.34.png

Link to comment
Share on other sites

Hi Chris,

3 hours ago, ChrisWimlett said:

but no instruments are listed when I select the down arrow - see screenshot 1.  Everything works fine in GarageBand - see screenshot 2.  Standalone and Cubase 12 are also fine.

I find it very strange that you would get this behavior only when loading Kontakt in Logic as Logic has no say of where Kontakt goes look for its libraries.

Maybe give this article by Spitfire a try?

Kontakt Library says "Browse", not "Instruments".

J. 

  • Like 2
Link to comment
Share on other sites

3 hours ago, des99 said:

Does Logic have full disk access? I'm wondering perhaps if it doesn't have permission to read some necessary NI preferences etc...

That did it thanks!  Granting access to Logic fixed the problem.  Still a bit puzzling as GarageBand and Cubase don’t have full disk access, but I’m not going to worry too much about that now Logic is working.

Thanks all for the help.

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...